使用螢幕助讀程式匯出 Access 資料表至 Excel 活頁簿

使用螢幕助讀程式匯出 Access 資料表至 Excel 活頁簿

含有螢幕助讀程式內容標籤的大聲朗讀符號。 本主題是關於如何在 Office 中使用螢幕助讀程式

本文為 Office 協助工具內容集的一部分,適用於搭配螢幕助讀程式使用 Office 產品的視力障礙使用者。 如需更多一般說明,請參閱 Microsoft 支援首頁

使用 Access 鍵盤和螢幕閱讀程式,將資料匯出為 Excel 的檔案格式。 我們已使用朗讀程式、JAWS 和 NVDA 加以測試,但是只要遵循常見的協助工具標準和技巧,就可以與其他螢幕助讀程式搭配使用。 您將瞭解如何使用匯出精靈將資料匯出,例如資料表、查詢、表單、報表或多重記錄視圖中的選取記錄,例如資料表 Excel 檔案。

附註: 

本主題內容

準備資料以匯出

匯出資料之前,請花一點時間查看資料,並決定匯出資料。

  • 請確定資料不含任何錯誤標記或錯誤值。 否則,匯出期間可能會發生問題,而 Null 值可能會插入到工作表 Excel 儲存格中。 若要疑難排解資訊,請前往疑 難解答匯出資料至 Excel> 一

  • 決定是否要匯出包含或不含其格式的表格或查詢。 此決定會影響匯出的資料量,以及資料的顯示格式。 若要取得匯出格式化和未格式化資料的結果詳細資訊,請前往準備將資料匯出至Excel。

  • 選擇目的活頁簿和檔案格式。 如果您將具有格式的表格、查詢、表單或報表匯出至現有的活頁簿,將會覆蓋該活頁簿。

    附註: 報表只能以較舊的 *.xls檔案格式匯出,不能以較新的 *.xlsx檔案格式匯出。

匯出資料

在匯出含有子表單、子報表或子資料工作表的表單、報表或資料工作表時,只會匯出主表單、主報表或主資料工作表。 您必須針對要匯出至表單的每個子表單、子報表和子資料工作表重複匯出 Excel。

一次匯出作業只能匯出一個資料庫物件。 不過,您可以在完成個別匯出作業 Excel 合併多個工作表。

如果您沒有準備好的活頁簿,它會在匯出期間建立。 資料一直新加到新的工作表中。

Access 目前不支援將宏或模組匯出至 Excel。

  1. 如果您有目的地 Excel ,請關閉它。

  2. 流覽至來源資料庫,然後選取要匯出的物件。

    如果物件是資料表、查詢或表單,而您只想匯出部分資料,請在資料 視圖中開啟該物件,然後選取您想要的記錄。 若要獲得指示,請前往 在資料表視圖中開啟物件

    附註: 無法匯出報表的一部分。 不過,您可以選取或開啟報表所根據的資料表或查詢,然後匯出該物件中的部分資料。

  3. 若要開始匯出匯出 Excel 精靈,請按 Alt+X,X。[匯出 - Excel試算表對話方塊隨即開啟。

  4. 請執行下列其中一個操作:

    • 如果您想要在匯出期間建立新試算表,請按 Alt+F,將焦點移至 [ 檔案名文字 欄位。 Access 將來源物件的名稱建議為匯出檔案的檔案名。 若要變更名稱,請刪除建議的名稱,然後輸入新名稱。

    • 如果您有要匯出 Excel 的現有檔案,請按 Alt+R 以開啟 [儲存檔案> 對話方塊,然後流覽您想要的檔案。 當您在檔案上時,請按 Enter 以選取檔案。 對話方塊會關閉,且焦點會回到 [匯出 - Excel試算表對話方塊

  5. 按 Alt+T,將焦點移至 [檔案格式清單 。 您聽見目前的格式。 若要選取您想要的檔案格式,請按空格鍵以展開清單,然後按向上鍵或向下鍵,直到您聽見想要的格式,然後按 Enter 以選取它。

  6. 如果您要匯出資料表或查詢,而且想要匯出格式化的資料,請按 Alt+W 移至,然後選取 [匯出格式及版面配置的資料選項。

    附註: 如果您要匯出表單或報表,此選項預設會選取,而且無法取消選取。

  7. 如果您想要在匯出 Excel 自動開啟目的活頁簿,請按 Alt+A 移至,然後選取 [匯出作業完成之後開啟目的地檔案>選項。

  8. 如果來源物件已開啟,而且您先在視圖中選取一或多個記錄,然後再開始匯出,而這些是您想要匯出的記錄,請按 Alt+S 移至,然後選取 [只匯出選取的記錄> 選項。 如果您想要匯出在視圖中顯示的所有記錄,請勿選取此選項。

    附註: 如果未選取任何記錄,則此選項將不可用。

  9. 若要開始匯出,請按 Tab 鍵,直到您到達 確定按鈕, 然後按 Enter。

  10. 如果匯出成功, Access 提示您儲存匯出步驟,以在沒有匯出精靈的情況下快速重複這些步驟。 若要選取此選項,請按 Alt+V。 若要命名檔案,請按 Alt+A,然後輸入檔案名。 若要儲存步驟檔案,請按 Alt+S。

    如果匯出失敗是因為錯誤, Access 會顯示描述錯誤原因的訊息。

    如果您選取了自動開啟 Excel ,請按 Alt+Tab,直到您聽見該活頁簿的名稱,然後查看其內容。

在資料工作表視圖中開啟物件

如果您要匯出的物件是資料表、查詢或表單,而您只想匯出部分資料,則需要在資料表視圖中開啟該物件,以選取您想要的記錄。

  1. 流覽至流覽樹狀結構中的物件。

  2. 在物件上時,按 Shift+F10 以開啟操作功能表。

  3. 在功能表中按 Tab 鍵,直到您到達資料 表視圖 選項,然後按 Enter 以選取該選項。 物件會在資料表 視圖中開啟

    如果 無法使用資料表 視圖選項,您必須啟用物件的視圖。 若要獲得指示,請前往 啟用物件的資料表視圖

為物件啟用資料表視圖

  1. 在流覽樹的物件上時,按 Shift+F10 以開啟操作功能表。

  2. 在功能表中,按 D 以開啟設計 視圖

  3. 在設計 視圖中,按 F4 以開啟 屬性工作表 窗格。

  4. 按 F6 一次。 焦點會移至屬性工作表窗格中 的屬性列 。 您聽見列號,後面接著屬性儲存格內容。

  5. 若要將焦點移至選取類型下拉式清單,請按 Shift+Tab,直到您聽見「整個欄位」,後面接著目前的值,以及「下拉式編輯」。 如果目前的值為 Form,您可以繼續進行下一個步驟。 否則,請按 Alt+向下鍵以展開清單,然後按向上鍵或向下鍵,直到您聽見「表單」,然後按 Enter 以選取它。

  6. 在屬性 窗格中,按 Tab 鍵,直到您聽見目前選取的 Tab 專案,例如「資料標籤專案,已選取」。 如果目前的定位停駐點 是格式標籤 ,您可以繼續進行下一個步驟。 否則,請按向左鍵或向右鍵,直到您聽見:「格式化 Tab 專案」。 系統會顯示格式 選項卡 的屬性。

  7. 在 「 格式」 的選項卡上,按 Tab 鍵,直到您聽見:「列四、否、已轉換」。 焦點會位於允許 資料表 View 屬性上。 若要將屬性設為 [是,請按 Alt+向下鍵,然後按一次向上鍵,然後按 Enter 以選取新值。

  8. 若要關閉屬性 窗格,請按 F4。

  9. 若要在 [資料工作表視圖> 中開啟選取 的物件,請按Alt+J、D、W,然後按 H。

另請參閱

使用螢幕助讀程式在 Access 桌面資料庫中建立資料表

使用螢幕助讀程式在 Access 桌面資料庫建立查詢

使用螢幕助讀程式在 Access 桌面資料庫中建立表單

使用螢幕助讀程式匯出 Access 資料表至文字檔

Access 的鍵盤快速鍵

使用螢幕助讀程式探索和瀏覽 Access

針對身心障礙使用者提供的客戶技術支援

Microsoft 盡最大的努力為所有客戶提供最佳的體驗。 如果您是殘疾人士或有任何協助工具相關問題,請連絡 Microsoft 殘疾人士 Answer Desk 以取得技術協助。 殘疾人士 Answer Desk 支援小組受過許多常用輔助技術的訓練,並可提供英文、西班牙文、法文和美國手語的協助。 請移至 Microsoft 殘疾人士 Answer Desk 網站,了解您所在地區的連絡人詳細資料。

如果您是政府、商業或企業使用者,請連絡企業殘疾人士 Answer Desk

需要更多協助?

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

×