如果您的圖形包含資料,您可以執行資料庫 匯出精靈 ,以建立包含該資料的資料庫資料表。

資料庫匯出精靈與使用 [匯出至資料庫」 命令所到達的對話方塊之間的不同在於,您可以透過精靈選擇匯出圖層上的所有圖形。 如果您不需要根據圖層匯出,您可能會發現使用匯出至 資料庫 命令更為簡化。 

使用資料庫匯出精靈

  1. On the View tab > Add-Ons > Visio Extras > Database Export Wizard.

  2. 請遵循精靈頁面上的指示。

    提示: 

    • 清單中顯示之圖形資料的儲存格名稱前面有道 ,例如 Prop.Cost

    • 當您執行資料庫匯出 精靈來 匯出圖形資料時,精靈會與繪圖頁面一起儲存匯出相關資訊。 如果您變更圖形,並想要再次匯出資料,請以滑鼠右鍵按一下繪圖頁面,然後選擇 [資料庫匯出表格

使用匯出至資料庫命令

  1. On the View tab > Add-Ons > Visio Extras > Export to Database.

  2. 選取您想要使用的資料庫資料表。

    • 如果您將資料來源儲存在預設位置外的其他位置,請按一下 [流覽 以尋找檔案。

    • 若要建立新資料來源,請按一下 [建立。 請遵循 建立新資料來源精靈 。 按一下 [完成後,ODBC 設定> 對話方塊即會顯示。 您可以在那裡選取現有的資料庫或建立新資料庫。 稍後您將在資料庫中建立資料表。

      附註: 

      • 如果您用 Excel做為資料來源,您可以選取現有的活頁簿,但無法從精靈建立一個。

      • 如果您選擇一個Excel,請務必清除 [選取活頁簿> 對話方塊中的 [唯讀資料讀取>核取方塊。

  3. 如果您的資料庫支援擁有者,請在 [擁有者清單> 中,按一下擁有者名稱以篩選資料表擁有者清單。 資料庫資料表是使用您用來登入資料庫的名稱建立。

  4. 如果您的資料庫提供您多個資料庫的存取權,請在 [ 限定詞清單 上, 按一下您想要使用的資料庫。

    提示: 如果您使用的是 Access 或 Excel,此處會列出要匯出至之資料庫的名稱和位置。

  5. 在 [ 資料 表> 清單中,按一下您想要使用的資料庫資料表。 若要建立新資料表,請輸入資料表的名稱。

  6. 如果您想要變更從 ShapeSheet 儲存格匯出資料的方法,請執行下列其中一項操作:

    新增 ShapeSheet 儲存格至匯出清單

    1. 按一下 [新增]。

    2. 選取要匯出的 ShapeSheet 儲存格。

    3. 在評估 方塊中,針對儲存在資料庫欄位中的值選取資料類型。

    4. 選取要複製圖形資料的資料庫欄位。

    5. 指定資料庫欄位的資料庫資料類型、欄位長度和小數精確度。

    修改 ShapeSheet 儲存格中資料的匯出方法

    1. 選取儲存格名稱,然後按一下 [ 修改

    2. 變更資料的匯出方法。

    從匯出清單中刪除 ShapeSheet 儲存格

    選取儲存格名稱,然後按一下 [ 刪除

使用資料庫匯出精靈

  1. 在 [工具」功能表上,指向[附加元件」,指向 [Visio額外專案,然後按一下 [資料庫匯出精靈> 。

  2. 請遵循精靈頁面上的指示。

    提示: 

    • 清單中顯示之圖形資料的儲存格名稱前面有道 ,例如 Prop.Cost

    • 當您執行資料庫匯出 精靈來 匯出圖形資料時,精靈會與繪圖頁面一起儲存匯出相關資訊。 如果您變更圖形,並想要再次匯出資料,請以滑鼠右鍵按一下繪圖頁面,然後選擇 [資料庫匯出表格

使用匯出至資料庫命令

  1. 在 [工具」功能表上,指向[附加元件」,然後指向 [Visio額外專案,然後按一下 [匯出至資料庫> 。

  2. 選取您想要使用的資料庫資料表。

    • 如果您將資料來源儲存在預設位置外的其他位置,請按一下 [流覽 以尋找檔案。

    • 若要建立新資料來源,請按一下 [建立。 請遵循 建立新資料來源精靈 。 按一下 [完成後,ODBC 設定> 對話方塊即會顯示。 您可以在那裡選取現有的資料庫或建立新資料庫。 稍後您將在資料庫中建立資料表。

      附註: 

      • 如果您用 Microsoft Office Excel做為資料來源,您可以選取現有的活頁簿,但無法從精靈建立一個。

      • 如果您選擇一個Excel,請務必清除 [選取活頁簿> 對話方塊中的 [唯讀資料讀取>核取方塊。

  3. 如果您的資料庫支援擁有者,請在 [擁有者清單> 中,按一下擁有者名稱以篩選資料表擁有者清單。 資料庫資料表是使用您用來登入資料庫的名稱建立。

  4. 如果您的資料庫提供您多個資料庫的存取權,請在 [ 限定詞清單 上, 按一下您想要使用的資料庫。

    提示: 如果您使用 Access 或 Microsoft Office,Excel,資料匯出至的資料庫名稱和位置會列在此處。

  5. 在 [ 資料 表> 清單中,按一下您想要使用的資料庫資料表。 若要建立新資料表,請輸入資料表的名稱。

  6. 如果您想要變更從 ShapeSheet 儲存格匯出資料的方法,請執行下列其中一項操作:

    新增 ShapeSheet 儲存格至匯出清單

    1. 按一下 [新增]。

    2. 選取要匯出的 ShapeSheet 儲存格。

    3. 在評估 方塊中,針對儲存在資料庫欄位中的值選取資料類型。

    4. 選取要複製圖形資料的資料庫欄位。

    5. 指定資料庫欄位的資料庫資料類型、欄位長度和小數精確度。

    修改 ShapeSheet 儲存格中資料的匯出方法

    1. 選取儲存格名稱,然後按一下 [ 修改

    2. 變更資料的匯出方法。

    從匯出清單中刪除 ShapeSheet 儲存格

    選取儲存格名稱,然後按一下 [ 刪除

需要更多協助?

擴展您的技能
探索訓練
優先取得新功能
加入 Microsoft 測試人員

這項資訊有幫助嗎?

您對翻譯品質的滿意度為何?

會影響您使用體驗的因素為何?

是否還有其他的意見反應? (選填)

感謝您的意見反應!

×