在 Mac 版 Office 中建立、執行、編輯或刪除宏

若要節省您經常執行的工作的時間,您可以將這些工作的步驟錄製為巨集。 接著,當您想要執行其中一個記錄的工作時,您可以啟動宏來為您執行這些步驟。 

Word

在 Mac 版 Word 2016 中,您可以建立具有鍵盤快速鍵的宏、執行宏,以及刪除不再需要的宏。

  1. 按一下 [檢視] > [巨集] > [錄製巨集]

    在 [檢視] 索引標籤上,按一下 [巨集],然後再按一下 [錄製巨集] 以開始建立巨集。
  2. 輸入宏的名稱,或接受 Word 提供的預設值。

    在 [巨集] 名稱中輸入您的巨集名稱,或接受 Word 提供的一般名稱。
  3. 若要在您建立的任何新檔中使用此宏,請確認已在 [將宏儲存在] 清單中選取 [所有檔(標準) ]。

  4. 按一下 [鍵盤],將按鍵組合指派給您的宏。

    Word 顯示 [自訂鍵盤] 對話方塊。

  5. 在 [按新的鍵盤快速鍵] 方塊中輸入按鍵組合。

    在您按下按鍵組合之後,Word 會顯示指派給該組合的命令或巨集 (如果有的話)。

    當您按下按鍵組合時, Word 會顯示目前指派給該按鍵組合的命令或動作(如果有的話)。

  6. 如果您選擇的按鍵組合已獲指派,請將它從 [按新的鍵盤快速鍵] 方塊中刪除,然後選擇一個新的按鍵組合。

    在您找到未指派的按鍵組合之後,請移至下一個步驟。

    Word 會指出您按下的按鍵組合尚未指派命令或巨集。
  7. 若要在任何新檔中使用此鍵盤快速鍵,請確定已選取 [儲存在] 清單中的 [ normal.dotm]、[全域範本]。

    選取 Normal.dotm 讓巨集可以在您建立的新文件中使用。
  8. 按一下 [指定]

  9. 當您準備好錄製巨集時,請按一下[確定]

  10. 針對工作中的每個步驟按一下命令或按下按鍵。

    Word 記錄您的按一下和擊鍵,但不會記錄您使用滑鼠選取的文字。 若要在錄製巨集時選取文字,請使用鍵盤。

  11. 若要停止錄製,按一下 [檢視] > [巨集] > [停止錄製]

    按一下 [巨集] 功能表上的 [停止錄製] 以停止錄製巨集。

若要執行宏,請按下指派給它的鍵盤快速鍵,或從 [] 清單中執行宏。

  1. 按一下 [檢視] > [巨集] > [檢視巨集]

    按一下 [檢視巨集] 以檢視和編輯與目前文件關聯的巨集。
  2. 在 [宏名稱] 底下的清單中,選取您要執行的宏。

  3. 按一下 [執行]

    在 [巨集] 名稱下選取某個巨集之後,按一下 [執行] 來執行該巨集。

  1. 按一下 [檢視] > [巨集] > [檢視巨集]

    按一下 [檢視巨集] 以檢視和編輯與目前文件關聯的巨集。
  2. 確認 [] 所指定的位置包含您要刪除之宏的位置。

    選取您要從巨集清單中檢視巨集的位置。

    清單將會包含目前視窗中已開啟的檔,以及全域範本和 Word 命令。

  3. 在 [宏名稱] 底下,選取您要刪除的宏,然後按一下清單下方的減號。

    選取您要刪除的巨集,然後按一下清單下的減號。
  4. 當 Word 要求您確認要刪除宏時,請按一下[是]

Excel

在 Mac 版 Excel 2016 中,您可以建立具有鍵盤快速鍵的宏、執行宏,以及刪除不再需要的宏。

當錄製巨集時,巨集錄製會錄製所有需要巨集完成之動作所需的步驟。 這些步驟可包括輸入文字或數字、按一下功能區或功能表上的儲存格或命令、格式設定、選取儲存格、列或欄,以及拖曳滑鼠來選取試算表上的儲存格。

附註: 在功能區上的 [開發人員] 索引標籤上,您也可以使用錄製、建立及刪除宏的命令,以及其他高級功能。 如需有關使用 [開發人員] 索引標籤的詳細資訊,請參閱使用 [開發人員] 索引標籤來建立或刪除 Mac 版 Excel 2016 中的宏

  1. 選取 [工具] >> [錄製新]。

    選取 [工具],然後選取 [宏],然後 [錄製新宏]

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    輸入宏名稱、位置及快速鍵

  3. 若要建立宏的鍵盤快速鍵,請在Option + Cmd方塊中輸入一個字母。

  4. 從下拉式清單中選取宏的位置。

    儲存巨集

    按一下

    在您要建立宏的檔中

    [本活頁簿]

    在所有開啟的文件中

    [新增活頁簿]

    每當您使用 Excel 時即可使用

    [個人巨集活頁簿]

  5. 可選新增宏的描述。

  6. 當您準備好錄製時,請按一下[確定]

  7. 針對工作中的每個步驟按一下命令或按下按鍵。

  8. 若要停止錄製,請選取 [工具] >> [停止錄製]。 (此步驟不會錄製在您的宏中)。

    選取 [停止錄製]

若要執行宏,請按下指派給它的鍵盤快速鍵,或從 [] 對話方塊中執行宏。

  1. [檢視] 索引標籤上,按一下 [檢視巨集]

  2. 按一下快顯功能表中的 [],然後選取 [此活頁簿]。

  3. 從清單中選取您的巨集,然後按一下 [執行]

    Mac 版 Excel [巨集] 對話方塊

  1. 選取 [工具] >>

    選取 [宏],然後選取 [宏]。

  2. 選取要刪除的宏,然後按減號。

    選取 [宏名稱],然後選取 [減號]

  3. 隨即會出現一則確認訊息。 按一下 [是] 以確認刪除。

    確認刪除

您也可以從 [開發人員] 索引標籤刪除宏。

  1. [開發人員] 索引標籤上,按一下 [巨集]

  2. 在清單中,按一下要刪除的巨集,然後按一下刪除按鈕。

    選取巨集,然後按一下減號即可將其刪除

Word

若要自動化重複的工作,您可以在 Word 中快速建立巨集。 您也可以在 Microsoft Visual Basic for Applications 中使用 Visual Basic 編輯器來撰寫自己的巨集指令碼,或將巨集的全部或部分複製到新巨集。

錄製巨集時,會錄製完成您想要宏執行之動作所需的所有步驟。 不過,回到索引標籤以停止錄製的動作並不會包含在錄製的步驟中。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [錄製]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

  3. [將巨集儲存在] 快顯功能表上,執行下列其中一項操作:

    儲存巨集

    按一下

    在您正在建立巨集的文件中

    [[文件名稱] (文件)]

    在所有開啟的文件中

    [所有文件 (一般)]

  4. 按一下 [確定],然後執行要錄製的動作。

  5. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [停止]

您可以使用內建的 Visual Basic 編輯器建立巨集。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [編輯器]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 如果需要插入模組,請在 [Visual Basic 編輯器] 的 [插入] 功能表上,按一下 [模組]

  3. 在模組的程式碼視窗中,輸入或貼上要使用的巨集程式碼。

  4. 當您完成時,請在 [Word] 功能表上,按一下 [關閉並返回 Microsoft Word]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下您要執行的巨集,然後按一下 [執行]

若要編輯巨集,可使用 Visual Basic 編輯器。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要編輯的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 進行所需的變更。

  4. 當您完成時,請在 [Word] 功能表上,按一下 [關閉並返回 Microsoft Word]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要複製的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示: 若要複製整個巨集,請將 [Sub] 及 [End Sub] 這兩行包括在選取範圍中。

  4. 按一下 [編輯] 功能表上的 [複製]

  5. 在程式碼視窗的 [專案] 方塊中,按一下要放置程式碼的模組。

  6. 按一下 [編輯] 功能表上的 [貼上]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要刪除的巨集,然後按一下 [刪除]

PowerPoint

若要自動化重複的工作,您可以使用 Visual Basic for Applications,在 PowerPoint 中建立 巨集 。

您可以使用內建的 Visual Basic 編輯器建立巨集。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [編輯器]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 如果需要插入模組,請在 [Visual Basic 編輯器] 的 [插入] 功能表上,按一下 [模組]

  3. 在模組的程式碼視窗中,輸入或貼上要使用的巨集程式碼。

  4. 當您完成時,請在 [PowerPoint] 功能表上,按一下 [關閉並返回 Microsoft PowerPoint]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下您要執行的巨集,然後按一下 [執行]

若要編輯巨集,可使用 Visual Basic 編輯器。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要編輯的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 進行所需的變更。

  4. 當您完成時,請在 [PowerPoint] 功能表上,按一下 [關閉並返回 Microsoft PowerPoint]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要複製的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示: 若要複製整個巨集,請將 [Sub] 及 [End Sub] 這兩行包括在選取範圍中。

  4. 按一下 [編輯] 功能表上的 [複製]

  5. 在程式碼視窗的 [專案] 方塊中,按一下要放置程式碼的模組。

  6. 按一下 [編輯] 功能表上的 [貼上]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要刪除的巨集,然後按一下 [刪除]

Excel

若要自動化重複的工作,您可以在 Excel 中快速建立巨集。 您也可以在 Microsoft Visual Basic for Applications 中使用 Visual Basic 編輯器來撰寫您自己的巨集指令碼,或將巨集的全部或部分複製到新巨集。

完成您希望巨集執行的動作所需的所有步驟都會錄製下來。 不過,回到索引標籤以停止錄製的動作並不會包含在錄製的步驟中。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [錄製]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    提示: 若要建立巨集的鍵盤快速鍵,請在 [Option+Cmd+] 方塊中鍵入字母。

  3. [將巨集儲存在] 快顯功能表上,執行下列其中一項操作:

    儲存巨集

    按一下

    在您正在建立巨集的文件中

    [本活頁簿]

    在所有開啟的文件中

    [新增活頁簿]

    每當您使用 Excel 時即可使用

    [個人巨集活頁簿]

    [個人宏活頁簿] 位於 [使用者/ username路徑/library/application support 支援/Microsoft/Office/Excel]。

  4. 按一下 [確定],然後執行要錄製的動作。

  5. [開發人員] 索引標籤的 [Visual Basic] 下方,再按一下 [錄製]

您可以使用內建的 Visual Basic 編輯器建立巨集。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [編輯器]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 如果需要插入模組,請在 [Visual Basic 編輯器] 的 [插入] 功能表上,按一下 [模組]

  3. 在模組的程式碼視窗中,輸入或貼上要使用的巨集程式碼。

  4. 當您完成時,請在 [Excel] 功能表上,按一下 [關閉並返回 Microsoft Excel]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下您要執行的巨集,然後按一下 [執行]

    提示: 若要使用鍵盤快速鍵執行巨集,請按 OPTION + 命令 + 建立鍵盤快速鍵時所鍵入的字母。

若要編輯巨集,可使用 Visual Basic 編輯器。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要編輯的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 進行所需的變更。

  4. 當您完成時,請在 [Excel] 功能表上,按一下 [關閉並返回 Microsoft Excel]

完成此程序後,每當您開啟包含該巨集的活頁簿時,巨集就會執行。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [錄製]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. [巨集名稱] 方塊中,輸入 Auto_Open

  3. [將巨集儲存在] 快顯功能表上,執行下列其中一項操作:

    儲存巨集

    按一下

    在您正在建立巨集的文件中

    [本活頁簿]

    在所有開啟的文件中

    [新增活頁簿]

    每當您使用 Excel 時即可使用

    [個人巨集活頁簿]

  4. 按一下 [確定],然後執行要錄製的動作。

  5. [開發人員] 索引標籤的 [Visual Basic] 下方,再按一下 [錄製]

  6. 按一下 [檔案] 功能表上的 [另存新檔]

  7. [格式] 快顯功能表上,按一下[Excel 啟用巨集的活頁簿 (.xlsm)],然後按一下 [儲存]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要複製的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示: 若要複製整個巨集,請將 [Sub] 及 [End Sub] 這兩行包括在選取範圍中。

  4. 按一下 [編輯] 功能表上的 [複製]

  5. 在程式碼視窗的 [專案] 方塊中,按一下要放置程式碼的模組。

  6. 按一下 [編輯] 功能表上的 [貼上]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區右側,按一下 [ [動作] 快顯功能表 ],然後按一下 [功能區偏好設定]。

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要刪除的巨集,然後按一下 [刪除]

需要更多協助?

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與我們的其中一個 Office 支援專員連絡以深入了解您的意見。

×