解決或刪除重複的連絡人

如果您從多個來源輸入連絡人,或繼承了其他人的連絡人清單,您可能有重複的連絡人儲存在 Outlook。 當您從 iCloud 或 Gmail 等外部來源匯入新連絡人時,Outlook 會檢查重複專案,並讓您選擇是否要建立新連絡人記錄 (重複) 或合併重複的連絡人。 很抱歉,一旦連絡人資料夾中有重複的連絡人,就沒有任何自動化程式可以移除這些連絡人。 不過,您可以將所有連絡人匯出至檔案,然後將這些連絡人重新匯入檔案Outlook並充分利用內建的重複檢查功能。 如果您只有幾個重複的連絡人,您可以排序連絡人清單並手動刪除。

一次刪除一個重複的連絡人

  1. 按一下 [人員]

    選取連絡人圖示以查看您的連絡人。

  2. 在功能區上的 [目前視圖群組中,按一下 [視圖> 方塊的右下角,然後按一下 [電話。 這是掃描連絡人清單及查看重複專案最簡單的視圖。

    [常用] 索引標籤上的 [目前檢視] 群組

  3. 在連絡人清單中,按住 Ctrl 並按一下要刪除的每個連絡人。

    按住 CTRL 並按一下每個要刪除的連絡人。

  4. 當您選取所有重複專案後,請按DeleteCtrl+D。

使用匯出和匯進刪除大量重複的連絡人

如果您擁有大量重複的連絡人,一個一個刪除重複的連絡人可能相當冗長且耗時。 刪除大量重複連絡人最快的方法,就是將它們匯出至檔案,然後將這些連絡人匯入新資料夾。 若要利用您輸入程式Outlook重複的偵測功能,請使用下列步驟

  1. 按一下 [人員]

    選取連絡人圖示以查看您的連絡人。

  2. 以滑鼠右鍵按一下您目前的連絡人資料夾,然後選取 [ 新增資料夾> 。

    建立新連絡人資料夾。
  3. 為新資料夾命名,例如 Duplicates

  4. 按一下回到您的主要 [連絡人」 資料夾。

  5. Ctrl+A 以選取所有連絡人。

  6. 將連絡人拖放到 [重複專案資料夾>,或使用Ctrl+Shift+V開啟 [移至資料夾> 對話方塊,然後選取 [重複專案資料夾>。

    將連絡人移至另一個資料夾。
  7. 您的主要連絡人資料夾現在應該是空的。

  8. 選取 [檔案] > [開啟和匯出] > [匯入/匯出]

    附註: 在 Outlook 2010 中,選取 >開啟>跳到步驟 10。

    選取 匯入/匯出。
  9. 選取 匯出至檔案

  10. 選取逗號分隔值 (Windows) 。

  11. 選取在步驟 3 中建立之重複檔案夾。

    從重複檔案夾匯出。
  12. 將檔案儲存到您可以再次找到的位置。

  13. 按一下 [完成]。

將連絡人重新輸入Outlook

  1. 選取 [檔案] > [開啟和匯出] > [匯入/匯出]

    附註: 在 Outlook 2010 中,選取 >開啟>跳至步驟 3。

    選取 匯入/匯出。
  2. 選取 從另一個程式或檔案中匯出

  3. 選取逗號分隔值 (Windows) 。

  4. 流覽以尋找您于上述程式中建立的檔。

    選取要導入的檔案。
  5. 選取選項 :不要匯出重複的專案

  6. 選擇您的主要連絡人資料夾做為目的地資料夾。 這是目前空白的資料夾。

  7. 選取 [完成]

將連絡人從複製資料夾複製回您的主要連絡人資料夾

  1. 選取複製 連絡人 資料夾。

  2. 按一下資料夾中的其中一個連絡人,然後按 Ctrl+A 以選取所有連絡人。

  3. 將選取的連絡人移至您的主要連絡人資料夾。 您可以拖放資料夾,或按 Ctrl+Shift+V 以使用 [移至 資料夾 > 對話方塊。

  4. 每次Outlook遇到重複的連絡人時,您都會看到一則提示,提示有兩個選項。

    • 如果 連絡人沒有重複 ,請選取新增連絡人。

    • 如果 連絡人重複,請 選取更新所選連絡人的資訊。

    選擇好之後,請選取 更新。 如果您想要針對所有重複的連絡人重複相同的選項,請選取 全部更新

    選擇您想要對重複的連絡人執行哪些工作。
  5. 移至資料夾程式完成後,您可以刪除重複檔案夾。

在 [偵測到重複的連絡人的連絡人) 對話方塊中,有兩個選項可解決 重複 的連絡人:

將重複專案新增為新連絡人     新連絡人會新新加入您的 連絡人 資料夾。 例如,如果您建立名為 Judy Lew 的連絡人,而且您的連絡人資料夾中已經有具有該名稱的連絡人,您將有兩個名為 Judy Lew 的連絡人。 若要區分這兩者,您可以將中間初始值新增到一個。

提示: 將連絡人顯示為電子名片是查看足夠的資訊,以區別名稱重複的連絡人的一個好選項。

將重複連絡人的新資訊更新至現有連絡人    Outlook比較重複和現有連絡人中包含資料的所有欄位,並將重複連絡人的資料複製到現有連絡人中具有衝突資料的任何欄位。 例如,如果您有一位名為 Judy Lew 的連絡人,且電話號碼為 555-0112,而且您收到新電話號碼的重複連絡人,Outlook 就會將新號碼複製到現有連絡人的適當欄位中,並保留所有其他欄位相同。

您指派給新連絡人的色彩類別,以及新連絡人訊息中的文字,將不會複製到現有的連絡人。 如果您想要複製這項資訊,您必須手動複製。 憑證和連絡人連結會從重複的連絡人複製,並新到現有的連絡人,而不會取代原始資訊。 不過,不會複製在活動 動捲動上連結到連絡人外的專案,例如工作與約會。

每當Outlook更新連絡人的資料時,原始連絡人的一份副本會儲存在刪除的郵件資料夾中。 如果您需要還原為原始連絡人的資訊,可以使用此複本。

如果您使用存在於連絡人資料夾中的相同名稱或電子郵件地址將連絡人匯入 Outlook,而且您選取了在匯入和匯出精靈中允許建立重複專案的選項,您可能會有您匯入之多個或所有連絡人的不想要的重複專案。

移除不想要的重複連絡人是手動程式,但下列是最簡單的方法。

  1. 連絡人中,選取具有重複連絡人的連絡人資料夾。

  2. [瀏覽窗格,按一下[目前視圖電話清單。 這是掃描連絡人清單及查看重複連絡人的最佳視圖。 現在,您可以根據修改的日期排序清單,將重複專案分組在一起。

  3. 在 [檢視] 功能表上指向 [目前檢視],然後按一下 [自訂目前檢視]。

  4. 按一下[欄位選取[可用欄位清單中的已修改內容,然後按一下[新增> 。

  5. 按一下 [向上 移動,直到 修改的欄位在此順序清單中顯示 這些欄位的頂端

  6. 按兩次 [確定]。

  7. 在連絡人清單中,按住 CTRL,同時選取每個重複的連絡人。

  8. 當您選取所有重複的連絡人時,請按 DELETE。

附註: 如果您在將連絡人匯入 Outlook 時不希望重複的連絡人,請在匯入和匯出精靈中選取不匯入重複專案選項或使用匯入專案取代重複專案選項。

  • 請勿輸入重複專案 現有資料會保留,而且不會將 個人資料夾檔案 (.pst) 中的重複資訊複製到 連絡人 資料夾。

  • 以匯入的項目取代重複的項目 [連絡人 資料夾中的現有資料會以正在輸入的 .pst 檔案中的資訊取代。

如果您要將許多連絡人Outlook,如果您不使用重複的偵測功能,程式可能會更快。 若要關閉此功能,請執行下列操作:

  1. 在 [工具] 功能表中,按一下 [選項]。

  2. 按一下 [連絡人選項,然後清除 [ 檢查重複的連絡人> 核取方塊。

需要更多協助?

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與我們的其中一個 Office 支援專員連絡以深入了解您的意見。

×