使用 Server-Side 同步處理時發生 PrivilegeDenied 錯誤

本文提供當您在 Microsoft Dynamics 365 中使用 Server-Side Synchronization 時所發生之 PrivilegeDenied 錯誤的解決方案。

適用於:Microsoft Dynamics CRM
原始 KB 編號: 4015092

徵狀

在 Dynamics 365 中使用 Server-Side 同步處理時,您在選取 [測試 & 啟用信箱] 後收到下列錯誤:

「無法同步處理信箱信箱 <名稱> 的約會、聯繫人和工作,因為信箱使用者對此信箱沒有足夠的許可權。
Email 伺服器錯誤碼:Crm.80040220.PrivilegeDenied”

原因

如果與信箱記錄相關聯的用戶沒有足夠的許可權可以使用 Server-Side 同步處理,就會出現此錯誤。

解決方案

修改使用者的安全性角色,以包含遺漏的許可權。 當您選取 [詳細數據] 段時,它應該包含遺漏許可權的名稱。 在下列範例中,使用者缺少 Email Server Profile 實體的讀取許可權。

T:331ActivityId: <GUID>>例外狀況:未處理的例外狀況:Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException:無法更新同步狀態:未處理的例外狀況:System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: 主要使用者 (Id=<GUID>, type=8) 遺失 prvReadEmailServerProfile 許可權 (Id=<ID>) Detail: <ID> -2147220960 Principal user (Id=<GUID>, type=8) is missing prvReadEmailServerProfile privilege (Id=edebe6f6-cf2e-45...

如需使用 Server-Side Sync 所需的許可權清單,請參閱 詳細資訊 一節。

其他相關資訊

下表列出使用 Server-Side 同步處理所需的許可權,以及可找到許可權的安全性角色索引標籤。 具有系統管理員角色的使用者可以流覽至 [ 設定]、[ 安全性]、[安全性角色] 來尋找及修改 安全性角色。 若要檢視 () 指派給特定使用者的角色,請流覽至 [ 設定],選取 [ 安全性],選取 [ 使用者],選取 特定的 [用戶記錄],然後選取 [ 管理角色]

許可權名稱 實體 安全性角色內的位置 (索引標籤)
prvReadEmailServerProfile EmailServerProfile 企業管理
prvWriteMailbox 信箱 企業管理
prvReadMailbox 信箱 企業管理
prvReadOrganization Organization 企業管理
prvSyncToOutlook (exchangeyncidmapping Outlook 商務管理 --> 隱私權相關許可權
prvReadActionCard ActionCard 核心記錄
prvDeleteActivity 活動 核心記錄
prvAppendActivity 活動 核心記錄
prvWriteActivity 活動 核心記錄
prvCreateActivity 活動 核心記錄
prvReadActivity 活動 核心記錄
prvAppendToActivity 活動 核心記錄
prvReadConnection 連線 核心記錄
prvAssignContact 連絡人 核心記錄
prvReadContact 連絡人 核心記錄
prvWriteContact 連絡人 核心記錄
prvCreateContact 連絡人 核心記錄
prvDeleteContact 連絡人 核心記錄
prvReadUserQuery 儲存的檢視 核心記錄
prvReadQueue Queue 核心記錄
prvReadQuery 檢視 自訂
prvReadIncident 案例 服務
prvSearchAvailability 服務管理 --> 其他許可權
prvOverrideCreatedOnCreatedBy 服務管理 --> 其他許可權