在 Microsoft Dynamics 365 App for Outlook 中開啟電子郵件時,無法使用檢視錯誤

本文提供解決方法:當您嘗試在 Microsoft Dynamics 365 App for Outlook 中開啟電子郵件時,無法使用此檢視錯誤。

適用於:Microsoft Dynamics CRM Online
原始 KB 編號: 4338690

徵狀

在 Microsoft Dynamics 365 App for Outlook 中開啟電子郵件時,您會看到下列錯誤:

「無法使用檢視。 請連絡您的系統管理員。」

原因

如果您停用 Microsoft Dynamics 365 App for Outlook 使用的其中一個檢視,就會出現此錯誤。 Microsoft Dynamics 365 App for Outlook 使用特殊表單來顯示潛在客戶 (App for Outlook 潛在客戶快速檢視) 或聯繫人 (App for Outlook 聯繫人快速檢視) 資訊。 這些表單都包含參考特定檢視的清單。 如果其中一個檢視已停用,您可能會看到無法 使用檢視 錯誤。

解決方案

請確定 Outlook 的 App for Outlook 潛在客戶快速檢視表單和 Outlook 的應用程式聯繫人快速檢視表單所使用的檢視未停用。 當您在 Microsoft Dynamics 365 App for Outlook 中檢視電子郵件時,所使用的表單取決於電子郵件是來自潛在客戶還是聯繫人。 如果您只在電子郵件來自聯繫人時看到此錯誤,您可能只需要修正聯繫人窗體所使用的檢視。 如果您只在電子郵件來自潛在客戶時看到錯誤,您可能只需要修正潛在客戶表單所使用的檢視。 在下列範例中,我們將確認已啟用 Outlook 應用程式聯繫人快速檢視表單所使用的預設檢視。 您可以針對 [潛在客戶] 實體底下的 [Outlook 潛在客戶快速檢視] 窗體使用類似的步驟,而非 [聯繫人] 實體:

  1. 身為具有系統管理員或系統自定義者安全性角色的用戶,開啟 Microsoft Dynamics 365 Web 應用程式。
  2. 流覽至 [設定] ,然後選取 [ 自定義]
  3. 取 [自定義系統]。 這會開啟 [ 默認解決方案 ] 對話框。
  4. 選取 [實體],選取 [ 聯繫人],然後選取 [ 表單]
  5. 開啟 [Outlook 應用程式聯繫人快速檢視] 表單。 根據預設,此表單包含兩份活動清單、一份商機清單,以及一份案例清單。 下表顯示清單的預設名稱,以及用於清單的默認檢視。
  6. 您可以使用這些資料表作為重新啟用預設檢視的參考。
  7. 在此範例中,我們將查看來自 Activity 實體的前兩個清單。 您可以針對其他提及的實體重複相同的步驟。
  8. 切換回 [ 默認解決方案 ] 對話框,選取 [ 活動],然後選取 [ 檢視]
  9. 選取 [ 檢視] 下拉式清單,然後選取 [非作用中的公用檢視]
  10. 確認 [下一個活動] 和 [上次活動] 檢視未出現在 [非使用中公用檢視] 列表中。 如果其中任何一個檢視已停用,請選取它們,然後選取 [ 啟用]
  11. 使用相同的步驟來確認其他檢視為作用中之後,請選取 [發佈所有自定義]
  12. 您可能需要關閉並重新開啟 Outlook,並可能清除瀏覽器快取。

Outlook 應用程式聯繫人快速檢視

清單名稱 默認檢視 實體
下一個活動 下一個活動 活動
上次活動 上次活動 活動
最近的機會 互動中心表單的最近商機 機會
最近的案例 我的作用中案例 案例

適用於 Outlook 潛在客戶的應用程式快速檢視表單

清單名稱 默認檢視 實體
下一個活動 下一個活動 活動
上次活動 上次活動 活動
利益相關 者 所有項目關係人 連線
競爭 對手 所有競爭對手 (摘要) 競爭 對手

注意事項

如果您想要變更這些表單所使用的檢視,而不是啟用預設檢視,您可以開啟表單上清單區段的屬性來變更選取的檢視。 如果您已停用其中一個默認檢視,即使清單目前仍在參考該默認檢視,您還是無法實際看到清單所參考的檢視。 相反地,它會顯示一些其他作用中的檢視名稱。 您可能需要先將它變更為另一個檢視,然後將它變更為您想要選取的檢視,變更才會生效。

Microsoft 知道您在嘗試變更檢視時可能會遇到錯誤的問題。 您可以變更下一個活動和最後一個活動檢視,但在嘗試變更其他檢視時,發生錯誤 (發生錯誤。請返回首頁,然後再試一次) 。 Microsoft 正在調查此問題的保護解決方案。