在 Microsoft Dynamics 365 中建立內送電子郵件時發生錯誤

本文提供在 Microsoft Dynamics 365 中建立內送電子郵件時所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 4053783

徵狀

下列警示會記錄在 Microsoft Dynamics 365 中的信箱記錄中:

「在 Microsoft Dynamics 365 中為信箱信箱<名稱建立內送電子郵件 <Email Subject> 時發生錯誤。>」

如果您選取警示內的 [ 檢視詳細 數據],您會看到下列其他資訊:

“Email 伺服器錯誤碼:InvalidSender”

或:

“Email 伺服器錯誤碼:InvalidForwardMailItem”

原因

原因 1:
如果警示包含 InvalidSender 文字,則如果 Server-Side 同步處理無法追蹤電子郵件,則會記錄此訊息,因為郵件的 [寄件者] 字段中沒有有效的電子郵件位址。

原因 2:
如果警示包含 InvalidForwardMailItem 文字,則如果轉寄信箱收到電子郵件,但轉寄電子郵件至 [轉寄信箱] 的 Dynamics 365 信箱未正確地將電子郵件轉寄為附件,或該信箱未將 [傳入 Email 信箱] 選項設定為 [轉寄信] 選項,就會記錄此郵件。

解決方案

解決方案 1 (InvalidSender) :

  1. 在信箱中找出對應的電子郵件。
  2. 確認 [寄件者] 欄位中有有效的電子郵件位址。

解決方案 2 (InvalidForwardMailItem) :

  1. 開啟將電子郵件轉寄至 [轉寄信箱] 的 Dynamics 365 信箱記錄。
  2. 確認位於 [同步處理方法] 區段內的 [傳入 Email] 設定已選取 [轉寄信箱] 選項。 如果選取另一個選項,例如伺服器端同步處理或 Email 路由器,則會說明記錄此錯誤的原因。
  3. 如果信箱已設定為使用傳入 Email 的 [轉寄信箱] 選項,請確認信箱已正確設定為不只將電子郵件轉寄至 [轉寄信箱],而是設定為將電子郵件轉寄為附件。

其他相關資訊

某些應用程式會傳送自動化電子郵件,但未在 [寄件者] 字段中包含有效的電子郵件位址。 例如,Outlook 中的 [雜亂] 功能會傳送會導致下列資訊警示的訊息:

在 Microsoft Dynamics 365 信箱中建立內送電子郵件「雜亂移動了新的和不同的郵件」時發生錯誤」

您可以放心地忽略此警示,而且這是資訊層級警示。 如果您想要避免記錄資訊層級警示,您可以變更在 [系統設定] 內啟用的警示類型。

  1. 身為具有系統管理員角色的使用者,流覽至 [設定],選取 [Email 組態],然後選取 [Email 組態設定]
  2. 向下捲動至 [ 設定警示] 區段,並從 [ 資訊 ] 複選框中移除選取專案。
  3. 選取 [確定]