啟動電子郵件路由器服務時,電子郵件路由器服務無法執行服務主要背景線程錯誤 Microsoft Dynamics CRM 電子郵件路由器服務

本文提供問題解決方法:當您啟動 Microsoft Dynamics CRM 電子郵件路由器服務時,可能會收到電子郵件路由器服務無法執行服務的主要背景線程錯誤。

適用於:Microsoft Dynamics CRM 2011 年
原始 KB 編號: 954522

徵狀

當您試著在 Microsoft Dynamics CRM 中啟動 Microsoft Dynamics CRM 電子郵件路由器服務時,會在應用程式記錄檔中記錄下列 Error 事件:

電子郵件路由器服務無法執行服務主要背景線程

原因

發生此問題的原因是 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案已損毀。

解決方案

如果要解決這個問題,請依照下列步驟執行。

  1. 刪除 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案。

    注意事項

    • 根據預設,Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案位於下列資料夾:C:\Program Files\Microsoft CRM Email\Service。
    • 根據預設,Service 資料夾是隱藏的資料夾。 若要查看此資料夾,您必須變更 Windows 檔案總管設定,以顯示隱藏的檔案和隱藏的資料夾。
  2. 重新啟動 Microsoft Dynamics CRM 電子郵件路由器服務。

    系統會重新建立 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案。

如果 Microsoft Dynamics CRM 使用者設定為使用 Email 路由器,而不是轉寄信箱,則在實作此解決方案之後,可能會刪除傳回 Microsoft Dynamics CRM 的電子郵件。 如果尚未從使用者的信箱中刪除電子郵件,Email 路由器可以在其 [收件匣] 中找到使用者的電子郵件、在 Microsoft Dynamics CRM 中找不到該電子郵件,然後再次在 Microsoft Dynamics CRM 中建立電子郵件。 若要避免這種情況,也應該從使用者的信箱中刪除電子郵件以及 Microsoft Dynamics CRM。

若要避免這種情況,請定期備份下列檔案,並將它們儲存在相同伺服器的桌面上。

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

如果 Microsoft Dynamics CRM Email 路由器 Configuration Manager 在啟動時失敗,或 Microsoft Dynamics CRM Email 路由器服務無法啟動,請在 C:\Program Files\ 中取代上述兩個檔案Microsoft CRM Email\Service。 重新啟動 Microsoft Dynamics CRM Email 路由器服務,然後啟動 Microsoft Dynamics CRM Email 路由器 Configuration Manager。 如果這些檔案的備份是最新的,則會有 Email 路由器的完整設定。

參考資料

如需詳細資訊,請參閱錯誤 Email 組態管理員無法讀取啟動 Microsoft Dynamics CRM Email 路由器 Configuration Manager 時發生的設定資訊