徵狀
當Dynamics 365 應用程式為 Outlook 中開啟一封電子郵件,您看到下列錯誤:
「 檢視無法使用。請連絡您的系統管理員。"
原因
如果您停用針對 Outlook Dynamics 365 應用程式所使用的檢視之一,就會顯示此錯誤。 Dynamics 365 的應用程式為 Outlook 會使用特殊的格式來顯示前置重疊時間 (如 Outlook 會導致快速檢視應用程式) 或連絡人 (Outlook 連絡人的快速檢視的應用程式)資訊。這些表單的每一個都包含參考特定的檢視表的清單。如果其中一個檢視停用了,您可能會看到 「 檢視方式無法使用 」 的錯誤。
解決方案
請確定應用程式,Outlook 會導致快速檢視表單及Outlook 連絡人的快速檢視的應用程式表單所使用的檢視不會停用。當您在檢視電子郵件,在 Dynamics 365 應用程式中,為 Outlook 時,所使用的形式取決於是否從前置重疊時間或連絡人的電子郵件。如果連絡人的電子郵件時,只會看到這個錯誤,您可能只需要修正連絡人表單所使用的檢視。如果從負責人電子郵件時,只會看到錯誤,您可能只需要修正的前置重疊時間表單所使用的檢視。在下面的範例中,我們將驗證所啟動的應用程式用於 Outlook 連絡人的快速檢視表單的預設檢視。您可以使用類似的步驟,如Outlook 會導致快速檢視表單中的前置重疊時間實體,而不是連絡人實體下找到相關的應用程式:
-
以具有系統管理員或系統自訂安全性角色的使用者,開啟 Dynamics 365 web 應用程式。
-
瀏覽至設定,然後按一下 [自訂]。
-
按一下 [自訂系統。 這會開啟 [預設的方案] 對話方塊。
-
按一下 [項目,按一下 [連絡人] ,然後按一下 [表單。
-
開啟Outlook 連絡人的快速檢視的應用程式表單。依預設此表單會包括活動、 的機會,清單和案例清單的兩個清單。下表顯示的清單,以及用於清單的預設檢視的預設名稱。
-
您可以在重新啟動的預設檢視,做為參考使用這些資料表。
-
在這個範例中會探討前兩份清單,也就是從活動實體。 至於其他所述的實體,您可以重複相同的步驟。
-
切換回 [預設的方案] 對話方塊,按一下活動,,然後按一下 [檢視]。
-
按一下 [檢視] 下拉式清單並選取 [非作用中的公用檢視。
-
請確認下一步的活動] 和 [最後一個活動檢視不會出現非作用中的公用檢視] 清單中。 如果任何這些檢視會停用了,請選取它們,然後再按一下 [啟動]。
-
之後使用相同的步驟,以驗證 [其他檢視為作用中,按一下 [發佈所有的自訂項目]。
-
您可能需要關閉並重新開啟 Outlook,並可能清除您的瀏覽器快取。
Outlook 連絡人的快速檢視的應用程式
清單名稱 |
預設檢視 |
實體 |
下一個活動 |
下一個活動 |
活動 |
最後一個活動 |
最後一個活動 |
活動 |
最近的機會 |
最近的機會,互動中心表單 |
機會 |
最近使用的情況下 |
我使用中的情況下 |
大小寫 |
Outlook 會導致快速檢視表單的應用程式
清單名稱 |
預設檢視 |
實體 |
下一個活動 |
下一個活動 |
活動 |
最後一個活動 |
最後一個活動 |
活動 |
共同工作人員 |
所有的利害關係者 |
連線 |
競爭者 |
所有的競爭者 (摘要) |
競爭者 |
注意: 如果您想要變更這些表單,而啟動的預設檢視的不是使用哪一個檢視,您可以開啟表單,變更選取的檢視上的 [清單] 區段的屬性。 如果您已停用其中一個預設檢視,您實際上無法看到即使它目前仍然會參考該預設檢視,它參考的清單。相反地,它會顯示為作用中的其他部份檢視名稱。您可能需要先將它變更為另一個檢視,然後將它變更為您要選取此選項,變更才會生效的檢視。
Microsoft 並成問題知道您將可能會遇到錯誤,嘗試變更檢視。 您可以變更下一個活動和最後一個活動檢視,但當嘗試變更其他的檢視,您會遇到錯誤 (「錯誤發生。請返回 [首頁] 頁面,然後再試一次。"). Microsoft 正在調查這個問題有 potention 的解決方案。