當使用伺服器端同步處理在動態 365 時發生 401 未經授權的例外狀況

狀況

使用伺服器端同步處理中時動態 365,可能會遇到下列錯誤之一︰

  • 無法傳送電子郵件訊息 「 測試訊息 」。請確定信箱 < 信箱名稱 > 中指定的認證正確,而且有足夠的權限,傳送電子郵件。然後,啟用電子郵件處理的信箱。

  • 約會、 連絡人及工作無法同步處理。請確定信箱 < 信箱名稱 > 中指定的認證正確,而且有足夠的權限。然後,啟用約會、 連絡人及工作同步處理的信箱。

  • 無法接收電子郵件信箱 < 信箱名稱 >。請確定在信箱中所指定的認證正確,而且有足夠的權限,來接收電子郵件。然後,啟用電子郵件處理的信箱。

此訊息也會包含下列的錯誤程式碼︰

電子郵件伺服器的錯誤代碼︰Http 伺服器會傳回 401 未經授權的例外狀況。


原因

這些錯誤的發生原因可能是以下其中一項︰

  1. 電子郵件地址,信箱中記錄的動態 365 不符的信箱的電子郵件地址在 [Exchange。

  2. 如果您使用 Exchange 線上使用動態 365 (線上),如果您使用 Exchange Server (混合式) 設定檔時,即使該使用者的信箱位於 Exchange 在線上時,會發生此錯誤。

  3. 如果您正在使用動態 365 與 Exchange 線上,則會發生此錯誤,如果使用者沒有 Exchange 線上的授權。

  4. 如果您使用 Exchange 線上使用動態 365 (線上),如果您的動態 365 訂閱不在相同的 Office 365 承租人,為您的 Exchange 線上訂閱時,會發生此錯誤。當使用線上交換的電子郵件伺服器設定檔時,必須屬於相同 Office 365 的帳戶/承租人動態 365 (線上) 和 Exchange 線上。

  5. 如果您使用 Exchange 先使用動態 365 (線上),如果 EWS (Exchange Web 服務) 未啟用基本驗證時,會發生此錯誤。




解決方案

  1. 請確認在 Exchange 信箱中記錄的動態 365 的電子郵件地址符合的電子郵件地址。錯誤會包括在動態 365 的信箱資料錄的連結。若要快速地確認電子郵件地址欄位,您可以使用此連結。

  2. 如果您使用動態 365 (線上),與 Exchange 線上,請確定您使用 Exchange 線上的電子郵件伺服器設定檔。只有使用 Exchange Server (混合) 表示該工期為設定先檔在 Exchange 中擁有信箱的使用者。

  3. 如果您使用動態 365 Exchange 線上,請確認該使用者擁有 Exchange 線上的授權。如需有關如何指派 Office 365 的授權的詳細資訊,請參閱指派或移除 Office 365 適用於企業的授權

  4. 如果您是使用動態 365 (線上) 與 Exchange 線上確認動態 365 (線上) 及 Exchange 線上位於同一個 Office 365 的帳戶/房客。

  5. 如果您使用 Exchange 先使用動態 365 (線上),請確認已啟用基本驗證,如 EWS (Exchange Web 服務)。 如需詳細資訊,請參閱必要條件 」 一節的連線動態 365 (線上) 到 (先) 的 Exchange Server。


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