當您嘗試在 Microsoft Dynamics CRM 啟動 Microsoft Dynamics CRM 電子郵件路由器服務的錯誤事件:"的電子郵件路由器服務無法執行服務的主要的背景執行緒"

狀況

當您嘗試在 Microsoft Dynamics CRM 啟動 Microsoft Dynamics CRM 電子郵件路由器服務時,應用程式記錄檔會記錄下列錯誤事件︰

原因

Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案已損毀,就會發生這個問題。

解決方案


動態 CRM 4.0 更新彙總套件 13] 中已處理這個問題。請參閱 KB http://support.microsoft.com/kb/2308072 如需詳細資訊。這也在動態 CRM 2011 中已處理。

如果您不是在更新彙總套件 13 上,若要解決此問題,請遵循下列步驟︰

  1. 刪除 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔。


    注意事項

    • 根據預設,Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案位於下列資料夾︰

      C:\Program 必要 CRM Email\Service

    • 根據預設,[服務] 資料夾會是隱藏的資料夾。若要查看此資料夾,您必須變更 [Windows 檔案總管設定,若要顯示隱藏的檔案及資料夾。

  2. 重新啟動 Microsoft Dynamics CRM 電子郵件路由器服務。

    重新建立 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 檔案。


如果 Microsoft Dynamics CRM 使用者已設定要用於內送電子郵件的電子郵件路由器和無法轉寄,信箱如圖中,沒有返回 Microsoft Dynamics CRM 實作這個解決方案之後刪除的電子郵件的可能性。 如果不從使用者的信箱刪除了一封電子郵件,電子郵件路由器無法在他們的收件匣中尋找使用者的電子郵件、 在 Microsoft Dynamics CRM,及 Microsoft Dynamics CRM 中重新建立電子郵件。若要避免這種情況,電子郵件應該也會從使用者的信箱,以及 Microsoft Dynamics CRM 進行刪除。

若要避免這種情況下,請定期採取下列檔案的備份,並將它們儲存在同一部伺服器的桌面上。

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin

  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml



如果在啟動的 Microsoft Dynamics CRM 電子郵件路由器組態管理員失敗或 Microsoft Dynamics CRM 電子郵件路由器服務無法啟動,取代 C:\Program 必要 CRM Email\Service 中的上述 2 的檔案。重新啟動 Microsoft Dynamics CRM 電子郵件路由器服務,並啟動 Microsoft Dynamics CRM 電子郵件路由器組態管理員。如果備份這些檔案是最新的它會具有完整的電子郵件路由器的設定。

參考

2012555錯誤電子郵件設定管理員無法讀取組態資訊會發生於您啟動 Microsoft Dynamics CRM 電子郵件路由器設定管理員

需要更多協助?

擴展您的技能
探索訓練
優先取得新功能
加入 Microsoft 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與我們的其中一個 Office 支援專員連絡以深入了解您的意見。

×