在 行動電話用 Microsoft Dynamics 365和 tablet 中找不到您角色錯誤訊息的任何應用程式

本文提供使用 行動電話用 Microsoft Dynamics 365 和tablet時所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 4486472

徵狀

針對手機和平板電腦使用 Dynamics 365 時,您會收到下列訊息:

「我們找不到您角色的任何應用程式。 若要檢查最近新增的應用程式,請選取 [重新整理]。
如果您找不到您的應用程式,請變更搜尋準則,然後再試一次。」

原因

原因 1:您沒有任何 Dynamics 365 安全性角色可提供任何整合介面應用程式的存取權。

原因 2:您沒有具有模型驅動應用程式許可權的 Dynamics 365 安全性角色。

解決方案

解決方法 1:確認使用者至少有整合介面應用程式的存取權。

  1. 以具有系統管理員安全性角色的使用者身分存取 Dynamics 365 Web 應用程式。

  2. 流覽至 [設定],然後選取 [我的應用程式]。

    注意事項

    如果您沒有看到 我的應用程式,您可以將 /apps 新增至 URL 的結尾:https://<your_organization_URL>/apps
    範例:https://contoso.crm.dynamics.com/apps

  3. 找出您要使用者使用的應用程式,然後選取省略號 (...) 選項,然後選取 [ 管理角色]

    注意事項

    [...] 選項只會出現在整合介面類型的應用程式上,這是唯一支援與手機和平板電腦 Dynamics 365 搭配使用的應用程式。 如果您還沒有整合介面應用程式,您可以使用 [ 建立新的應用程式] 選項。

  4. 隨即會出現 Dynamics 365 安全性角色的清單。 確認已選取至少一個指派給使用者的角色,然後選取 [ 儲存]

如需詳細資訊,請 參閱使用安全性角色管理應用程式的存取權。

解決方案 2:確認使用者的角色包含模型驅動應用程式許可權

  1. 以具有系統管理員安全性角色的使用者身分存取 Dynamics 365 Web 應用程式。
  2. 流覽至 [設定], 選取 [ 安全性],然後選取 [ 安全性角色]
  3. 開啟指派給使用者的角色。
  4. 選取 [ 自定義] 索引 標籤,然後找出 模型驅動應用程式許可權 。 確認角色至少包含此許可權的 取許可權。
  5. 取 [儲存並關閉]