桌面流程失敗,因安全策略而無法啟動流程
本文提供解決因 UI 流程執行期間的安全策略而無法啟動流程的問題。
適用於:Microsoft Dynamics CRM
原始 KB 編號: 4564550
徵狀
執行包含桌面流程的 Flow 時,即使目標裝置已安裝桌面流程,仍會失敗並出現下列錯誤。
無法連線到計算機上執行的傳統型流程。 請確定已安裝並執行Power Automate Desktop。
例如,在重新啟動 (裝置重新啟動) 時,Windows 服務 uiflowservice 在事件識別符為 7041 的 Windows Logs\System 事件查看器中無法重新啟動,並出現下列錯誤:
此服務帳戶沒有必要的用戶權力「以服務方式登入」。
嘗試手動啟動 uiflowservice 時,啟動會失敗並顯示訊息:
Windows 無法在本機計算機上啟動 UIFlowService 服務。 錯誤 1069:由於登入失敗,服務未啟動。
原因
UI 流程服務 (uiflowservice) 未在目標電腦上執行,因為服務所使用的帳戶不會透過手動設定或網域組策略授與登入 服務 授權。
解決方案
目標裝置
請確定 UI 流程服務正在目標電腦上的本地服務中執行。
請確定本機安全策略設定的 [以服務方式登入] 原則中有 UI 流程服務帳戶 NT SERVICE\UIFlowService 或一般服務帳戶 NT SERVICE\ALL SERVICES。
更多詳細數據 更多詳細數據 如果沒有任何專案存在,而且無法新增至本機「以服務方式登入」原則,則其中一個必須加入網域組策略中。 移至已加入網域的伺服器。策略登入的螢幕快照。 這表示原則設定為域控制器上的組策略: 請確定服務帳戶 NT SERVICE\UIFlowService 和一般服務帳戶 NT SERVICE\ALL SERVICES 不會出現在本機安全策略設定的 [拒絕以服務方式登 入] 原則中。
更多詳細數據 更多詳細數據 如果無法從本機「拒絕以服務方式登入」原則中移除它們,則必須從網域組策略中移除它們。 移至 已加入網域的伺服器 這表示原則設定為域控制器上的組策略:
已加入網域的伺服器
如果您的伺服器已加入網域,且 [以 服務方式 登入] 或 [ 拒絕以服務方式 登入] 原則是由網域管理,請查看域控制器上的下列步驟。 您可能需要連絡網域系統管理員以執行下列步驟:
請確定組安全策略設定的 [以服務方式登入] 原則中有 UI 流程服務帳戶 NT SERVICE\UIFlowService 或一般服務帳戶 NT SERVICE\ALL SERVICES。
更多詳細數據 更多詳細數據 UI 流程服務所使用的虛擬帳戶 「NT SERVICE\UIFlowService」 會在安裝 Power Automate Desktop (期間建立,) 安裝 UI 流程服務時。 如果網域中不存在,請遵循此程式在域控制器上建立它:
1。 在域控制器
2 上安裝 Power Automate Desktop。 安裝不需要成功,即使您遇到錯誤狀況,也會在網域中建立虛擬帳戶。
如果發生錯誤,請在取消或中止安裝之前,檢查帳戶 「NT SERVICE\UIFlowService」 具有域控制器和目標伺服器原則所需的所有存取權。
3. 現在“NT SERVICE\UIFlowService” 帳戶已可在網域中使用,可以新增至組策略設定,並且會顯示在已加入網域的伺服器中。UI 流程服務,其虛擬帳戶已安裝在域控制器上。 將 “NT SERVICE\UIFlowService” 新增至網域群組的 [以服務方式登入] 原則登入。 確定 「NT SERVICE\UIFlowService」 帳戶存在於您可能從域控制器卸載 Power Automate Desktop 的適當組策略之後,目標計算機上才需要此服務。 請確定UI流程服務帳戶 NT SERVICE\UIFlowService 或一般服務帳戶 NT SERVICE\ALL SERVICES 都不存在於組安全策略設定的 [拒絕以服務方式登入] 原則中。
更多詳細數據 更多詳細數據 如果帳戶 「NT SERVICE\UIFlowService」 或帳戶 「NT SERVICE\ALL SERVICES」 位於「拒絕以服務方式登入」原則中,則必須編輯網域組策略。