メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

この修正プログラムは、2 つの特定の現象を修正します。

  • ボリューム シャドウ コピー サービス ライターでタイムアウト エラーが発生します。

  • シャドウ コピーは、バックアップ中および時間、失われた高度な入力/出力がある場合にします。

ボリューム シャドウ コピー サービス ライターでタイムアウト エラーが発生します。

場合によっては、バックアップ中に、一部のボリューム シャドウ コピー サービス ライターがバックアップの失敗の原因となるタイムアウト エラーのため失敗します。ボリューム シャドウ コピー サービス ライターは、プログラムまたはシャドウ コピーの記憶域に情報を保存するのにはボリューム シャドウ コピー サービスを使用するサービスです。たとえば、NTBackup プログラムを使用して、バックアップが成功すると、できない場合があり、次のエラー メッセージが表示される場合があります。

ボリューム シャドウ コピーの作成中にエラーが返されます: 800423f4 (値は 800423f2 または 800423f3)

ボリューム シャドウ コピー サービス ライターの問題を診断するためには、バックアップが失敗した直後にvssadminコマンドを実行します。

  1. [開始] をクリック
    実行します。

  2. Vssadmin list writersを入力します。

このコマンドは、ボリューム シャドウ コピー サービス ライターと各ライターの現在の状態を表示します。たとえば、出力可能性があります、Microsoft SQL Server デスクトップ エンジン (MSDE) または Microsoft Active Directory ディレクトリ サービスのライターが失敗したことです。MSDE ライター、SQL ライター、新しいテクノロジーのディレクトリ サービス (NTDS) ライター、Windows インターネット ネーム システム (WINS) ライター、動的ホスト構成プロトコル (DHCP)、ライターなど、いくつかのライターでタイムアウト エラーが発生する可能性があります、リモート記憶域のライター、証明機関のライター、および Microsoft Exchange 書き込みプログラムです。サンプル出力を次に示します。

C:\ > VSSADMIN LIST WRITERS
[...]
ライター名: 'NTDS'
ライター Id: {b2014c9e-8711-4c5c-a5a9-3cf384484757}
ライター インスタンス Id: {26ed439f-4a52-481d-963d-5db5b695d9e7}
状態: [10] に失敗しました
最後のエラー: 再試行可能なエラー

さらに、タイムアウト エラーは、アプリケーション イベント ログを参照して識別できます。いくつかの例:

イベント ID: 12290
説明:
ボリューム シャドウ コピー サービスの警告: ESENT エラー {b2014c9e-8711-4c5c-a5a9-3cf384484757} NTDS:-2402。hr = 0x00000000 です。

イベント ID: 2004
説明:
シャドウ コピー 6 がタイムアウトしました (20000 ミリ秒) をします。

シャドウ コピーは、バックアップ中および時間、失われた高度な入力/出力がある場合に

別の関連する現象は、そのシャドウを共有ネットワーク フォルダーのコピーが削除された可能性があります。この問題が発生すると、次のイベント エラーが記録されます。

イベントの種類: エラー
イベント ソース: VolSnap
イベント カテゴリ: なし
イベント ID: 25
説明:


ボリュームVolumeNameのシャドウ コピーは、異なる領域ファイルが時間内に拡大できなかったために中止しました。今後この問題を回避するには、このシステム上の IO 読み込みを減らしてください。

メッセージは、ボリューム名は、バックアップ用にスケジュールされているボリュームの名前です。

原因

次の理由のいずれかのこの資料に記載されている現象があります。

  • ボリューム シャドウ コピー サービス ライターのタイムアウト

  • シャドウ コピーの削除

  • 大規模な監査ログ

ボリューム シャドウ コピー サービス ライターのタイムアウト

長いシャドウ コピーの作成中に特定のボリューム シャドウ コピー サービス ライターのタイムアウト時間を原因となる問題が発生する可能性があります。特に低速のハード ディスク、メモリ不足、または低の CPU の速度を持つコンピューターでこの問題が発生します。または (たとえば、ドメイン コント ローラーのコンピューターに搭載したコンピューターでディスク書き込みキャッシュを無効にします。

シャドウ コピーの作成には、複雑な一連プロセス間呼び出しにはが含まれています。プロセス間の呼び出しは、すべての重要なボリューム シャドウ コピー サービス ライター (SQL、Exchange Server、オペレーティング システム サービス、および他のユーザーなどのプログラム) がシャドウ コピーの作成中に、データ ・ バッファーをフラッシュすることを確認します。また、Exchange ライターのように、いくつかのボリューム シャドウ コピー サービス ライターは間隔の間にシャドウ コピーを作成することができますので、定義済みの時間間隔の書き込みを待機します。ライターが発生するため、シャドウ コピーの内容は、データ バッファーを一定になります。ただし、CPU が低速、高いメモリ使用量、または高の入力/出力レベルがある場合、以下の現象が発生する可能性があります。

  • ライターは、データ ・ バッファーをフラッシュしません。

  • ライターは、時間間隔を待たずに書き込む前にします。

この問題が発生した場合、シャドウ コピーの作成は失敗します。

重要 ボリューム シャドウ コピー サービス ライターは、その他の原因のようなエラーで失敗する可能性があります。これらの条件には、ディスク領域の不足、またはコンピューターの不適切な構成が含まれます。この修正プログラムは、バックアップ中にボリューム シャドウ コピー サービス ライターでランダムに発生した特定のタイムアウト エラーのみを修正します。他の潜在的なボリューム シャドウ コピー サービス エラー ライター エラーが生成されるイベント ログを確認するのにはするを強くお勧めします。

シャドウ コピーの削除

(たとえば、ドメイン コント ローラーのコンピューターでディスク書き込みキャッシュが無効になっている場合は特に、入力/出力の高レベルがある場合、シャドウ コピーの削除が発生する、Volsnap.sys ドライバーで問題が発生する可能性があります。

既定では、バックアップの目的でシャドウ コピーを作成する Microsoft Windows Server 2003 に含まれているシャドウ コピー プロバイダーが使用されます。シャドウ コピーを実装するには、コピー オン ライトの実装を使用します。相違点は、シャドウ コピーの記憶域にコピーされます。ボリューム シャドウ コピー サービスでは、シャドウ コピーの管理ツールを使用することができます。 またはvssadminコマンドを使用することができます。

Windows Server 2003 のオリジナル リリース バージョン、シャドウ コピーの作成に割り当てられている最初のシャドウ コピーの記憶域とは、100 メガバイト (MB) です。ただし、使用される実際の領域は、はるかに小さいです。時間が経過すると元のボリュームでより多くのデータが変更されると、割り当てられた領域は増えることがあります。ただし、元のボリュームに大量の入出力トラフィックがある場合、ときにシャドウ コピーの記憶域の拡張が間に合わず、コピー オン ライトの変更をすべて格納することはできませんがあります。これは、ため、元のボリューム上のシャドウ コピーをすべて削除します。この問題は、ドメイン コント ローラー構成でより顕著に表れます。既定では、ドメイン コント ローラー構成でディスク書き込みキャッシュが無効になります。

重要 同様の問題は、すべてのシャドウ コピーが削除されると、この資料に記載されているイベント ログ エラーがログに記録され、小規模なクラスター サイズが、ボリュームの最適化によって発生します。ディスクの最適化の実行中のシャドウ コピーを失うことに関する詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします:

312067シャドウ コピーが失われる場合、ボリュームを最適化します。

また、イベントのエラー ID 2004 がある場合に記録される可能性がありますには、NTFS ファイル システム ボリュームが破損しています。この問題を確認するのには、 /fスイッチを使用して Chkdsk.exe プログラムを実行します。

大規模な監査ログ

監査ログが非常に大きい場合は、システム状態のバックアップ中にはライターのタイムアウト エラーも表示されます。バックアップするか、監査ログを定期的にクリーンアップをお勧めします。

解決策

重要 「ファイル情報」セクションに記載されている修正プログラムは次のマイクロソフト サポート技術情報資料に記載されている更新プログラムに含まれていますいます。

833167ボリューム シャドウ コピー サービス (VSS) 更新プログラム パッケージは、Windows Server 2003 の使用


この資料およびその他の VSS 関連の問題で説明する問題を解決するのには、この更新プログラムをインストールすることを強くお勧めします。

修正プログラムの情報

この問題を解決するには、Windows Server 2003 の最新の service pack を入手します。詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料をご参照ください。

889100 Windows Server 2003 の最新の service pack の入手方法
サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この問題が発生しているシステムにのみ適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。

修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×