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現象

次のような状況で問題が発生します。

  • ユーザーコントロールポイント (UCP) をホストしている Microsoft SQL Server 2008 R2 のインスタンスがあります。

  • SQL Server 2008 R2 の累積的な更新パッケージ1をインスタンスにインストールします。

このシナリオでは、インストールは成功します。 ただし、SQL Server サービスを開始することはできません。 さらに、次のエラーメッセージが SQL Server のエラーログファイルに記録されます。

<日付> <時刻> spid7s [sysutility_mdw] sysutility_ucp_core sp_initialize_mdw_internal<Date><time> spid7s SQL server は、このサーバーのセキュリティ構成の一部としてこのコンポーネントがオフになっているため、コンポーネント ' Agent XPs ' ののプロシージャへのアクセスをブロックしました。 システム管理者は、sp_configure を使用して、"Agent XPs" の使用を有効にすることができます。 「Agent XPs」を有効にする方法について詳しくは、SQL Server Books Online の「Surface Area の構成」をご覧ください。<日付><時刻> spid7s エラー: 15281、レベル:16、状態: 1。<日付><時刻> spid7s SQL server は、このサーバーのセキュリティ構成の一部としてこのコンポーネントがオフになっているため、コンポーネント ' Agent XPs ' のプロシージャ ' sys.xp_qv ' へのアクセスをブロックしました。 システム管理者は、sp_configure を使用して、"Agent XPs" の使用を有効にすることができます。 「Agent XPs」を有効にする方法について詳しくは、SQL Server Books Online の「Surface Area の構成」をご覧ください。<日付><時刻> spid7s エラー: 912、レベル:21、状態: 2。<日付><時刻>アップグレード手順 ' sqlagent100_msdb_upgrade. sql ' でエラー15281、状態1、重大度16が発生したため、データベース ' Master ' の spid7s スクリプトレベルのアップグレードに失敗しました。 これは、通常の操作の妨げになる可能性のある重大なエラー条件であり、データベースはオフラインになります。 "Master" データベースのアップグレード中にエラーが発生した場合は、SQL Server インスタンス全体の開始を防ぐことができます。 以前のエラーログエントリを確認して、適切な是正措置を実行し、データベースを再起動します。これにより、スクリプトのアップグレード手順が完了します。<日付><時刻> spid7s エラー: 3417、レベル:21、状態: 3。<日付><時刻> spid7s はマスターデータベースを復元できません。 SQL Server を実行できません。 Master を完全バックアップから復元するか、修復するか、再構築します。 Master データベースの再構築方法の詳細については、「SQL Server Books Online」を参照してください。<日付><時刻> spid7s SQL Trace がサーバーのシャットダウンによって停止されました。 トレース ID = ' 1 '。 これは情報メッセージにすぎません。ユーザー操作は必要ありません。

この問題は、UCP をホストしている SQL Server 2008 R2 Release 候補 (RC) のインスタンスを、SQL Server 2008 R2 のリリースバージョンにアップグレードした場合にも発生することがあります。

原因

この問題は、SQL Server 2008 R2 で msdb データベースのアップグレードスクリプトが実行されるときに、Agent XPs オプションが有効になっていないために発生します。このスクリプトは、SQL Server サービスが起動したときに実行されます。 このスクリプトは、UCP に関連するストアドプロシージャを実行します。 また、ストアドプロシージャでは、エージェントの XPs オプションを有効にする必要があります。

解決方法

累積的な更新プログラムの情報

この問題の修正プログラムは、累積的な更新プログラム2で最初にリリースされました。SQL Server 2008 R2 用の累積的な更新プログラムパッケージの入手方法の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

2072493 SQL Server 2008 R2 の累積的な更新プログラムパッケージ2注: ビルドは累積的であるため、各新しい修正プログラムには、以前の SQL Server 2008 R2 fix release に含まれていたすべての修正プログラムとセキュリティ修正プログラムが含まれています。 この修正プログラムを含む最新の修正プログラムを適用することを検討することをお勧めします。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。

981356 SQL Server 2008 R2 のリリース後にリリースされた SQL Server 2008 R2 ビルド

回避策

注: 累積更新プログラムパッケージ1をまだインストールしていない場合は、「解決策」セクションに従って累積的な更新プログラムパッケージ2をインストールする必要があります。 この問題は、SQL Server 2008 R2 の累積的な更新プログラムパッケージ2以降のバージョンでは存在しません。累積的な更新プログラムパッケージ1をインストールした後にこの問題が発生する場合は、次の手順に従ってこの問題を回避してください。

  1. SQL Server 2008 R2 のインスタンスでトレースフラグ902を有効にします。 これを行うには、次の手順を実行します。

    1. SQL Server 構成マネージャーを開きます。

    2. SQL Server 構成マネージャーで [ Sql Server Services] をクリックします。

    3. SQL Server サービスをダブルクリックし ます。

    4. [ SQL Server のプロパティ ] ダイアログボックスで、[ 詳細設定 ] タブをクリックします。

    5. [ 詳細設定 ] タブをクリックし、[ スタートアップパラメーター ] 項目を見つけます。

    6. [追加] をクリックし、既存の文字列値の末尾に T902 して、[ OK]をクリックします。

  2. SQL Server サービスを右クリック し、[ 開始] をクリックします。

  3. SQL Server エージェントサービスが実行されている場合は、SQL Server エージェントサービスを右クリックし、[ 停止] をクリックします。

  4. SQL Server Management Studio を開き、SQL Server 2008 R2 のインスタンスに接続します。

  5. 次のステートメントを実行します。

    EXEC sp_configure ' 詳細を表示 ', 1; ャ EXEC sp_configure の [更新を許可する]、0、 ャ EXEC sp_configure ' Agent XPs ', 1;ャいく

  6. SQL Server 構成マネージャーで SQL Server サービスを右クリックし、[ 停止] をクリックします。

  7. SQL Server 2008 R2 のインスタンスでトレースフラグ902を削除します。 これを行うには、手順1f で更新した文字列の値から T902 を削除します。

  8. SQL Server サービスを右クリック し、[ 開始] をクリックします。

  9. SQL Server エージェントサービスを右クリックし、[ 開始] をクリックします。

  10. SQL Server Management Studio で、SQL Server 2008 R2 のインスタンスに再接続します。

  11. オブジェクトエクスプローラーで、[ 管理] を展開し、[ データ収集] を右クリックして、[ データ収集を有効にする] をクリックします。注: データコレクションが既に有効になっている場合、[データ収集を有効にする] 項目は使用できません。

注: SQL server Management Studio で SQL Server 2008 R2 のインスタンスに接続すると、次のエラーメッセージが表示されることがあります。

エラー: ユーザー '<ログイン名>' の18401login に失敗しました。 理由: サーバーはスクリプトアップグレードモードになっています。 この時点では、管理者のみが接続できます。

このエラーメッセージは、SQL Server 2008 R2 で累積的な更新プログラムパッケージ1のインストールが完了していることを示します。 このエラーメッセージが表示された場合は、数分待ってから、SQL Server 2008 R2 のインスタンスにもう一度接続します。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

関連情報

SQL Server の段階的サービスモデルの詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

935897 SQL Server チームが段階的なサービスモデルを利用して、報告された問題の修正プログラムを提供する SQL Server 更新プログラムの名前付けスキーマの詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

822499 Microsoft SQL Server ソフトウェア更新プログラム パッケージの命名スキーマ ソフトウェア更新プログラムの用語の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

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