以下の条件に該当する場合に、Microsoft .NET Framework Version 4 用の更新プログラムはインストールされないことがあります。
-
Microsoft .NET Framework 4 または Microsoft .NET Framework 4 Client Profile を事前にインストールした。
-
新しい更新プログラムをインストールする前に、システムの再起動が保留中で、完了していない。
注: Windows Update サイトを使用して更新プログラムをインストールすると、更新プログラムが提供およびインストールされたように思われることがあります。ところが、コンピューターを再起動した後に、同じ更新プログラムが再度提供されます。
現象
この問題は、Microsoft .NET Framework 4 がインストールされている場合、システムを再起動するまでに、特定のコンポーネントがロックされるか、使用中になることが原因で発生します。これらのコンポーネントは、システムを再起動するまでは更新できません。このため、「現象」セクションに記載されている状況では、shim (mscoree.dll) のバージョンは .NET Framework Version 3.5 SP1 以降です。Microsoft .NET Framework 4 のインストールでは、システムの再起動後、shim が更新されるまでの間に shim の古いバージョンが正しく機能しないようにする特定の設定が展開されます。この状況では、再起動の保留中に Microsoft .NET Framework の別の更新プログラムをインストールしようとすると、その更新プログラムは、更新プログラム内のファイルについてグローバル アセンブリ キャッシュ (GAC) 展開を使用しようとします。この GAC の処理には、shim が必要です。ただし、shim は整合性のない状態で、再起動の保留中であるため、GAC の処理は失敗します。これにより、更新プログラムは失敗します。
原因
この問題を回避するには、新しい Microsoft .NET Framework 更新プログラムをインストールする前に、システムを再起動します。既に経験している状況で、この問題のために更新プログラムがインストールされなかった場合、コンピューターを再起動して、新しい更新プログラムを再インストールします。
回避策
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。