XL : Comment faire pour créer un graphique d'une courbe de Gauss

Traductions disponibles Traductions disponibles
Numéro d'article: 213930 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Résumé

Une courbe de Gauss (courbe en cloche) est une représentation graphique de la distribution normale d'un jeu de données quelconque. Cet article explique comment créer un graphique d'une courbe de Gauss dans Microsoft Excel.

Plus d'informations

Dans l'exemple suivant, vous pouvez créer une courbe de Gauss de données générée par Excel à l'aide de l'outil Génération de nombres aléatoires compris dans l'utilitaire d'analyse. Une fois le jeu de nombres aléatoires généré dans Microsoft Excel, vous pouvez créer un histogramme à l'aide de ces nombres aléatoires et de l'outil Histogramme compris dans l'utilitaire d'analyse. À partir de l'histogramme, vous pouvez créer un graphique pour représenter une courbe de Gauss.

Pour créer un exemple de courbe de Gauss, procédez comme suit :
  1. Démarrez Excel.
  2. Entrez les en-têtes de colonne suivants dans une nouvelle feuille de calcul :
       A1 :Original B1 :Moyenne C1 :Bin D1 :Aléatoire E1 :Histogramme G1 :Histogramme
    					
  3. Entrez les données suivantes dans cette feuille de calcul :
       A2 : 23         B2 :
       A3 : 25         B3 : ECARTYPE
       A4 : 12         B4 :
       A5 : 24
       A6 : 27
       A7 : 57
       A8 : 45
       A9 : 19
    					
  4. Entrez les formules suivantes dans cette feuille de calcul :
       B2 :  =MOYENNE(A2:A9)
       B3 :
       B4 :  =ECARTYPE(A2:A9)
    						
    Ces formules généreront respectivement la moyenne et l'écart type des données d'origine.
  5. Entrez les formules suivantes pour générer la plage bin pour l'histogramme :
       C2 : =$B$2-3*$B4
    						
    Cela génère la limite inférieure de la plage bin. Ce nombre représente trois écarts types de moins que la moyenne.
       C3 : =C2+$B$4
    						
    Cette formule ajoute un écart type au nombre calculé dans la cellule supérieure.
  6. Sélectionnez la cellule C3, déplacez la poignée de recopie, puis recopiez la formule de la cellule C3 à C8.
  7. Pour générer les données aléatoires qui formeront la base de la courbe de Gauss, procédez comme suit :
    1. Dans le menu Outils, cliquez sur Analyse de données.
    2. Dans la boîte de dialogue Utilitaire d'analyse, cliquez sur Génération de nombres aléatoires, puis sur OK.
    3. Dans la zone Nombre de variables, tapez 1.
    4. Dans la zone Nombre de nombres aléatoires, tapez 2000.

      REMARQUE : en faisant varier ce nombre, vous pouvez augmenter ou diminuer la précision de la courbe de Gauss.
    5. Dans la zone Distribution, sélectionnez Normale.
    6. Dans la zone Moyenne du volet Paramètres, entrez le nombre calculé dans la cellule B2 (29 dans notre exemple).
    7. Dans la zone Écart type, entrez le nombre calculé dans la cellule B4 (14,68722).
    8. Laissez la zone Entier générateur vierge.
    9. Dans le volet Options de sortie, cliquez sur Plage de sortie.
    10. Tapez D2 dans la zone Plage de sortie.

      Cela générera 2 000 nombres aléatoires qui seront représentés dans une distribution normale.
    11. Cliquez sur OK.
  8. Pour créer un histogramme pour les données aléatoires, procédez comme suit :
    1. Dans le menu Outils, cliquez sur Analyse de données.
    2. Dans la boîte de dialogue Utilitaire d'analyse, sélectionnez Histogramme, puis cliquez sur OK.
    3. Dans la zone Plage d'entrée, tapez D2:D2001.
    4. Dans la zone Plage bin, tapez C2:C8.
    5. Dans le volet Options de sortie, cliquez sur Plage de sortie.
    6. Tapez E2 dans la zone Plage de sortie.
    7. Cliquez sur OK.
  9. Pour créer un histogramme pour les données d'origine, procédez comme suit :
    1. Dans le menu Outils, cliquez sur Analyse de données.
    2. Cliquez sur Histogramme, puis sur OK.
    3. Dans la zone Plage d'entrée, tapez A2:A9.
    4. Dans la zone Plage bin, tapez C2:C8.
    5. Dans le volet Options de sortie, cliquez sur Plage de sortie.
    6. Tapez G2 dans la zone Plage de sortie.
    7. Cliquez sur OK.
  10. Créez des étiquettes pour la légende du graphique en entrant les informations suivantes :
       E14 : =G1&"-"&G2
       E15 : =E1&"-"&F2
       E16 : =G1&"-"&H2
    					
  11. Sélectionnez la plage de cellules E2:H10 sur la feuille de calcul.
  12. Dans le menu Insertion, cliquez sur Graphique.
  13. Sous Type de graphique, cliquez sur Nuage de points (XY).
  14. Sous Sous-type de graphique, dans la ligne centrale, cliquez sur le graphique de droite.

    REMARQUE : la description « Nuage de points avec lissage sans marquage des données » s'affiche juste au-dessous de ces 5 sous-types.
  15. Cliquez sur Suivant.
  16. Cliquez sur l'onglet Série.
  17. Dans la zone Nom, supprimez la référence de cellule, puis sélectionnez la cellule E15.
  18. Dans la zone Valeurs X, supprimez la référence de plage, puis sélectionnez la plage E3:E10.
  19. Dans la zone Valeurs Y, supprimez la référence de plage, puis sélectionnez la plage F3:F10.
  20. Cliquez sur Ajouter pour ajouter une autre série.
  21. Cliquez sur la zone Nom, puis sélectionnez la cellule E14.
  22. Cliquez sur la zone Valeurs X, puis sélectionnez la plage E3:E10.
  23. Dans la zone Valeurs Y, supprimez la valeur affichée, puis sélectionnez la plage G3:G10.
  24. Cliquez sur Ajouter pour ajouter une autre série.
  25. Cliquez sur la zone Nom, puis sélectionnez la cellule E16.
  26. Cliquez sur la zone Valeurs X, puis sélectionnez la plage E3:E10.
  27. Dans la zone Valeurs Y, supprimez la valeur affichée, puis sélectionnez la plage H3:H10.
  28. Cliquez sur Terminer.

    Le graphique reproduira deux séries en courbe et une série plate sur l'axe des X.
  29. Double-cliquez sur la deuxième série ; elle doit être étiquetée « Bin » en légende.
  30. Dans la boîte de dialogue Format de la série de données, cliquez sur l'onglet Axe.
  31. Cliquez sur Axe secondaire, puis sur OK.
Vous avez maintenant créé un graphique qui compare un jeu de données à une courbe de Gauss.

Références

Pour plus d'informations sur la création de graphiques, cliquez sur Aide sur Microsoft Excel dans le menu ? (Aide), tapez création d'un graphique dans le Compagnon Office ou dans l'Aide intuitive, puis cliquez sur Rechercher pour afficher la rubrique.

Propriétés

Numéro d'article: 213930 - Dernière mise à jour: jeudi 15 juin 2006 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Excel 2000 Standard
  • Microsoft Excel 97 Standard
Mots-clés : 
kbhowto KB213930
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com