CORRIGER : Plusieurs problèmes se produisent lorsque vous utilisez BizTalk Adapter pour JD Edwards EnterpriseOne ou adaptateur BizTalk pour JD Edwards OneWorld XE dans BizTalk Server 2006 R2 ou en 2009 de BizTalk Server

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Numéro d'article: 2291479 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Considérez le scénario suivant :
  • Vous possédez un ordinateur qui exécute Microsoft BizTalk Server 2006 R2 ou Microsoft BizTalk Server 2009.
  • Vous utilisez une des cartes suivantes pour échanger Fonction d'entreprise messages entre BizTalk Server et un système de JD Edwards EnterpriseOne :
    • Carte Microsoft BizTalk pour JD Edwards EnterpriseOne
    • Carte Microsoft BizTalk pour JD Edwards OneWorld XE
Dans ce scénario, un ou plusieurs des problèmes suivants peuvent se produire.

Problème 1

Une fois que vous essayez d'envoyer un message à l'aide de la carte, la carte est inactive pour un certain temps, puis vous essayez d'envoyer un autre message. Dans ce scénario, la carte n'envoie pas le premier message. Toutefois, la carte envoie le deuxième message. En outre, un événement semblable au suivant est enregistré dans le journal applications :

Type d'événement : erreur
Source d'événements : Microsoft Biztalk Adapters for Enterprise Applications
Catégorie d'événement : aucune
ID d'événement: 0
Description :
Erreur d'exécution : Aucune connexion peut être établie car l'ordinateur cible refusée 127.0.0.1:15000

Problème 2

Lorsque vous définissez la Nombre d'appels simultanés maximal propriété une valeur supérieure à 1 pour la carte, le message de nombreuses instances de mettre en attente et ne sont pas traités de transport.

Problème 3

Périodiquement les messages sont suspendues. En outre, certaines entrées d'événement semblables aux suivants sont enregistrées dans le journal des applications :

Événement 1

Type d'événement : erreur
Source d'événements : Microsoft BizTalk Adapters for Enterprise Applications
Catégorie d'événement : aucune
ID d'événement: 0
Description :
Cible non valide : X0010GetNextNumber@JDE://CALLBSFN/

Événement 2

Type d'événement : erreur
Source d'événements : Microsoft Biztalk Adapters for Enterprise Applications
Catégorie d'événement : aucune
ID d'événement: 0
Description : Erreur transmission de message :<soap-env:fault></soap-env:fault>
ENV = "http://schemas.xmlsoap.org/SOAP/Envelope/

« ><faultcode>SOAP-ENV:Client</faultcode><faultstring>ID de demande : inconnu</faultstring>

Type d'exception : La méthode n'existe pas
Informations sur l'exception :
Exception s'est produite :
Cible non valide : X0010GetNextNumber@JDE://CALLBSFN/X0010>

Événement 3

Type d'événement : avertissement
Source d'événements : BizTalk Server 2009
Catégorie d'événements : BizTalk Server 2009
ID d'événement : 5743
Description : La carte n'a pas pu envoyer le message au port «<send port="">» d'envoi avec l'URL «<url>». Il va être retransmis après l'intervalle avant nouvelle tentative spécifié pour ce Port d'envoi. Détails: "message d'erreur transmission : <soap-env:fault xmlns:soap-env=" xmlns:soap-env=""></soap-env:fault xmlns:soap-env="></url></send>http://schemas.xmlsoap.org/SOAP/Envelope/

« ><faultcode>SOAP-ENV:Client</faultcode><faultstring>ID de demande : inconnu</faultstring>

Type d'exception : La méthode n'existe pas
Informations sur l'exception :
Exception s'est produite :
Cible non valide : X0010GetNextNumber@JDE://CALLBSFN/X0010>".

Cause

Ces problèmes se produisent en raison d'une erreur dans les adaptateurs BizTalk pour Applications d'entreprise.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour de logiciel qui comprendra ce correctif.

Si le correctif est disponible au téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » en haut de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle de Microsoft et prise en charge pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage est nécessaire, il se peut que vous deviez créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour une liste complète des numéros de téléphone Service clientèle de Microsoft et prise en charge ou pour créer une demande de service distinct, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.Microsoft.com/contactus/?ws=support
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est dans la mesure où un correctif n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez disposer des adaptateurs BizTalk pour Applications d'entreprise (également appelé LOB adaptateurs BizTalk) installé. En outre, l'ordinateur doit exécuter BizTalk Server 2006 R2 Service Pack 1 (SP1) ou BizTalk Server 2009.

Nécessité d'un redémarrage

Il est inutile de redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace pas d'autres correctifs.

Informations sur les fichiers

La version anglaise de ce correctif possède les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est converti en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez la Fuseau horaire onglet dans la Date et heure élément dans le panneau de configuration.
Pour BizTalk Server 2006 R2 SP1
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Microsoft.BizTalk.Adapters.bizutil.dll1.0.5022.13164,23208-Août-201116 : 47x 86
Pour BizTalk Server 2009
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Microsoft.BizTalk.Adapters.bizutil.dll1.0.5102.2156,04028-Juil-201010 h 30x 86

Comment faire pour appliquer ce correctif

Pour appliquer ce correctif après que l'avoir installé, effectuez les opérations suivantes :
  1. Inscrire manuellement le fichier Microsoft.BizTalk.Adapters.BizUtil.dll dans le global assembly cache (GAC). Pour ce faire, procédez comme suit.

    1. Ouvrir un Invite de commande Visual Studio ou SDK Command Prompt fenêtre. Modifier le répertoire en cours à ce qui suit :
      %ProgramFiles%\Common Files\Microsoft BizTalk Adapters for Enterprise Applications\Bin
      Important Pour ouvrir un Invite de commande Visual Studio fenêtre, vous devez avoir Microsoft Visual Studio 2008 ou Microsoft Visual Studio 2005 installé. Pour ouvrir un SDK Command Prompt fenêtre, vous devez disposer de Microsoft.NET Framework 2.0 SDK est installé.
    2. À la Invite de commande Visual Studio ou SDK Command Prompt fenêtre, tapez la commande suivante et appuyez sur ENTRÉE :
      gacutil /i Microsoft.BizTalk.Adapters.BizUtil.dll
  2. Créez une nouvelle sous-clé dans le Registre. Pour ce faire, procédez comme suit :

    Avertissement Problèmes sérieux peuvent survenir si vous modifiez le Registre de manière incorrecte à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent vous obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
    1. Cliquez sur Début, cliquez sur Exécuter, type Regedit, puis cliquez sur OK.
    2. Recherchez, puis sélectionnez la clé de Registre suivante :
      Pour le système d'exploitation 32 bits
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters
      Pour le système d'exploitation 64 bits
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\BizTalkAdapters
    3. Sur le Modifier pointez sur Nouveau, puis cliquez sur Valeur DWORD.
    4. Type AgentOutboundTimeout, puis appuyez sur ENTRÉE.
    5. Sur le Modifier menu, cliquez sur Modifier.
    6. Sélectionnez Décimal, type 60000, puis cliquez sur OK.
    Le AgentOutboundTimeout valeur est utilisée pour recycler le RunTimeAgent processus après un certain délai d'inactivité. Nous vous recommandons de définir la valeur afin qu'il soit plus que le temps requis pour l'opération se termine sur le serveur Oracle. Par défaut, la valeur est de 60 000 millisecondes (1 minute).

Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur l'adaptateur BizTalk pour JD Edwards EnterpriseOne, visitez le site Web Microsoft Developer Network (MSDN) suivant :
Informations générales sur BizTalk Adapter pour JD Edwards EnterpriseOne
Pour plus d'informations sur l'adaptateur BizTalk pour JD Edwards OneWorld XE, visitez le site Web MSDN suivant :
Informations générales sur BizTalk Adapter pour JD Edwards OneWorld XE
Pour plus d'informations sur la Invite de commande Visual Studio fenêtre, visitez le site Web MSDN suivant :
Informations générales sur la "Visual Studio" fenêtre d'invite
Pour plus d'informations sur les correctifs de BizTalk Server, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
2003907 Informations sur les correctifs de BizTalk Server

Propriétés

Numéro d'article: 2291479 - Dernière mise à jour: vendredi 19 août 2011 - Version: 5.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Service Pack 1 sur le système suivant
    • Microsoft BizTalk Server 2006 R2 Branch
    • Microsoft BizTalk Server 2006 R2 Developer Edition
    • Microsoft BizTalk Server 2006 R2 Enterprise Edition
    • Microsoft BizTalk Server 2006 R2 Standard Edition
Mots-clés : 
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Traduction automatique
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