FIX: augmentation du nombre de threads rapidement lorsque vous utilisez l'adaptateur WCF SQL Server les emplacements de réception dans BizTalk Server 2006 R2, ou dans BizTalk Server 2009

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Numéro d'article: 2300507
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Sommaire

Symptômes

Envisagez le scénario suivant :

  • Utiliser par programme de Windows Communications Foundation (WCF) sur un ordinateur qui exécute Microsoft BizTalk Server 2006 R2 ou de Microsoft BizTalk Server 2009.
  • Vous créez un emplacement de réception qui utilise la carte de SQL Server à partir de la carte de BizTalk Pack 2.0 pour la réception de messages.
Dans ce scénario, vous pouvez rencontrer les problèmes suivants :
  • Instances d'orchestration qui se trouvent dans leMise en attenteétat.
  • L'emplacement de réception ne traite pas les nouveaux messages.
  • Exclusif verrous s'affichent dans les tables de base de données, et vous trouvez des erreurs dans la trace DTC.
  • Vous pouvez voir le DTCXact transaction ouvrir lorsque le programme s'exécute DBCC OPENTRAN.

En outre, si vous surveillez lesProcess\ThreadCount $ BTSNTSvccompteur dans l'Analyseur de performances, vous pouvez voir la valeur de nombre de threads augmente rapidement.

Cause

Ce problème se produit parce que la valeur de délai d'attente de WCF ne synchronise pas avec le délai d'attente de réception lorsqu'il n'y a pas de données à interroger. De plus, WCF s'ouvre un nouveau canal et attend les messages sur le nouveau canal. Cela peut entraîner une situation de fuite de mémoire.

Résolution

Pour résoudre ce problème, appliquez ce correctif.

Plus d'informations sur ce correctif logiciel

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif logiciel est conçu pour corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement sur les systèmes qui rencontrent le problème décrit dans cet article. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous recommandons attendre la prochaine mise à jour de logiciel qui contient ce correctif.

Si le correctif est disponible au téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

RemarqueSi, en plus de problèmes se produisent ou si des procédures de dépannage est nécessaire, vous devez peut-être créer une demande de service distincte. Les coûts habituels du support technique seront appliqueront aux autres questions et problèmes non traités par ce correctif logiciel spécifique. Pour obtenir une liste complète de Microsoft Services de support technique des numéros de téléphone ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :
http://support.Microsoft.com/contactus/?ws=support
RemarqueLe formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif logiciel n'est pas disponible pour ce langage.

Conditions préalables

Vous devez disposer du WCF LOB carte SDK Service Pack 2 (SP2) pour appliquer ce correctif.

Informations sur le redémarrage

Vous n'avez pas à redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations fichier

Anglais de la version de ce correctif possède les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour connaître le décalage entre l'UTC et l'heure locale, utilisez leFuseau horairedans l'onglet leDate et heureélément dans le panneau de configuration.

WCF LOB carte SDK SP2 (x 86-basé)
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Microsoft.ServiceModel.Channels.dll3.0.5308.0280,44803-Août-201002 : 56x 86
WCF LOB carte SDK SP2 (x 64 sur)
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Microsoft.ServiceModel.Channels.dll3.0.5308.0276,35203-Août-201002 : 59x 64


Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section «S'applique à».

Propriétés

Numéro d'article: 2300507 - Dernière mise à jour: vendredi 3 septembre 2010 - Version: 1.0
Mots-clés : 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbprb kbexpertiseinter kbbtsadapters kbbiztalk2009presp1fix kbmt KB2300507 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 2300507
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