診断ツール Fix it: 状況によっては Microsoft .NET Framework 4 用の更新プログラムのインストールに予想以上の時間がかかる問題

文書翻訳 文書翻訳
文書番号: 2570538 - 対象製品
すべて展開する | すべて折りたたむ

現象

Microsoft .NET Framework 4 用の更新プログラムをインストールするときには、ネイティブ イメージ ジェネレーター (NGen.exe) が、コンピューター上で CPU サイクルを高い割合で長時間使用します。この時間は、コンピューターにインストールされているネイティブ イメージの数に応じて異なります。

原因

.NET Framework 4 の更新では、ネイティブ イメージ キャッシュの完全な再生成が必要で、これは非常に長い時間のかかる処理です。一部のコンピューターでは、以前にインストールされたネイティブ イメージとの対話処理により、ネイティブ イメージの再生成で予想よりも時間がかかる場合があります。この問題はセットアップの時間のみに影響しますが、影響する時間は数分から数十分になる可能性があります。コンピューターにインストールされているネイティブ イメージが多いほど、生成の時間が長くなります。

回避策

このページでこの問題を回避するには、「Fix it で解決する」セクションに進んでください。自分でこの問題を解決するには、「自分で解決する」セクションに進んでください。

Fix it で解決する


この問題を自動的に解決するには、[この問題を解決する] ボタンまたはリンクをクリックします。次に、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、Fix it ウィザードの手順に従います。
元に戻す全体を表示する
Microsoft .NET Framework 4、32 ビット版Microsoft .NET Framework 4、64 ビット版Microsoft .NET Framework 4、Itanium 版
元に戻す画像を拡大する
assets fixit1
この問題を解決する
Microsoft Fix it 50735
元に戻す画像を拡大する
assets fixit2
元に戻す画像を拡大する
assets fixit1
この問題を解決する
Microsoft Fix it 50736
元に戻す画像を拡大する
assets fixit2
元に戻す画像を拡大する
assets fixit1
この問題を解決する
Microsoft Fix it 50737
元に戻す画像を拡大する
assets fixit2


注意事項
  • このウィザードは英語版のみである場合があります。しかし、自動的な解決は英語版以外の Windows でも機能します。
  • 問題のあるコンピューターとは別のコンピューターを操作している場合、自動的な解決ツールをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

自分で解決する

この問題を回避するには、以前に生成されたネイティブ イメージを考慮せずに NGen.exe で新しいネイティブ イメージを強制的に生成させることで、ネイティブ イメージの生成時間をある程度短縮できる場合があります。

再生成の時間を改善するには、.NET Framework 4 の更新プログラムをインストールする直前に、管理者特権のコマンド プロンプトを開いて、以下のコマンドを実行します。

重要: 更新プログラムを適用する直前に以下のコマンドを実行します。このようにしないと、コマンドの効果が低くなります。

32 ビット Windows オペレーティング システムを搭載しているコンピューター
%windir%\microsoft.net\framework\v4.0.30319\ngen.exe update /force /queue

64 ビット Windows オペレーティング システムを搭載しているコンピューター
%windir%\microsoft.net\framework\v4.0.30319\ngen.exe update /force /queue

%windir%\microsoft.net\framework64\v4.0.30319\ngen.exe update /force /queue

プロパティ

文書番号: 2570538 - 最終更新日: 2013年11月29日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft .NET Framework 4.0
キーワード:?
kbexpertiseinter kbprb kbsurveynew kbmsifixme kbfixme KB2570538
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com