Symptômes
Après l'installation d'une mise à jour ASP.NET sur un ordinateur qui exécute une application de bureau à deux niveaux Microsoft Visual Studio LightSwitch 2011 ou si les services Internet (IIS) hébergent Microsoft Visual Studio LightSwitch 2011 Server, le serveur peut se bloquer. Lorsque ce problème se produit, les utilisateurs finaux de l'application peuvent rencontrer des échecs de chargement de données dans le programme client.
Cause
Ce problème se produit lorsqu'il manque des données d'assembly nécessaires au bon fonctionnement de la fonction d'unification de l'assembly .NET Framework. Par conséquent, les domaines d'application chargent deux versions du même assembly.
Remarque Ce problème ne peut se produire qu'entre l'installation d'une mise à jour ASP.NET et le redémarrage suivant de l'application ou du serveur.
Résolution
Pour résoudre ce problème, utilisez l'une des méthodes suivantes, adaptée à l'application.
Méthode 1
Pour une application de bureau à deux niveaux, fermez et redémarrez l'application.
Méthode 2
Pour un site Web ou une application de bureau à trois niveaux, utilisez le compte d'administrateur pour redémarrer le serveur exécutant les services IIS.
Méthode 3
Si l'application est en cours de démarrage à l'aide de Microsoft Visual Studio, redémarrez Visual Studio.
Références
Pour plus d'informations sur Visual Studio LightSwitch 2011, reportez-vous au site Web de Microsoft à l'adresse suivante :
Informations générales sur Visual Studio LightSwitch 2011Pour plus d'informations sur la fonction d'unification de l'assembly, reportez-vous au site Web MSDN à l'adresse suivante :
Informations générales sur la fonction d'unification de l'assembly