Makale numarası: 279242 - Son Gözden Geçirme: 19 Ekim 2009 Pazartesi - Gözden geçirme: 7.1

Windows Media Player'da .avi dosyasını yürütmeye çalıştığınızda bir hata iletisi alıyorsunuz

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.

Bu Sayfada

Hepsini aç | Hepsini kapa

Belirtiler

Windows Media Player'da bir .avi dosyasını yürütmeye çalıştığınızda, aşağıdaki hata iletilerinden herhangi birini alabilirsiniz:
Geçersiz Dosya Biçimi Hata=8004022F
Dosya çalınamıyor. Biçim desteklenmiyor. Hata=80040265
Video akışı kayıttan yürütülemiyor: uygun açıcı bulunamadı. Hata=80040255
Akışı işlemek için süzgeç bileşimleri bulunamadı. Hata=80040218
Bu dosya için kaynak süzgeci yüklenemedi. Hata=80040241
Windows Media Player dosya adını açamıyor. Karşıdan yüklenen bir bileşenin yüklenmesini tamamlamak için yeniden başlatmanız gerekir. Lütfen yol ve dosya adının doğru olduğundan emin olun ve yeniden deneyin. Hata=80004005
Bu içeriği açmak için gereken bir veya daha fazla codec bileşeni bulunamadı. Hata=C00D10D1
Video kullanılamıyor, 'VIDS:xxxx' açıcısı bulunamıyor.
Uygun açıcı karşıdan yüklenemiyor Hata=80040200
Bu makale başlangıç ve orta düzeylerdeki bilgisayar kullanıcılarına yöneliktir.

Neden

Video dosyaları oluşturulurken dosya boyutunu küçültmek için, geliştiricinin bilgisayarında yüklü olan bir program (veya sıkıştırıcı) kullanılarak bu dosyalar sıkıştırılabilir. Video dosyasını yürütürken bilgisayarınızda ilgili sıkıştırma biçimini okuyabilen bir açıcı yüklü olmalıdır. Bu programa codec bileşeni adı verilir.

Bilgisayarınızda yüklü olmayan bir codec bileşeninin kullanıldığı bir dosyayı yürütmeye çalıştığınızda, Windows Media Player bu codec bileşenini bir Microsoft sunucusundan yüklemeye çalışır. Codec bileşeni kullanılabiliyorsa, Windows Media Player onu bilgisayarınıza yükler ve daha sonra dosyayı yürütür. Ancak codec bileşeni sunucuda yoksa (örneğin, codec bileşeni Microsoft tarafından oluşturulmamış olabilir), Windows Media Player, bilgisayarınızda bir codec bileşeninin eksik olduğunu bildiren bir ileti görüntüler.

Bazı durumlarda, yürütmek istediğiniz dosya, kullanılamayan veya Windows Media Player ile uyumlu olmayan bir codec bileşeni kullanır. Bu durumda, bu .avi dosyasını Windows Media Player ile yürütemeyebilirsiniz.

Çözüm

Bu sorunu çözmek için, gerekli codec bileşenini bulun ve karşıdan yükleyin.

Başlamadan önce, bilgisayarınızda Windows'un hangi sürümünün çalıştığını bilmeniz gerekir. Windows'un hangi sürümünü çalıştırdığınızı belirlemek için. Windows'da bilgisayar yöneticisi olan bir kullanıcı hesabıyla oturum açmış olduğunuzu doğrulamak için aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/gp/admin (http://support.microsoft.com/gp/admin)
Daha sonra, Windows Media Player sürümünü bilmeniz gerekir. Windows Vista çalıştırıyorsanız, Windows Media Player 11 yüklüdür. Windows XP çalıştırıyorsanız, sürüm bilgisini bulmak için Windows Media Player ile birlikte gelen yardım içeriğine bakın.

Windows Media Player'ın hangi sürümünü çalıştırdığınızı belirledikten sonra, işletim sistemi ve Windows Media Player sürümlerinizle ilgili bölüme gidin.

Not Windows Media Player'ın 6.4 sürümünden önceki bir sürümünü çalıştırıyorsanız, yardım için "Sonraki adımlar" bölümündeki "Windows Media Player'ın eski sürümleri" maddesine gidin.

Windows Vista kullanıyorsanız

Bazı durumlarda, Windows Media Player'da görüntülenen hata iletisinde, gerekli codec bileşeni dosyasıyla ilgili bilgi sağlanır. Hata iletisinde ayrıca codec bileşeni dosyasını karşıdan yüklemek için tıklatabileceğiniz bir bağlantı sağlanır. Dolayısıyla, sorunu çözmek için, .avi dosyasını yürütün ve yardım için Windows Media Player'da görüntülenen hata iletisini denetleyin.

Bu sorunu gidermek için aşağıdaki adımları izleyin.
  1. Windows Media Player'ın yürütmesini istediğiniz .avi dosyasını çift tıklatın.

    Aşağıdakine benzer bir hata alırsınız:
    Windows Media Player bir hatayla karşılaştı. Daha fazla bilgi için simgeyi tıklatın
  2. Aşağıdaki iletiyi almak için Hata Ayrıntıları'nı tıklatın:
    Bu dosyayı yürütmek için bir codec bileşeni gerekiyor
  3. Eksik codec bileşeni ve bu codec bileşeni karşıdan yüklenebiliyorsa ilgili bağlantı hakkındaki bilgileri görüntülenmesi için Web Yardımı'nı tıklatın.

    Not Codec bileşeni bağlantısı kullanılamıyorsa, ilgili codec bileşenini Internet'te arayarak kullanılabilir olduğu bir konum belirlemeye çalışın. Edinmeniz gereken codec bileşenini belirleyemezseniz veya bulamazsanız, codec bileşeni kullanılamıyor olabilir. Veya, Windows Media Player ile uyumlu olmayabilir. Bu nedenle, bu .avi dosyasını Windows Media Player ile yürütemeyebilirsiniz.
  4. Uygun codec bileşeni dosyasını karşıdan yükledikten sonra, sorunun çözülmüş olup olmadığını görmek için .avi dosyasını yeniden yürütün.
.avi dosyasını yürütürken sorunlar oluşmaya devam ediyorsa, bu sorunla ilgili diğer kaynakları bulmak üzere "Sonraki adımlar" bölümüne gidin.

Windows XP ile birlikte Windows Media Player 11, Windows Media Player 10 veya Windows Media Player 9 kullanıyorsanız

Bazı durumlarda, Windows Media Player'da görüntülenen hata iletisinde, gerekli codec bileşeni dosyasıyla ilgili bilgi sağlanır. Hata iletisinde ayrıca codec bileşeni dosyasını karşıdan yüklemek için tıklatabileceğiniz bir bağlantı sağlanır. Dolayısıyla, sorunu çözmek için, .avi dosyasını yürütün ve yardım için Windows Media Player'da görüntülenen hata iletisini denetleyin.

Bu sorunu gidermek için aşağıdaki adımları izleyin.
  1. Windows Media Player'ın yürütmesini istediğiniz .avi dosyasını çift tıklatın.
  2. Şimdi Yürütülüyor altında, dosya adının önündeki ünlem işaretini sağ tıklatın ve sonra Hata Ayrıntıları'nı tıklatın.
  3. Eksik codec bileşeni ve bu codec bileşeni karşıdan yüklenebiliyorsa ilgili bağlantı hakkındaki bilgileri görüntülenmesi için Web Yardımı'nı tıklatın.

    Not Codec bileşeni bağlantısı kullanılamıyorsa, ilgili codec bileşenini Internet'te arayarak kullanılabilir olduğu bir konum belirlemeye çalışın. Edinmeniz gereken codec bileşenini belirleyemezseniz veya bulamazsanız, codec bileşeni kullanılamıyor olabilir. Veya, Windows Media Player ile uyumlu olmayabilir. Bu nedenle, bu .avi dosyasını Windows Media Player ile yürütemeyebilirsiniz.
  4. Uygun codec bileşeni dosyasını karşıdan yükledikten sonra, sorunun çözülmüş olup olmadığını görmek için .avi dosyasını yeniden yürütün.
.avi dosyasını yürütürken sorunlar oluşmaya devam ediyorsa, bu sorunla ilgili diğer kaynakları bulmak üzere "Sonraki adımlar" bölümüne bakın.

Windows XP ile birlikte Windows Media Player 7.1, Windows Media Player 7 veya Windows Media Player 6.4 kullanıyorsanız

Bazı durumlarda, hata iletisinde FourCC tanımlayıcısı olarak bilinen codec bileşeni tanımlayıcısı bulunur. Codec bileşenini oluşturan üreticiyi bulmak için FourCC tanımlayıcısını kullanabilirsiniz. Daha sonra, gerekli codec bileşenini üreticisinden edinip edinemediğinize bakın.

Bu sorunu gidermek için aşağıdaki adımları izleyin.
  1. Başlat'ı ve ardından Çalıştır'ı tıklatın. Aşağıdaki komutu kopyalayıp kutusuna yapıştırın (veya yazın) ve ENTER tuşuna basın:
    mplay32.exe
  2. Dosya menüsünde 'ı tıklatın, yürütmek istediğiniz .avi dosyasını bulun ve sonra dosyayı Windows Media Player'ın üzerine sürükleyin.
  3. Hata iletisini aldığınızda, FourCC tanımlayıcısını denetleyin. FourCC tanımlayıcısı varsa bunu not alın. İlgili .avi dosyasının codec bileşenini bulmak için kullanabileceğiniz benzersiz FourCC tanımlayıcısı, "vids:" veya "vidc:" sonrasındaki dört karakterdir.

    Örneğin dizede "vids:vcr2" görünüyorsa, FourCC tanımlayıcısı "vcr2" değeridir.

    Not FourCC tanımlayıcısı hata iletisinde listelenmiyorsa, bu .avi dosyasını yürütmek için Windows Media Player'ı kullanamazsınız.
  4. Aşağıdaki Web sitesini ziyaret edin ve sayfanın Content Overview (İçeriğe Genel Bakış) bölümünde bulunan Video codecs (Video codec bileşenleri) bağlantısını tıklatın:
    http://www.fourcc.org/ (http://www.fourcc.org/)
  5. Codec bileşenini oluşturan üreticiyi bulmak için FourCC tanımlayıcısını kullanın. Örneğin, 3.adımda FourCC tanımlayıcısı "vcr2" değeriydi. Dolayısıyla, codec bileşenini ve üreticisini bulmak için FOURCC sütununda "vcr2" değerini arayın. Bu örnekte, codec bileşeninin adı olarak "ATI Video Codec 2" ve sahibi (veya üreticisi) olarak "ATI Technologies" listelendiğini göreceksiniz.

    Listelenen bir codec bileşeni veya üretici bulamazsanız, FourCC tanımlayıcısını kullanarak codec bileşenini ve üreticisini Internet'te aramayı deneyebilirsiniz.

    Not Tüm üreticilerin codec bileşenlerini karşıdan yüklenmek üzere sağlamadıklarını unutmayın. Gerekli codec bileşenini üreticisinden edinemiyorsanız, bu .avi dosyasını yürütmek için Windows Media Player'ı kullanamazsınız.
  6. Bu Web sitesinde üretici için bir bağlantı sağlanıyorsa, gerekli codec bileşenini edinmek üzere üreticiye başvurmak için bu bağlantıyı kullanın. Üreticinin bağlantısı kullanılamıyorsa, üreticinin iletişim bilgileri için Microsoft Bilgi Bankası'nda arama yapmayı deneyin.Üreticiye başvurma konusunda bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki uygun makale numarasını tıklatın:
    65416  (http://support.microsoft.com/kb/65416/ ) Donanım ve yazılım satıcıları iletişim bilgileri, A-K

    60781  (http://support.microsoft.com/kb/60781/ ) Donanım ve yazılım satıcıları iletişim bilgileri, L-P

    60782  (http://support.microsoft.com/kb/60782/ ) Donanım ve yazılım satıcıları iletişim bilgileri, Q-Z
    Microsoft, teknik destek bulmanıza yardımcı olmak üzere üçüncü taraf iletişim bilgilerini sağlamaktadır. Bu iletişim bilgileri önceden haber verilmeksizin değiştirilebilir. Microsoft bu üçüncü taraf iletişim bilgilerinin doğruluğunu garanti etmez. Microsoft Bilgi Bankası Web sitesinde üreticinin bağlantısı yoksa, Internet'te arama yapmayı deneyin.
  7. Uygun codec bileşeni dosyasını karşıdan yükledikten sonra, sorunun çözülmüş olup olmadığını görmek için .avi dosyasını yeniden yürütün.
.avi dosyasını yürütürken sorunlar oluşmaya devam ediyorsa, bu sorunla ilgili diğer kaynakları bulmak üzere "Sonraki adımlar" bölümüne gidin

SONRAKİ ADIMLAR

Bu yöntemler size yardımcı olmadıysa, tanıdığınız birinden yardım isteyebilirsiniz. Windows Media Player'ın çalıştırdığınız sürümü için sorun giderme Web sitesini de ziyaret edebilirsiniz. Windows Media Player ile ilgili sorunları giderme hakkında daha fazla bilgi için aşağıdaki Microsoft Web sitelerini ziyaret edin: Sorununuza yönelik başka çözümler bulmak için Microsoft Müşteri Destek Hizmetleri Web sitesini de kullanabilirsiniz. Microsoft Müşteri Destek Hizmetleri Web sitesinin sağladığı bazı hizmetler şunlardır:
  • Aranabilir Bilgi Bankası (http://support.microsoft.com/search/?adv=1) : Microsoft ürünleri hakkında teknik destek bilgileri ve kendi kendinize yardım araçlarını arayın.
  • Çözüm Merkezleri (http://support.microsoft.com/select/?target=hub) : Ürüne özgü sık sorulan soruları ve önemli destek konularını görüntüleyin.
  • Microsoft Müşteri Destek Haber Grupları (http://www.microsoft.com/communities/newsgroups/default.mspx) : Ortaklarınıza, meslektaşlarınıza ve Microsoft'un En Değerli Uzmanları'na (MVP) danışın.
  • Diğer Destek Seçenekleri (http://support.microsoft.com/default.aspx?pr=csshome) : Web'i kullanarak bir soru sorun, Microsoft Müşteri Destek Hizmetleri'ne başvurun veya görüş bildirin.
Bu Microsoft Web sitelerini kullandıktan sonra sorularınıza yanıt bulamazsanız veya Microsoft Destek Hizmetleri Web sitesinde bir çözüm bulamazsanız, Destek Hizmetleri'ne başvurmak üzere aşağıdaki bağlantıyı tıklatın:
http://support.microsoft.com/contactus (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fcontactus)

Daha fazla bilgi

.avi dosyalarının birkaç farklı ses veya video biçimi içerebileceğini unutmayın. Bir .avi dosyasını oynatmak için, .avi dosya oynatıcısını ve avi dosyasını açmak etmek için uygun codec bileşenini .kullanmanız gerekir. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
138261  (http://support.microsoft.com/kb/138261/ ) Hata iletisi: video kullanılamıyor, açıcı bulunamıyor (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)
230687  (http://support.microsoft.com/kb/230687/ ) Hata İletisi: Uygun Açıcı Karşıdan Yüklenemedi
Microsoft, MPEG4 sürüm 3 codec'i kullanılarak oluşturulmuş olan .avi dosyalarının yürütülmesini desteklememektedir. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
316992  (http://support.microsoft.com/kb/316992/ ) Windows Media Player multimedya dosyası biçimleri
138261  (http://support.microsoft.com/kb/138261/ ) Hata İletisi: Video Kullanılamıyor, Açıcı Bulunamıyor (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)
230687  (http://support.microsoft.com/kb/230687/ ) Hata İletisi: Uygun Açıcı Karşıdan Yüklenemedi
814629  (http://support.microsoft.com/kb/814629/ ) Bir AVI dosyasını yürütürken pencere modu ile tam ekran komut istemi arasında geçiş yaptığınızda Windows Media Player yanıt vermeyi durduruyor veya hata iletisi görüntülüyor (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)
278947  (http://support.microsoft.com/kb/278947/ ) Bir .avi dosyasını yürütürken "Uygun açıcı karşıdan yüklenemiyor." hata iletisi (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)
291818  (http://support.microsoft.com/kb/291818/ ) Windows XP için Windows Media Player'da codec'ler nasıl otomatik olarak karşıdan yüklenir (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)
842186  (http://support.microsoft.com/kb/842186/ ) Windows Media Player'da "Uygun açıcı karşıdan yüklenemiyor" hata iletisini alıyorsunuz (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows Media Player 8.01
  • Microsoft Windows Media Player 8.01
  • Microsoft Windows Media Player 7.1
  • Microsoft Windows Media Player 6.4
  • Microsoft Windows Media Player 7.0
  • Microsoft Windows Media Player 11
  • Microsoft Windows Media Player 10
Anahtar Kelimeler: 
kbresolve kbfile kbprb KB279242