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Symptômes

Considérez le scénario suivant :

  • Un serveur web est publié à l’aide de Microsoft Forefront Unified Access Gateway (UAG) 2010.

  • Forefront UAG 2010 utilise des tickets de délégation de contrainte de Kerberos (KCD) de déléguer les informations d’identification de l’utilisateur au serveur web publié.

  • Le serveur web publié rejette le ticket KCD qui est fourni par Microsoft Forefront UAG 2010 et renvoie une erreur 401.

Dans ce scénario, Forefront UAG 2010 entre alors dans une boucle de demande/réessayer. En outre, les conditions suivantes peuvent se produire pour le processus de travail w3wp.exe Forefront UAG lors de la boucle/nouvelle tentative de demande :

  • Une augmentation rapide de la consommation de mémoire

  • Utilisation élevée du processeur

Cause

Ce problème est généralement causé par un problème affectant le programme d’installation KCD ou un problème qui existe sur le serveur web publié.

Si Forefront UAG a authentifié l’utilisateur et a obtenu avec succès un ticket KCD vers le serveur publié, le programme n’attend de recevoir une erreur 401 à partir du serveur web publié lors de la négociation de KCD avec le serveur publié. Dans ces conditions, Forefront UAG essaie de traiter l’erreur 401 en obtenant un nouveau ticket KCD, puis de le resoumettre la demande au serveur web publié. Cette activité entraîne une boucle/nouvelle tentative de demande se produit.

Important Nouvelle tentative de la demande/boucle est corrigé dans Forefront Unified Access Gateway 2010 Service Pack 3 (SP3). Forefront UAG 2010 SP3 ne résout pas le problème d’authentification sous-jacent car que le problème ne se produit pas dans Forefront UAG. Si Forefront UAG reçoit l’erreur 401 inattendue à partir du serveur web publié, car la négociation avec le serveur web publié de KCD a échoué, l’erreur 401 est renvoyé au client. Puis, le client reçoit une invite d’authentification. Toutefois, le client ne pourra pas effectuer l’authentification en raison du problème sous-jacent.

Remarque : Consultez la section « Plus informations » pour plus d’informations sur certaines des causes de l’échec d’authentification sur le serveur web publié.

Résolution

Pour résoudre ce problème, installez le service pack qui est décrit dans l’article suivant de la Base de connaissances Microsoft :

2744025 description de Forefront Unified Access Gateway 2010 Service Pack 3

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Prise en charge de client de Microsoft a enregistré plusieurs occurrences de ce problème dans les scénarios de publication Outlook Anywhere. Dans ces cas, le problème a provoqué l’authentification KCD sur le serveur d’accès Client (CAS) Basculer pour RPC sur le trafic HTTP. Pour plus d’informations sur un problème semblable, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2545850 les utilisateurs ne peuvent pas accéder à un site hébergé par IIS après avoir modifié le mot de passe pour le serveur dans Windows 7 ou dans Windows Server 2008 R2Remarques

  • Le correctif qui est décrit dans la base de connaissances 2545850 doit être installé sur les autorités de certification, pas sur le serveur Forefront UAG.

  • Pour contourner ce problème sans installer le correctif 2545850, redémarrez les autorités de certification. Cette solution de contournement restera en vigueur jusqu'à ce que la prochaine fois que vous rencontrez ce problème.

Le web server peut également renvoyer une erreur 401 en raison d’un problème d’autorisations ou si KCD n’est pas configuré correctement. Par exemple, le Service de nom Principal (SPN) qui Forefront UAG délègue ne peuvent pas être inscrits sur le compte de serveur web cible ou le compte de service du processus. Pour plus d’informations sur la configuration de la délégation contrainte Kerberos, accédez au site Web TechNet de Microsoft suivant :

Configuration de l’authentification unique avec Kerberos de délégation contrainte

Références

Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

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