Que faire si votre ordinateur avec un programme Office pour Mac installé est infecté par une macro virus

Traductions disponibles Traductions disponibles
Numéro d'article: 291824 - Voir les produits auxquels s'applique cet article
Pour une version de Microsoft Word 98 de cet article, voir 181080.
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article décrit quelles sont les virus de macro, que faire si vous pensez que votre ordinateur peut dispose d'un virus de macro Word et comment vous assurer que vos documents ne pas être infectés par un virus de macro.

Plus d'informations

Le premier macrovirus a été découvert en été de 1995. Depuis, autres macrovirus ont est apparu.

Un macrovirus est un programme malveillant qui est écrit en utilisant le langage de macro d'un programme tel que Word. Le virus propage entre les fichiers de données et peuvent endommager vos fichiers ou un système d'exploitation de votre ordinateur.

Virus de macro Word ne voyage pas librement sur Internet ou tout autre support ; ils peuvent n'être transférés que lorsqu'un utilisateur ouvre un document ou modèle contenant la macro virus.

Impossible de transférer les virus de macro par courrier électronique, sauf si un document affecté est incorporé dans le message électronique et le destinataire ouvre le document.

Symptômes d'un virus de macro

Voici quelques symptômes de virus de macro Word sont connus pour affecter Word et Word documents :
  • Lorsque vous essayez d'enregistrer un document, Word vous uniquement permet d'enregistrer le document comme un modèle.

    -ou-
  • L'icône du fichier ressemble à un modèle plutôt que dans un document.

    -ou-
  • Lorsque vous ouvrez un document, une boîte de dialogue indiquant le numéro 1 s'affiche.

    -ou-
  • Les commandes de macro et personnaliser apparaissent plus dans le menu Outils .

    -ou-
  • Nouvelles macros apparaissent dans la liste des macros. Macros AutoOpen et FileSaveAs peuvent également apparaissent ; si vous avez déjà macros par ces noms, leur contenu peut être modifié par le virus de macro.

    -ou-
  • Messages inhabituels ou inattendus apparaître lorsque vous ouvrez un document Word ou modèle.
notes
  • Dans Word 2001 pour Mac, vous pouvez définir l'option de protection contre les virus macro (dans le menu Edition , cliquez sur Options et puis cliquez sur l'onglet Général ) qui est conçu pour vous avertir si vous ouvrez un fichier qui contient des macros, indépendamment de ce que les macros. Dans Word X pour Mac, vous pouvez définir l'option de protection contre les virus macro en cliquant sur Options dans le menu de Word , en cliquant sur l'onglet Général , puis en cliquant sur l'option de protection contre les virus macro pour activer ou désactiver. Dans Word 2004 pour Mac, vous pouvez définir l'option de protection contre les virus macro en cliquant sur Options dans le menu de Word , cliquez sur l'onglet sécurité , puis en cliquant sur l'option de protection contre les virus macro pour activer ou désactiver. Pour une solution permanente, vous devez utiliser un logiciel antivirus conçu spécifiquement pour détecter et empêcher les virus de macro.
  • Word ne pas Recherchez les virus de macro ou supprimer des virus de macro des documents existants et des modèles. Il seulement vous avertit si le document que vous ouvrez contient des macros. Puis vous pouvez ouvrir le document avec les macros actives ou ouvrez-le avec les macros désactivées. Vous ne devez pas ouvrir un document actif macros, sauf si vous êtes absolument assurer que le document ne contient aucun virus de macro dangereux.
  • Tiers antivirus doivent être mis à jour fréquemment pour rester efficaces. Contactez le fournisseur pour les informations de mise à jour.
  • Disinfectant, un utilitaire antivirus gratuits pour Mac OS 9 et les versions antérieures, ne permet pas de protéger contre les virus de macro. Développement du programme Disinfectant a été abandonné. La version finale du Disinfectant est la version 3.7.1.

    Pour des liens vers un logiciel antivirus en cours, consultez les liens qui se trouvent dans la section suivante. ?S Norton AntiVirus, par Symantec et Sophos deux conçu pour Mac OS X, les deux analyse de virus de macro.

Installez un programme antiviru

Pour une solution à long terme pour les virus de macro, installez un logiciel antivirus est conçu spécifiquement pour détecter les virus de macro. Pour plus d'informations sur les fournisseurs antivirus, y compris logiciel capable de détecter et empêcher les virus de macro, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
49500 Liste des fournisseurs de logiciels antivirus
Microsoft fournit des coordonnées de sociétés tiers afin de rechercher le support technique. Ces informations peuvent modifiées sans préavis. Microsoft ne garantit pas l'exactitude des informations tiers contact concernant.

Que faire lorsque vous pensez que votre ordinateur est peut-être un virus de macro

Utilisez les méthodes suivantes que solutions temporaires uniquement lorsque vous pensez que votre ordinateur peuvent soit un virus de macro.

Méthode 1: désactiver les macros et copiez le texte dans un nouveau document

Si vous ne rencontrez pas des symptômes décrits plus haut dans cet article, mais vous ne souhaitez pas être affecté par un virus de macro, maintenez la touche MAJ enfoncée lorsque vous ouvrez un fichier qui peut être infecté par un virus de macro. En appuyant sur MAJ empêche les macros Word automatiquement de s'exécuter ; si un macrovirus est présent, il n'est pas chargé.

Méthode 2: supprimer la macro et récupérer le document

Si vous rencontrez les problèmes décrits plus haut dans cet article, ou si vous pensez que vous avez un virus de macro pas décrite dans cet article, procédez comme suit pour supprimer la macro suspect et corriger document concerné.

note Il s'agit uniquement d'une solution temporaire ; étant donné que nouvelles macros sont en cours créés, ces étapes peuvent ne fonctionne pas sur les nouvelles macros.
  1. Fermez Word et déplacez le modèle Normal vers le Bureau.
  2. Effectuez une copie de sauvegarde d'un fichier concerné.
  3. Ouvrez Word. Dans le menu Fichier , cliquez sur Ouvrir .
  4. Accédez au dossier qui contient le fichier concerné.
  5. Cliquez pour sélectionner le fichier concerné.
  6. Appuyez sur la touche MAJ et cliquez sur Ouvrir . Poursuivez maintenant la touche MAJ jusqu'à ce que le fichier concerné soit ouvert dans Word.

    note Maintenant la touche MAJ lors de l'ouverture d'un fichier empêche les macros Word automatique en cours d'exécution.
  7. Pour supprimer une macro suspect, procédez comme suit :
    1. Dans le menu Outils , pointez sur macro , puis cliquez sur macros .
    2. Dans le Macros disponibles dans contextuel menu, sélectionnez Tous les modèles active et des documents .
    3. Sélectionnez la macro suspect, puis cliquez sur Supprimer . Cliquez sur Oui lorsque vous êtes invité si vous souhaitez supprimer la macro.
    4. Répétez les étape c pour toutes les macros suspectes.
    5. Cliquez sur Annuler pour fermer la boîte de dialogue macro .
  8. Pour récupérer le texte d'un document infecté, procédez comme suit :
    1. Sélectionner tout le document en appuyant sur commande + A ou en cliquant sur Sélectionner tout dans le menu Edition .
    2. Supprimer la dernière marque de paragraphe du document de la sélection en appuyant sur MAJ + flèche vers la gauche.
    3. Dans le menu Edition , cliquez sur Copier .
    4. Dans le menu Fichier , cliquez sur Nouveau . Sélectionnez le modèle que vous souhaitez utiliser, puis cliquez sur OK .
    5. Dans le menu Edition , cliquez sur Coller .
    6. Répétez l'étape 7 pour vous assurer que la macro virus-containing n'a pas répliqué.
    7. Enregistrez le document.
  9. Répétez ces étapes pour tous les documents que vous suspectez susceptibles de contenir un virus de macro.
note Si la méthode 2 ne fonctionne pas, essayez la méthode 3.

Méthode 3: utiliser la boîte de dialogue Organiser pour nettoyer temporairement un virus de macro

Utiliser la boîte de dialogue Organiser pour nettoyer le virus de macro. Gardez à l'esprit que si vous ouvrez d'autres fichiers après avoir ouvert le fichier infecté, ces fichiers probablement sont infectés ainsi.

Pour supprimer le virus le modèle Normal, procédez comme suit :
  1. Fermez tous les documents. Si un document infecté est ouvert, il peut facilement réinfecter le modèle Normal.
  2. Dans le menu Outils , cliquez sur Modèles et compléments , puis cliquez sur le bouton Bibliothèque multimédia .
  3. Cliquez sur l'onglet macros , puis renommer ou supprimer toutes les macros suivantes :
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • « FichierEnregistrer »
    • FileSaveAs
    • Macros
    • ToolsMacro
  4. Cliquez sur Fermer .
  5. Maintenez la touche MAJ enfoncée pendant que vous cliquez sur Enregistrer tout dans le menu Fichier pour enregistrer le modèle.
Pour supprimer un virus de macro d'un document infecté :

Si un fichier est infecté, utilisez la même méthode que dans les étapes 1 à 5, mais supprimer les macros de à la fois le modèle Normal et dans le document infecté modèle dans l'organisateur. Lorsque vous avez terminé, maintenez la touche MAJ enfoncée pendant que vous cliquez sur Enregistrer tout dans le menu Fichier , puis déplacez vers le fichier suivant. Gardez à l'esprit que chaque fois que vous ouvrez un fichier infecté, elle infecte votre modèle Normal, donc vous devez supprimer plusieurs fois les macros le modèle Normal.

Méthode 4: Insérer le fichier infecté dans un nouveau document

Cette méthode est particulièrement utile avec le virus de macro « CAP », qui supprime la macro , puis Personnaliser dans le menu Outils .

note Dans ce cas, Modèles et compléments dans le menu Outils peuvent ne pas fonctionner.
  1. Fermez Word et le déplacez le modèle normal sur le Bureau.
  2. Ouvrez Word et vérifiez que macro et personnaliser apparaissent dans le menu Outils .
  3. Ouvrez un nouveau document. Dans le menu Insertion , cliquez sur fichier .
  4. Accédez au dossier contenant le fichier concerné.
  5. Cliquez pour sélectionner le fichier concerné.
  6. Appuyez sur la touche MAJ et cliquez sur Ouvrir . Continuez à maintenir la touche MAJ jusqu'à ce que le fichier concerné est ouvert dans Word.
    note Maintenant la touche MAJ lors de l'ouverture d'un fichier empêche Word automatiquement macros en cours d'exécution.
  7. Pour vérifier si toutes les macros figurent dans le nouveau document (aucun doit figurer), pointez sur macro dans le menu Outils , puis cliquez sur macros . Dans la Macros disponibles dans contextuelle liste, cliquez sur Tous les modèles et documents actifs . Sous Nom de macro , sans macros doivent être répertoriés. Cliquez sur Annuler .
  8. Enregistrez le fichier sous un nom de fichier différent.
  9. Supprimez le fichier infecté.

Propriétés

Numéro d'article: 291824 - Dernière mise à jour: mercredi 31 janvier 2007 - Version: 3.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office 2004 pour Mac Edition Standard
  • Microsoft Office v. X pour Mac
  • Microsoft Office 2001 pour Mac
  • Microsoft Word 2004 for Mac
  • Microsoft Word X pour Mac
  • Microsoft Word 2001 pour Mac
Mots-clés : 
kbmt kbinfo KB291824 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 291824
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com