Help and Support

Makale numarası: 315353 - Son Gözden Geçirme: 18 Mayıs 2005 Çarşamba - Gözden geçirme: 4.0

Windows XP'de bir program yüklediğinizde "Windows Installer Hizmetine Erişilemedi" hata iletisi

ÖNEMLİ: Bu makale, kayıt defterini değiştirmeyle ilgili bilgiler içermektedir. Kayıt defterini değiştirmeden önce, yedeklediğinizden ve bir sorun çıkması durumunda kayıt defterini nasıl geri yükleyeceğinizi anladığınızdan emin olun. Kayıt defterini yedekleme, geri yükleme ve düzenleme ile ilgili bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986  (http://support.microsoft.com/kb/256986/Tr/ ) Microsoft Windows kayıt defterinin açıklaması
Hepsini aç | Hepsini kapa

Belirtiler

Microsoft Windows XP'de, Windows XP için Microsoft Plus! veya Microsoft Office 2003 gibi bir program yüklemeye çalıştığınızda, aşağıdaki hata iletisini alabilirsiniz:
Windows Installer hizmetine erişilemedi.
Bu durum, Windows'u güvenli
modda çalıştırıyorsanız veya Windows Installer düzgün
yüklenmemişse oluşabilir. Yardım için destek personeline başvurun.

Neden

Bu sorun, aşağıdaki koşullardan her ikisi de doğru olduğunda oluşabilir:
  • Windows XP'yi Normal modda kullanıyorsunuz.
  • Windows XP'nin içerdiği Windows Installer Hizmeti kayıtlı değil veya bozuk.

€”zm

Bu sorunu çözmek için aşağıdaki adımları izleyin:
  1. Bilgisayarınızda yönetici olarak oturum açın.
  2. Başlat'ı ve sonra da Çalıştır'ı tıklatın.
  3. kutusuna cmd yazın ve Tamam'ı tıklatın.
  4. Komut istemine msiexec.exe /unregister yazıp ENTER tuşuna basın.
  5. Msiexec /regserver yazıp ENTER tuşuna basın.
  6. SYSTEM hesabının Windows kayıt defterindeki HKEY_CLASSES_ROOT kovanı için tam denetim erişimi izinleri olduğunu doğrulayın. Bazı durumlarda, Administrator hesaplarını da eklemeniz gerekebilir. Bunu yapmak için:UYARI: Kayıt Defteri Düzenleyicisi'ni yanlış kullanırsanız, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilirsiniz. Microsoft, Kayıt Defteri Düzenleyicisi'nin yanlış kullanımı sonucunda ortaya çıkan sorunları çözebileceğiniz konusunda garanti vermez. Kayıt Defteri Düzenleyicisi'ni kullanmak kendi sorumluluğunuzdadır.
    1. Başlat'ı ve sonra Çalıştır'ı tıklatın, kutusuna regedit yazın ve Tamam'ı tıklatın.
    2. Aşağıdaki kayıt defteri kovanını tıklatın:
      HKEY_CLASSES_ROOT
    3. Düzen menüsünde, İzinler'i tıklatın.
    4. Grup veya kullanıcı adları altında SYSTEM listelenmiyorsa, Ekle'yi tıklatın, Bu konumdan kutusunda yerel bilgisayar adının göründüğünden emin olun, Seçilecek nesne adlarını girin kutusuna system yazın, Adları Denetle'yi ve sonra da Tamam'ı tıklatın.
    5. Grup veya kullanıcı adları listesinden SYSTEM öğesini tıklatın ve SYSTEM İzinleri kutusundaki İzin Ver altında Tam Denetim onay kutusunu işaretleyin.
    6. Uygula'yı tıklatın, Tamam'ı tıklatın ve sonra da Kayıt Defteri Düzenleyicisi'nden çıkın.
  7. Bilgisayarı yeniden başlatın. Sorun giderilmezse, Windows XP'yi onarın. Windows XP'yi onarma hakkında ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
    315341  (http://support.microsoft.com/kb/315341/ ) Windows XP'nin yerinde yükseltilmesi (yeniden yüklemesi) nasıl gerçekleştirilir

Bu makaledeki bilginin uygulandigi durum:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Office Standard Edition 2003
Anahtar Kelimeler: 
kbtshoot kberrmsg kbprb KB315353

Makale çevirileri

 

Related Support Centers