Удаление метаданных из документов в Word 2003

Переводы статьи Переводы статьи
Код статьи: 825576 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

В данной статье описаны различные способы уменьшения объема метаданных в документах Word.

При создании, открытии или сохранении документа в Microsoft Office Word 2003 в него могут быть добавлены сведения, которые не всем хочется предоставлять другим пользователям при распространении документа в электронной форме. Эти сведения называются метаданными и используются для оптимизации редактирования, просмотра, хранения и извлечения документов Microsoft Office.

Доступ к некоторым метаданным легко получить через интерфейс пользователя Word. К другим метаданным получить доступ гораздо сложнее. Например, иногда для этого требуется открыть документ в низкоуровневом редакторе двоичных файлов. Ниже приведены примеры метаданных, которые могут храниться в документах.
  • Фамилия пользователя
  • Инициалы пользователя
  • Название компании или организации
  • Имя компьютера
  • Имя сетевого сервера или жесткого диска, на котором хранится документ
  • Другие свойства файла и сводные сведения
  • Невидимые элементы внедренных объектов OLE
  • Изменения документа
  • Версии документа
  • Сведения о шаблоне
  • Скрытый текст
  • Примечания
Метаданные создаются в документах Word разными способами, поэтому нет единой методики, позволяющей удалять из документов сразу все метаданные. В приведенных ниже разделах содержатся сведения о том, где в документах Word могут храниться метаданные.

В данной статье описаны различные способы уменьшения объема метаданных в документах Word.

Корпорация Майкрософт приводит примеры программного кода только для иллюстрации и не предоставляет явных или подразумеваемых гарантий относительно их пригодности для применения в пользовательских приложениях. Примеры в данной статье рассчитаны на пользователя, имеющего достаточный уровень знаний соответствующего языка программирования и необходимых средств разработки и отладки. Специалисты служб технической поддержки Майкрософт могут пояснить назначение определенной процедуры, но модификация примеров для обеспечения дополнительных возможностей или разработка процедур для конкретных задач заказчика не предусмотрена. Дополнительные сведения об использовании образцов кода, приведенных в данной статье, см. в следующей статье базы знаний Майкрософт:
290140 Выполнение примеров кода для программ Office XP, встречающихся в статьях базы знаний (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Автоматическое удаление личных сведений при сохранении документов

При сохранении документов Word личные сведения могут удаляться из них автоматически. Чтобы задать соответствующий параметр, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Параметры.
  2. Откройте вкладку Безопасность, установите флажок Удалять личные сведения из свойств файла при сохранении в разделе Параметры конфиденциальности и нажмите кнопку ОК.
Примечание. Это оптимальный способ удаления личных сведений при сохранении документа Word.

Удаление имени пользователя из документов вручную

Чтобы просмотреть или изменить свое имя пользователя, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Параметры и откройте вкладку Пользователь.

    Появятся указанные ниже поля.
    Имя
    Инициалы
    Почтовый адрес
  2. Чтобы устранить эти сведения из документов, очистите соответствующие поля или введите в них строки, не содержащие идентификационной информации, и нажмите кнопку ОК.
Примечание. Эта информация будет включаться во все новые документы вместо значений по умолчанию, указанных при установке пакета Office. Однако в документах, созданных ранее, могут сохраниться прежние сведения.

Удаление кратких личных сведений вручную

При создании или сохранении документа Word в нем могут быть сохранены краткие личные сведения. Просмотреть эти сведения можно несколькими способами.
  • Откройте документ. Выберите в меню Файл пункт Свойства. На вкладках Документ, Статистика, Состав и Прочие могут быть заданы различные свойства, такие как фамилия пользователя, фамилия его руководителя и название его учреждения.
  • Запустите проводник Windows, щелкните документ правой кнопкой мыши и выберите пункт Свойства. Те или иные метаданные могут быть указаны на вкладках диалогового окна Свойства.
  • Для чтения свойств, отображаемых в диалоговом окне Свойства, можно использовать макрос Microsoft Visual Basic для приложений (VBA) или другой программный код.
Чтобы удалить краткие личные сведения из существующего документа или шаблона, выполните указанные ниже действия.
  1. Откройте документ или шаблон.
  2. Выберите в меню Файл пункт Свойства.
  3. Откройте вкладку Документ и очистите поля Автор, Руководитель, Учреждение и все прочие поля, содержащие сведения, распространять которые нежелательно.
  4. Откройте вкладку Прочие и удалите все свойства, содержащие сведения, которые желательно не распространять.
  5. Нажмите кнопку ОК.

    Выберите в меню Файл пункт Сохранить, а затем — команду Выход.
После выполнения этих действий документ будет сохранен без кратких личных сведений.

Удаление кратких личных сведений вручную при наличии подключения к сети

Если установлено подключение к сети, сетевое имя пользователя может отображаться в поле Автор на вкладке Документ и в поле Автор изменений на вкладке Статистика. Это возможно даже в том случае, если все другие личные сведения удалены с компьютера.

Чтобы удалить краткие личные сведения из документа при наличии подключения к сети, выполните указанные ниже действия.
  1. Если документ хранится на сетевом сервере, скопируйте его на локальный жесткий диск.
  2. Запустите компьютер, но не входите в сеть. Когда появится диалоговое окно входа в сеть, нажмите кнопку Отмена или клавишу "ESCAPE".

    Примечание. Если после нажатия клавиши "ESCAPE" система Windows не загружается (это возможно, например, если на компьютере установлена система Microsoft Windows NT), продолжить выполнение процедуры не удастся.
  3. Откройте документ.
  4. Выберите в меню Файл пункт Свойства.
  5. Откройте вкладку Документ и очистите поля Автор, Руководитель, Учреждение и все остальные поля, содержащие сведения, распространять которые нежелательно.
  6. Откройте вкладку Прочие и удалите все свойства, содержащие сведения, которые желательно не распространять.
  7. Нажмите кнопку ОК.

    Выберите в меню Файл пункт Сохранить, а затем — команду Выход.
При входе в сеть не открывайте файл. Если сделать это, в файл может быть записано сетевое имя пользователя. Однако копировать файл на сетевой сервер или на дискету при помощи проводника можно.

Удаление примечаний из документов вручную

Приложение Word позволяет добавлять в документы примечания. Обычно примечания содержат имя их автора, чтобы можно быть понять, кто их добавил.

Примечания обычно отображаются как выделенный текст. Примечание можно удалить, щелкнув его правой кнопкой мыши и выбрав пункт Удалить примечание.

Если имя пользователя удалено из диалогового окна Параметры в соответствии с описанной в разделе "Удаление имени пользователя из документов вручную" процедурой, создаваемые примечания не будут содержать имени пользователя.

Удаление колонтитулов из документов вручную

Колонтитулы в документах могут содержать идентификационные сведения. Чтобы удалить сведения из колонтитулов, выполните указанные ниже действия.
  1. Выберите в меню Вид пункт Колонтитулы.
  2. В начале и в конце каждой страницы в документе появятся колонтитулы.

    При необходимости их можно изменить.
  3. Нажмите на панели инструментов Колонтитулы кнопку Закрыть.

Удаление записанных исправлений вручную

Документы могут содержать записанные исправления, позволяющие узнать, кто внес в документ определенные изменения. При утверждении или отклонении исправлений текст сохраняется в документе, а записи исправлений удаляются.

Чтобы принять или отклонить исправления, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Исправления, чтобы включить функцию записи исправлений.
  2. С помощью кнопок Предыдущее и Следующее на панели инструментов Рецензирование найдите и выделите нужное исправление. Поле этого нажмите кнопку Принять исправление или Отклонить примечание об изменении или удалении, чтобы принять или отклонить выделенное исправление.
  3. По окончании нажмите кнопку Закрыть.
Примечание. Если изменить параметры показа на панели инструментов "Рецензирование", сведения об исправлениях удалены не будут.

Отключение функции быстрого сохранения

Функция быстрого сохранения ускоряет сохранение документов за счет того, что при ее использовании сохраняются только внесенные в документ изменения.

Реализована эта функция так, что текст, удаленный из документа, может остаться в документе даже после его сохранения. Если это нежелательно, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Параметры.
  2. Откройте вкладку Сохранение.
  3. Снимите флажок Разрешить быстрое сохранение и нажмите кнопку ОК.
Дополнительные сведения о функции быстрого сохранения см. в следующей статье базы знаний Майкрософт:
291181 Ответы на часто задаваемые вопросы о параметре "Разрешить быстрое сохранение" в Word 2002 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Поиск и удаление скрытого текста

В документах Word текст может быть отформатирован как скрытый. Скрытый текст может содержать конфиденциальные сведения, поэтому иногда его целесообразно сделать видимым и удалить. Чтобы удалить из документа весь скрытый текст, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Параметры и откройте вкладку Вид.
  2. Установите флажок Скрытый текст и нажмите кнопку ОК.
  3. Выберите в меню Правка пункт Заменить.
  4. В появившемся диалоговом окне нажмите кнопку Больше.
  5. Щелкните в любом месте поля Найти.
  6. Нажмите кнопку Формат и выберите пункт Шрифт.

    Установите флажок Скрытый и нажмите кнопку ОК.
  7. Нажмите кнопку Заменить все.
Весь скрытый текст будет удален из документа. Чтобы отключить отображение скрытого текста, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Параметры и откройте вкладку Вид.
  2. Снимите флажок Скрытый текст и нажмите кнопку ОК.

Удаление гиперссылок из документов

Документы могут содержать гиперссылки на другие документы или веб-страницы в интрасети или Интернете. Обычно гиперссылки имеют вид голубых подчеркнутых текстовых строк.

Чтобы вручную удалить из документа одну гиперссылку, щелкните ее правой кнопкой мыши и выберите в меню Гиперссылка пункт Удалить гиперссылку.

Для удаления всех гиперссылок из документа можно использовать макрос VBA. Пример такого макроса приведен ниже.

Примечание. В приведенном ниже примере макрос удаляет только саму ссылку. Текст гиперссылки в документе остается.

Внимание! Перед использованием данного макроса просмотрите еще раз отказ от ответственности, приведенный в начале данной статьи.
	Sub RemoveHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Delete
	      Next
	   Next
	
	End Sub
Если нужно удалить из документа и сами гиперссылки, и их текст, можно использовать приведенный ниже макрос.
	Sub RemoveAllHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Range.Delete
	      Next
	   Next
	
	End Sub

Удаление стилей из документов

Документы могут включать стили, содержащие метаданные. Эти стили можно удалить или переименовать. Для этого выполните указанные ниже действия.
  1. Откройте документ, содержащий стили.
  2. Выберите в меню Формат пункт Стиль.
  3. Выберите стиль, который нужно удалить или переименовать.

    Чтобы удалить стиль, нажмите кнопку Удалить. Чтобы переименовать стиль, нажмите кнопку Изменить.

Удаление старых версий файлов из документов

Приложение Word позволяет хранить в одном файле несколько версий одного документа. Перед распространением документа иногда желательно удалить из него более старые версии.

Чтобы удалить одну или несколько версий документа, выполните указанные ниже действия.
  1. Выберите в меню Файл пункт Версии.
  2. Выберите версию документа, которую нужно удалить.

    Чтобы выбрать более одной версии, удерживайте при их выборе нажатой клавишу "CTRL".
  3. Нажмите кнопку Удалить.
  4. Завершив удаление старых версий из документа, выберите в меню Файл пункт Сохранить.

Удаление связей из кодов полей

Связанные изображения и другие объекты в документах Word могут содержать информацию о связи, такую как путь к связанному изображению или объекту. Эту информацию можно удалить из документа, изменив коды полей.

Чтобы отобразить коды полей, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Параметры и откройте вкладку Вид.
  2. Установите флажок Коды полей и нажмите кнопку ОК.
Когда коды полей будут показаны, можно проверить, содержат ли какие-либо из них идентификационные сведения.

Чтобы удалить информацию о связи из связанного изображения или другого объекта, выполните указанные ниже действия.
  1. Выберите связанное изображение или объект либо код поля изображения или объекта, если коды полей видимы.
  2. Нажмите клавиши CTRL+SHIFT+F9.
Связь с изображением или объектом теперь отсутствует. Несвязанные изображения или объекты изменять нельзя.

Удаление имени шаблона и сведений о его расположении

Все документы создаются в Word на основе шаблонов. По умолчанию в качестве шаблона используется файл Normal.dot, хранящийся в папке Templates, однако документ можно создать и на основе другого шаблона. Путь к этому шаблону и его имя сохраняются в свойствах документа.

Чтобы просмотреть имя и расположение шаблона, выберите в меню Файл пункт Свойства и откройте вкладку Документ.

Даже если шаблон не отправляется вместе с документом, в документе содержатся сведения об имени и расположении шаблона. Чтобы заменить имя и расположение шаблона значениями, не содержащими идентификационных сведений, выполните указанные ниже действия.
  1. Выберите в меню Сервис пункт Шаблоны и надстройки.
  2. Нажмите кнопку Присоединить.
  3. Выберите шаблон, имя и расположение которого не являются ни конфиденциальными, ни уникальными.

    Например, на каждом компьютере с установленным приложением Word имеется файл Normal.dot, поэтому можно выбрать его.
  4. Нажмите кнопку Открыть, а затем — кнопку ОК.
Примечание. Шаблон может содержать макросы, элементы автотекста, пользовательские стили и пользовательские панели инструментов. При смене шаблона некоторые из этих элементов могут стать недоступны.

Удаление сведений о маршруте документа

Если документ отправляется по электронной почте с использованием маршрута документа, к документу могут быть присоединены сведения о маршруте. Чтобы удалить их из документа, его необходимо сохранить в формате, при котором сведения о маршруте не сохраняются.

Сохраните документ Word в формате RTF или HTML. Закройте документ и откройте сохраненный файл. Сведений о маршруте в нем теперь нет, и его можно сохранить в формате Word.

Для решения этой же задачи можно также выполнить указанные ниже действия.
  1. Снимите флажок Разрешить быстрое сохранение, следуя инструкциям, приведенным выше.
  2. Выберите в меню Файл пункт Отправить, а затем — пункт По маршруту.
  3. Нажмите кнопку Очистить, чтобы удалить маршрут, а затем нажмите кнопку ОК.
  4. Выберите в меню Файл пункт Сохранить.
Документ будет сохранен без сведений о маршруте.

Удаление имени пользователя из кода Visual Basic

Внимание! Перед использованием следующего примера макроса просмотрите еще раз отказ от ответственности, приведенный в начале статьи.

Макросы VBA, записанные в Word, начинаются с заголовка, похожего на приведенный ниже.
	' Macro1 Macro
	' Макрос записан 3/11/1999 пользователем <Имя_пользователя>
Чтобы удалить свое имя из записанных макросов, выполните указанные ниже действия.
  1. Откройте документ, содержащий макросы.
  2. Выберите в меню Сервис пункт Макрос, а затем — пункт Редактор Visual Basic или нажмите клавиши ALT+F11.
  3. В окне проекта дважды щелкните модуль, содержащий макросы.
  4. Удалите свое имя из кода записанных макросов.
После удаления своего имени нажмите клавиши ALT+Q, чтобы вернуться в Word, и выберите в меню Файл пункт Сохранить.

Удаление ссылок Visual Basic на другие файлы

В редакторе Visual Basic можно создавать ссылки на другие файлы. Если открыть документ, содержащий ссылки на другие файлы, можно увидеть имена этих файлов.

Чтобы удалить эти ссылки, выполните указанные ниже действия.
  1. Откройте документ, содержащий ссылки.
  2. Выберите в меню Сервис пункт Макрос, а затем — пункт Редактор Visual Basic или нажмите клавиши ALT+F11.
  3. Выберите в меню Tools (сервис) пункт References (ссылки).
  4. Снимите флажки рядом с файлами, на которые имеются ссылки.

    По окончании нажмите кнопку ОК.
  5. Нажмите клавиши ALT+Q.
  6. Выберите в меню Файл пункт Сохранить.
Примечание. Удаление ссылок на другие файлы может нарушить работоспособность макросов в документе.

Удаление сведений о сети или жестком диске

При сохранении документа на локальном жестком диске или на сетевом сервере в документ могут быть записаны сведения, идентифицирующие жесткий диск или сервер.

Чтобы удалить из документа эти сведения, выполните указанные ниже действия.
  1. Откройте документ.
  2. Выберите в меню Файл пункт Сохранить как.

    Сохраните документ на дискете (как правило, это диск A).
  3. Выберите в меню Файл пункт Закрыть.
  4. Достаньте дискету из дисковода.
Теперь документ можно скопировать с дискеты на любой жесткий диск или сетевой сервер с помощью проводника Windows.

Примечание. Из-за ограниченности места на дискете (как правило, дискета вмещает 1,44 МБ) данный способ не годится для копирования больших документов, размер которых превышает объем свободного места на дискете.

Метаданные в объектах, внедренных в документы

Ели в документ внедрен объект, он сохраняет свои свойства независимо от того, какие операции выполняются над документом. Например, если в документ Word внедрена книга Microsoft Excel, и документ, и книга имеют собственные свойства.

Чтобы удалить метаданные из внедренного объекта, активируйте объект, удалите все метаданные в соответствии с инструкциями, приведенными в предыдущих разделах, заново активируйте документ-контейнер и сохраните его.

Примечание. При активации объекта, внедренного в документ, отображается только часть внедренного объекта; объект может содержать дополнительные сведения, которые остаются скрытыми. Ели необходимо, чтобы документ содержал только визуальные параметры внедренного объекта, но не его фактическое содержимое, выберите в меню Правка пункт Вырезать, чтобы удалить объект, а затем воспользуйтесь командой Специальная вставка, чтобы вставить объект в документ в формате метафайла. После этого изменить внедренный объект будет невозможно, но он не будет содержать никаких метаданных.

Метаданные в переменных документа

Внимание! Перед использованием следующего макроса просмотрите еще раз отказ от ответственности, приведенный в начале данной статьи.

Для удаления переменных документа, содержащихся в документе Word, можно использовать приведенный ниже макрос.
	Sub DeleteDocVars()
	
	   Dim Response
	   Dim myVar As Variable
	
	   For Each myVar In ActiveDocument.Variables
	      Response = MsgBox("Переменная документа: " & myVar.Name & vbCr & _
	         "Значение: " & myVar.Value & vbCr & vbCr & _
	         "Хотите удалить эту переменную из данного документа?", vbYesNo)
	            
	      If Response = "6" Then
	         ' Удаление переменной.
	         myVar.Delete
	      Else
	         End
	      End If
	   Next myVar
	            
	   MsgBox "В документе нет переменных."
	   
	End Sub
Для получения дополнительных сведений о переменных откройте редактор Visual Basic, выберите в меню Help (справка) пункт Справка: Microsoft Visual Basic, введите в поле помощника Office или мастера ответов запрос Свойство Variables и нажмите кнопку Начать поиск.

Общие рекомендации по обеспечению безопасности

Ниже приведены некоторые общие советы, позволяющие надежнее защитить компьютерную среду.
  • Чтобы обеспечить безопасность компьютера, когда он остается без присмотра, используйте защищенную паролем экранную заставку, настройте компьютер так, чтобы после включения питания требовалось ввести пароль, или активируйте функцию блокировки Windows NT.
  • Если на компьютере есть общие папки, защитите их с помощью паролей, чтобы предотвратить несанкционированный доступ к ним. Чтобы сделать защиту еще более эффективной, используйте средства управления доступом на пользовательском уровне, позволяющие надежно контролировать доступ к общим ресурсам на компьютере.
  • При удалении файла сразу же очищайте корзину. Подумайте об использовании программы, окончательно уничтожающей или перезаписывающей файлы при их удалении.
  • Храните резервные копии данных в защищенном месте, таком как сейф, банковская ячейка или запирающийся шкаф.
  • Защищайте важные документы с помощью паролей, чтобы исключить несанкционированный доступ к ним. Храните пароли отдельно, в надежном месте. Если пароль будет утрачен, получить доступ к содержимому защищенного документа не удастся.
  • Не распространяйте документы в электронной форме. Вместо этого распечатывайте их. Не печатайте документы на специальной бумаге и не используйте в них идентификационные элементы, такие как специфические шрифты, водяные знаки или логотипы, если это не требуется в силу конкретных причин (например для презентации).
  • Помните, что электронная почта не обеспечивает анонимности. Не отправляйте документ по электронной почте, если не хотите, чтобы ваши личные сведения стали известны получателю.
  • Не пересылайте документы через Интернет по протоколу HTTP или FTP. Данные, отправляемые с использованием этих протоколов, пересылаются как обычный текст, из-за чего они могут быть перехвачены (хоть это и маловероятно).

Свойства

Код статьи: 825576 - Последний отзыв: 8 мая 2007 г. - Revision: 5.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Word 2003
Ключевые слова: 
kbregistry kbhowtomaster KB825576

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com