Word 2003'teki meta veriler nasıl en aza indirilir

Makale çevirileri Makale çevirileri
Makale numarası: 825576 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

™zet

Bu makalede, Word belgelerinizdeki meta verileri en aza indirmek için kullanabileceğiniz çeşitli yöntemler anlatılmaktadır.

Microsoft Office Word 2003'te bir belge oluşturduğunuzda, açtığınızda veya kaydettiğinizde, belge elektronik olarak dağıtılırken başkalarıyla paylaşmak istemeyebileceğiniz içeriğe sahip olabilir. Bu bilgilere meta veri adı verilir. Meta veriler Office belgelerinin düzenlenmesini, görüntülenmesini, oluşturulmasını ve alınmasını geliştirmek gibi amaçlarla kullanılır.

Bazı meta verilere Word kullanıcı arabirimi üzerinden kolayca erişilebilir. Diğer meta verilere ise belgeyi bir alt düzey ikili dosya düzenleyicisinde açmak gibi sıra dışı yollarla erişilebilir. Aşağıda, belgelerinizde saklanabilecek meta verilere bazı örnekler verilmektedir:
  • Adınız
  • Adınızın ve soyadınızın baş harfleri
  • Şirketinizin veya kuruluşunuzun adı
  • Bilgisayarınızın adı
  • Belgenizi kaydettiğiniz ağ sunucusunun veya sabit diskin adı
  • Diğer dosya özellikleri ve özet bilgileri
  • Katıştırılmış OLE nesnelerinin görünür olmayan bölümleri
  • Belgedeki düzeltmeler
  • Belge sürümleri
  • Şablon bilgileri
  • Gizli metin
  • Açıklamalar
Meta veriler Word belgelerinde çeşitli yollarla oluşturulur. Bu nedenle, bu içeriğin tümünü belgelerinizden kaldırmak için kullanabileceğiniz tek bir yöntem yoktur. Aşağıdaki bölümlerde Word belgelerinde meta verilerin kaydedilebileceği alanlar açıklanmaktadır.

Bu makalede, Word belgelerinizdeki meta verileri en aza indirmek için kullanabileceğiniz çeşitli yöntemler anlatılmaktadır.

Microsoft, programlama örneklerini yalnızca gösterim amacıyla sağlar; örtülü veya açık garanti vermez. Buna satılabilirlik veya belirli bir amaca uygunluk zımni garantileri de dahildir, ancak bunlarla sınırlı değildir. Bu makale, gösterilen programlama dilini ve yordamları oluşturmak ve hata ayıklamak amacıyla kullanılan araçları kullanmayı bildiğinizi varsayar. Microsoft destek mühendisleri, belirli bir yordamın işlevselliğinin açıklanmasına yardımcı olabilir, ancak gereksinimlerinizi karşılamaya yönelik olarak ek işlevsellik sağlamak veya yordamlar geliştirmek amacıyla bu örnekleri değiştirmezler. Bu makaledeki örnek kodu kullanma hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
290140 Office XP programları için Bilgi Bankası makalelerindeki örnek kodu çalıştırma (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)

Kaydederken Kişisel Bilgileri Otomatik Olarak Kaldırma

Bir Word belgesini kaydederken kişisel bilgilerinizi belgeden artık otomatik olarak kaldırabilirsiniz. Bu seçeneği etkinleştirmek için şu adımları izleyin:
  1. Araçlar menüsünde Seçenekler'i tıklatın.
  2. Güvenlik sekmesinde, Gizlilik seçenekleri altındaki Kaydederken dosya özelliklerinden kişisel bilgileri kaldır onay kutusunu tıklatıp seçin ve sonra da Tamam'ı tıklatın.
Not Bu, Word belgesini kaydederken kişisel bilgileri kaldırmak için tercih edilen yöntemdir.

Kullanıcı Adınızı Belgelerinizden El İle Kaldırma

Kullanıcı adınızı görüntülemek veya değiştirmek için şu adımları izleyin:
  1. Araçlar menüsünde Seçenekler'i ve sonra Kullanıcı Bilgileri sekmesini tıklatın.

    Aşağıdaki düzenleme kutuları görüntülenir:
    Adı
    İlk Harfler
    Posta Adresi
  2. Bu bilgilerden hiçbirinin belgelerinizde görünmesini istemiyorsanız, ilgili düzenleme kutularına tanımlayıcı olmayan dizeler veya boşluk girin ve sonra da değişiklikleri kabul etmek üzere Tamam'ı tıklatın.
Not Oluşturduğunuz yeni belgeler, Office'i yüklediğiniz sırada girilen varsayılan değerler yerine bu bilgileri içerecektir. Ancak varolan belgeler bu bilgileri zaten içeriyor olabilir.

Kişisel Özet Bilgilerini El İle Kaldırma

Word'de bir belge oluşturduğunuzda veya belgeyi kaydettiğinizde, özet bilgileri belgeye kaydedilebilir. Bu bilgilere erişmek için kullanabileceğiniz birkaç yöntem bulunmaktadır:
  • Belgeyi açın. Dosya menüsünde, Özellikler'i tıklatın. Özet, İstatistikler, İçindekiler ve Özel sekmeleri adınız, yöneticinizin adı ve şirketinizin adı gibi çeşitli özellikler içerebilir.
  • Microsoft Windows Gezgini'nde belgeyi sağ tıklatın ve sonra da Özellikler'i tıklatın. Özellikler iletişim kutusundaki sekmeler bilgi içerebilir.
  • Özellikler iletişim kutusunda gösterilen özellikleri okumak için bir Microsoft Visual Basic for Applications (VBA) makrosu veya başka bir program kodu kullanabilirsiniz.
Varolan bir belgeden veya şablondan özet bilgilerini temizlemek için şu adımları izleyin:
  1. Belgeyi veya şablonu açın.
  2. Dosya menüsünde, Özellikler'i tıklatın.
  3. Özet sekmesindeki Yazar, Yönetici, Şirket ve dağıtmak istemediğiniz diğer düzenleme kutularını tıklatıp temizleyin.
  4. Özel sekmesinde, dağıtmak istemediğiniz bilgileri içeren tüm özellikleri silin.
  5. Tamam'ı tıklatın.

    Dosya menüsünde, Kaydet'i ve sonra da Kapat'ı tıklatın.
Bu adımları tamamladıktan sonra, belge, özet özellikleri içermez.

Ağa Bağlıyken Kişisel Özet Bilgilerini El İle Kaldırma

Bir ağda oturum açtıysanız, bir belgeyi kaydettiğinizde ağdaki kullanıcı adınız Özet sekmesindeki Yazar kutusunda ve İstatistikler sekmesindeki Son kaydeden alanında görünebilir. Bu sorun, tüm diğer kişisel bilgileri bilgisayarınızdan kaldırmış olsanız da oluşabilir.

Ağ üzerindeyken bir belgeden özet bilgilerini kaldırmak için şu adımları izleyin:
  1. Belge bir ağ sunucusunda saklanıyorsa, belgeyi yerel sabit diskinize kopyalayın.
  2. Bilgisayarınızı başlatın ama ağda oturum açmayın. Ağda oturum açma iletişim kutusunu gördüğünüzde, İptal'i tıklatın veya ESCAPE tuşuna basın.

    Not ESCAPE tuşuna basarak Windows'u başlatamıyorsanız (örneğin, bilgisayarınızda Microsoft Windows NT çalışıyorsa), bu adımlara devam edemezsiniz.
  3. Belgeyi açın.
  4. Dosya menüsünde, Özellikler'i tıklatın.
  5. Özet sekmesindeki Yazar, Yönetici, Şirket ve dağıtmak istemediğiniz bilgileri içeren diğer düzenleme kutularını tıklatıp temizleyin.
  6. Özel sekmesinde, dağıtmak istemediğiniz bilgileri içeren tüm özellikleri silin.
  7. Tamam'ı tıklatın.

    Dosya menüsünde, Kaydet'i ve sonra da Kapat'ı tıklatın.
Ağda oturum açtığınızda, dosyayı açmayın. Bunu yaparsanız, ağdaki kullanıcı adınız dosyaya yazılabilir. Ancak Windows Gezgini'ni kullanarak dosyayı bir ağ sunucusuna veya diskete kopyalayabilirsiniz.

Belgelerdeki Açıklamaları El İle Kaldırma

Word ile, belgelere açıklama eklenebilir. Açıklamalar genelde belgenin kimin tarafından yazıldığının bilinebilmesi için ilgili kişinin adını içerir.

Açıklamalar, metnin vurgulanmış bölümü olarak görünür; açıklamayı sağ tıklatıp Açıklamayı Sil'i tıklatabilirsiniz.

Bu makalenin "Kullanıcı Adınızı Belgelerinizden El İle Kaldırma" bölümünde açıklanan yolla kullanıcı adınızı Seçenekler iletişim kutusundan kaldırdığınız için, oluşturduğunuz yeni açıklamalar kullanıcı adınızı içermez.

Belgelerdeki Üstbilgileri ve Altbilgileri El İle Kaldırma

Belgelerdeki üstbilgiler ve altbilgiler, tanımlayıcı bilgiler içerebilir. Üstbilgi ve altbilgi bölümlerinden bilgileri kaldırmak için şu adımları izleyin:
  1. Görünüm menüsünde Üstbilgi ve Altbilgi'yi tıklatın.
  2. Üstbilgi ve altbilgi, belgenizdeki her sayfanın üstünde ve altında görünür.

    Bunları dilediğiniz gibi değiştirin.
  3. Üstbilgi ve Altbilgi araç çubuğunda Kapat'ı tıklatın.

Düzeltme İşaretlerini El İle Kaldırma

Belgeler düzeltme işaretleri içerebilir. Düzeltme işaretleriyle, bir belgedeki belirli değişiklikleri kimlerin yaptığını belirleyebilirsiniz. Düzeltme işaretlerini kabul ettiğinizde veya reddettiğinizde, düzeltilen metin belgeye kaydedilir ve düzeltme işaretleri kaldırılır.

Düzeltmeleri kabul etmek veya reddetmek için şu adımları izleyin:
  1. Araçlar menüsünde, Değişiklikleri İzle'yi tıklatarak özelliği etkinleştirin.
  2. İnceleme araç çubuğunda, Geri veya İleri'yi tıklatarak ilgili düzeltmeleri bulun ve seçin. Ardından, seçili düzeltmeyi kabul etmek veya reddetmek için Değişikliği Kabul Et veya Açıklamayı Değiştir/Sil'i Reddet'i tıklatın.
  3. Tamamladığınızda, Kapat'ı tıklatın.
Not İnceleme araç çubuğundaki "Göster" ayarlarını değiştirirseniz, düzeltme bilgileri kaldırılmaz.

Hızlı Kaydetme Özelliğini Kapatma

Hızlı Kaydetme özelliği, yalnızca belgede yapılan değişiklikleri kaydederek belge kaydetme işlemini hızlandırır.

Hızlı Kaydetme özelliğinin tasarımı nedeniyle, bir belgeden sildiğiniz metin, belge kaydedildikten sonra da belgede kalabilir. Silinmiş metnin belgelerinizde kalması konusunda endişeleriniz varsa şu adımları izleyin:
  1. Araçlar menüsünde Seçenekler'i tıklatın.
  2. Kaydet sekmesini tıklatın.
  3. Hızlı kaydetmeye izin ver onay kutusunu tıklatıp temizleyin ve sonra Tamam'ı tıklatın.
Hızlı Kaydetme özelliği hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
291181 Word 2002'deki "Hızlı Kaydetmeye İzin Ver" özelliğiyle ilgili sık sorulan sorular (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir)

Gizli Olarak Biçimlendirilmiş Metni Arama ve Kaldırma

Word belgelerinde, metni gizli olarak biçimlendirebilirsiniz. Gizli metin dağıtmak istemeyebileceğiniz bilgiler içerebileceğinden, bu bilgileri görünür yaptıktan sonra kaldırmak isteyebilirsiniz. Gizli olarak biçimlendirilmiş bir belgedeki tüm metni kaldırmak için şu adımları izleyin:
  1. Araçlar menüsünde Seçenekler'i ve sonra Görünüm sekmesini tıklatın.
  2. Gizli metin onay kutusunu tıklatıp seçin ve sonra da Tamam'ı tıklatın.
  3. Düzen menüsünde, Değiştir'i tıklatın.
  4. Diğer’i tıklatıp iletişim kutusunu genişletin.
  5. Aranan yanındaki kutunun içini tıklatın.
  6. Biçim düğmesini ve ardından Yazı Tipi'ni tıklatın.

    Gizli onay kutusunu tıklatıp seçin ve sonra da Tamam'ı tıklatın.
  7. Tümünü Değiştir'i tıklatın.
Tüm gizli metinler belgeden kaldırılır. Gizli metin görüntüsünü kapatmak için şu adımları izleyin:
  1. Araçlar menüsünde Seçenekler'i ve sonra Görünüm sekmesini tıklatın.
  2. Gizli metin onay kutusunu tıklatıp temizleyin ve sonra da Tamam'ı tıklatın.

Belgelerden Köprüleri Kaldırma

Belgeler, intranetteki veya Internet'teki başka belgelere ya da Web sayfalarına köprüler içerebilir. Köprüler genelde altı çizili ve mavi renkli metin dizeleri olarak görünür.

Bir belgeden tek bir köprüyü el ile silmek için, köprüyü sağ tıklatın, Köprü'nün üzerine gelin ve sonra da Köprüyü Kaldır'ı tıklatın.

Bir belgedeki tüm köprüleri silmek isterseniz, bunun için bir VBA makrosu kullanabilirsiniz. Aşağıdaki örnek VBA makrosu bir belgedeki tüm köprüleri kaldırır.

Not Aşağıdaki örnek makroda yalnızca bağlantı kaldırılır. Köprü metni belgede kalır.

Önemli Aşağıdaki makro örneğini kullanmadan önce, bu makalede daha önce yer alan Vazgeçme Belgesi'ni inceleyin.
	Sub RemoveHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Delete
	      Next
	   Next
	
	End Sub
Hem köprünün hem de köprü metninin tüm izlerini belgeden kaldırmak için, aşağıdaki örnek makroyu kullanabilirsiniz.
	Sub RemoveAllHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Range.Delete
	      Next
	   Next
	
	End Sub

Belgelerden Stilleri Kaldırma

Belgelerde, meta veriler içeren stiller olabilir. Bu stilleri kaldırabilir veya yeniden adlandırabilirsiniz. Bunu yapmak için şu adımları izleyin:
  1. Stiller içeren belgeyi açın.
  2. Biçim menüsünde Stiller'i tıklatın.
  3. Silmek veya yeniden adlandırmak istediğiniz stili seçin.

    Stili silmek için Sil'i, yeniden adlandırmak için Değiştir'i tıklatın.

Belgelerden Eski Dosya Sürümlerini Kaldırma

Word, aynı belgenin birden çok sürümünü aynı dosyaya kaydetmenize olanak veren bir dosya sürümü özelliği içerir. Belgeyi başkalarıyla paylaşmadan önce eski sürümlerini silmek isteyebilirsiniz.

Belgenin bir veya daha fazla sürümünü silmek için şu adımları izleyin:
  1. Dosya menüsünde, Sürümler'i tıklatın.
  2. Silmek istediğiniz belge sürümünü seçin.

    Sürümleri seçerken CTRL tuşunu basılı tutarak birden çok sürüm seçebilirsiniz.
  3. Sil'i tıklatın.
  4. Belgenin eski sürümlerini silmeyi tamamladığınızda, Dosya menüsünde Kaydet'i tıklatın.

Alan Kodlarından Bağlantıları Kaldırma

Word belgelerindeki bağlantılı resimler ve başka nesneler, bağlantılı resmin veya nesnenin yolu gibi bağlantı bilgilerini içerebilir. Alan kodlarını düzenleyerek, belgelerinizden bu bağlantı bilgilerini kaldırabilirsiniz.

Alan kodlarını görüntülemek için şu adımları izleyin:
  1. Araçlar menüsünde Seçenekler'i ve sonra Görünüm sekmesini tıklatın.
  2. Alan kodları onay kutusunu tıklatıp seçin ve sonra da Tamam'ı tıklatın.
Alan kodları görünür olduktan sonra, bunlardan birinin tanımlayıcı bilgiler içerip içermediğini denetleyebilirsiniz.

Bağlantılı resimden veya başka bir nesneden bağlantı bilgilerini kaldırmak için şu adımları izleyin:
  1. Bağlantılı resmi veya nesneyi ya da alan kodları görünür durumdaysa resmin veya nesnenin alan kodunu seçin.
  2. CTRL+SHIFT+F9 tuşlarına basın.
Resim veya nesnenin bağlantısı kaldırılır. Bir resmin veya nesnenin bağlantısı kaldırıldığında bu öğeyi düzenleyemezsiniz.

Şablon Adını ve Konumunu Kaldırma

Word'de oluşturulan tüm belgeler bir şablona dayalıdır. Varsayılan olarak, bu şablon dosyası Templates klasöründe bulunan Normal.dot adlı dosyadır. Ancak başka bir konumdaki farklı bir şablona dayalı bir belge oluşturabilirsiniz. Bu şablonun yolu ve adı, belgenin özelliklerinde saklanır.

Şablon adını ve konumunu görüntülemek için, Dosya menüsünde Özellikler'i tıklatın ve sonra da Özet sekmesini tıklatın.

Şablonu belgeyle birlikte göndermeseniz de, belgede şablonun adı ve konumu saklanır. Şablon adını ve konumunu tanımlayıcı olmayan değerlere dönüştürmek için şu adımları izleyin:
  1. Araçlar menüsünde, Şablonlar ve Eklentiler'i tıklatın.
  2. İliştir'i tıklatın.
  3. Adı veya konumu önemli ya da benzersiz olmayan bir şablon seçin.

    Örneğin, Word'ün yüklü olduğu tüm bilgisayarlarda Normal.dot dosyası bulunduğu için, Normal.dot şablonunu seçebilirsiniz.
  4. 'ı ve sonra Tamam'ı tıklatın.
Not Şablon makrolar, otomatik metin girdileri, özel stiller ve özel araç çubukları içerebilir. Şablonları değiştirdiğinizde, bu öğelerden bazıları belgelerinizde kullanılamayabilir.

Dolaştırma Notu Bilgilerini Kaldırma

Dolaştırma notu içeren bir belgeyi e-posta yoluyla göndermek istediğinizde, dolaştırma bilgileri belgeye iliştirilebilir. Bu bilgileri belgeden kaldırmak için, belgeyi, dolaştırma notu bilgilerini korumayan bir biçimde kaydetmelisiniz.

Word'de, belgenizi Zengin Metin Biçimi (RTF) veya HTML biçiminde kaydedin. Belgeyi kapatın ve yeni dosyayı yeniden açın. Dolaştırma notu bilgileri artık bulunmadığı için, belgenizi Word biçiminde kaydedebilirsiniz.

Aşağıdaki adımları da uygulayabilirsiniz:
  1. Bu makalede daha önce yer alan yönergeleri kullanarak Hızlı kaydetmeye izin ver özelliğini kapatın.
  2. Dosya menüsünde, Gönder'in üzerine gelin ve Dolaştırma Alıcısına'yı tıklatın.
  3. Dolaştırma notunu kaldırmak üzere Temizle'yi tıklatın ve sonra da Tamam'ı tıklatın.
  4. Dosya menüsünde, Kaydet'i tıklatın.
Belge, dolaştırma notu bilgileri olmadan kaydedilir.

Visual Basic Kodundan Adınızı Kaldırma

Önemli Aşağıdaki makro örneğini kullanmadan önce, bu makalede daha önce yer alan Vazgeçme Belgesi'ni inceleyin.

Word'de bir VBA makrosunu kaydettiğinizde, kaydedilen makro aşağıdakine benzer bir üstbilgiyle başlar:
	' Macro1 Macro
	' Macro recorded 3/11/1999 by <User Name>
Kaydettiğiniz makrolardan adınızı kaldırmak için şu adımları izleyin:
  1. Makroları içeren belgeyi açın.
  2. Araçlar menüsünde, Makro'nun üzerine gelin ve sonra da Visual Basic Düzenleyicisi'ni tıklatın. Veya, ALT+F11 tuşlarına basın.
  3. Proje penceresinde, makroları içeren modülü çift tıklatın.
  4. Kaydedilmiş makro kodundan adınızı kaldırın.
Adınızı kaldırmayı tamamladığınızda, ALT+Q tuşlarına basarak programa dönün ve sonra da Dosya menüsünde Kaydet'i tıklatın.

Başka Dosyalara Visual Basic Başvurularını Kaldırma

Visual Basic Editor'da, başka bir dosyaya başvuru oluşturabilirsiniz. Kullanıcı başka dosyalara başvurular içeren bir belgeyi açtığında, başvurulan dosyaların adlarını görebilir.

Bu başvuruları kaldırmak için şu adımları izleyin:
  1. Başvurular içeren belgeyi açın.
  2. Araçlar menüsünde, Makro'nun üzerine gelin ve sonra da Visual Basic Düzenleyicisi'ni tıklatın veya ALT+F11 tuşlarına basın.
  3. Tools (Araçlar) menüsünde, References'ı (Başvurular) tıklatın.
  4. Başvurulan dosya veya dosyaların yanındaki onay kutularını tıklatıp temizleyin.

    Tamamladığınızda, OK'i (Tamam) tıklatın.
  5. ALT+Q tuşlarına basın.
  6. Dosya menüsünde, Kaydet'i tıklatın.
Not Başka dosyalara başvuruları kaldırırsanız, belgenizdeki makrolar düzgün çalışmayabilir.

Ağ veya Sabit Disk Bilgilerini Kaldırma

Bir belgeyi yerel sabit diskinize veya ağ sunucusuna kaydettiğinizde, belgeye yerel sabit diskinizi veya ağ sunucusunu tanımlayan bilgiler yazılabilir.

Bu bilgileri belgeden kaldırmak için şu adımları izleyin:
  1. Belgeyi açın.
  2. Dosya menüsünde, Farklı Kaydet'i tıklatın.

    Belgeyi sabit disk sürücünüze kaydedin (genelde A sürücüsüdür).
  3. Dosya menüsünde, Kapat'ı tıklatın.
  4. Disketi sürücünüzden çıkartın.
Windows Gezgini'ni kullanarak, disketteki belgeyi artık dilediğiniz sabit diske veya ağ sunucusuna kopyalayabilirsiniz.

Not Disketin alan kısıtlaması nedeniyle (genelde 1,44 megabayttır [MB]), belgenin dosya boyutu disketteki boş alandan daha fazlaysa bu yöntem kullanılamaz.

Belgelerdeki Katıştırılmış Nesneler Meta Veriler İçerebilir

Belgeye bir nesne katıştırırsanız, belgede yaptığınız işlemlerden bağımsız olarak, nesnenin kendi özellikleri korunur. Örneğin, Word belgesine bir Microsoft Excel çalışma kitabı katıştırırsanız, belgenin ve çalışma kitabının kendi özellikleri olur.

Katıştırılmış nesneden meta verileri kaldırmak için, nesneyi etkinleştirin, önceki bölümlerde açıklanan yollarla meta verileri kaldırın ve sonra da kapsayıcı belgeyi yeniden etkinleştirip kaydedin.

Not Bir belgedeki katıştırılmış nesneyi etkinleştirdiğinizde, belgede katıştırılmış nesnenin yalnızca bir bölümü görüntülenir; nesne, görünmeyen ek bilgiler içerebilir. Bir belgenin asıl içerik yerine yalnızca katıştırılmış nesnenin işlenmiş şeklini içermesini istiyorsanız, Düzen menüsündeki Kes komutunu kullanarak nesneyi silin ve sonra da Özel Yapıştır komutunu kullanarak nesneyi bir Meta dosyası biçiminde belgeye yapıştırın. Bunu yaptıktan sonra, katıştırılmış nesneyi artık düzenleyemezsiniz; ancak nesne, meta veriler içermeyecektir.

Belge Değişkenleri Meta Veriler İçerebilir

Önemli Aşağıdaki makro örneğini kullanmadan önce, bu makalede daha önce yer alan Vazgeçme Belgesi'ni inceleyin.

Word belgenizin içerdiği belge değişkenlerini silmek için, aşağıdaki örnek makroyu kullanın:
	Sub DeleteDocVars()
	
	   Dim Response
	   Dim myVar As Variable
	
	   For Each myVar In ActiveDocument.Variables
	      Response = MsgBox("Belge değişkeni: " & myVar.Name & vbCr & _
	         "Değer: " & myVar.Value & vbCr & vbCr & _
	         "Değişkeni bu belgeden silmek istiyor musunuz?", vbYesNo)
	            
	      If Response = "6" Then
	         ' Değişkeni silin.
	         myVar.Delete
	      Else
	         End
	      End If
	   Next myVar
	            
	   MsgBox "Belge değişken içermiyor."
	   
	End Sub
Değişkenler hakkında daha fazla bilgi için, Visual Basic Editor'da Yardım menüsünde Microsoft Visual Basic Yardımı'nı tıklatın, Office Yardımcısı'na veya Yanıt Sihirbazı'na Variables Property (Değişkenler Özelliği) yazın ve sonra da Ara'yı tıklatıp konuyu görüntüleyin.s

Güvenlik İle İlgili Genel Öneriler

Aşağıda, çalışma ortamınızın güvenlik düzeyini artırmanıza yardımcı olmak için kullanabileceğiniz bazı genel öneriler yer almaktadır:
  • Bilgisayarınızın başında olmadığınız zamanlarda, parola korumalı bir ekran koruyucu, açılış parolası veya Windows NT kilit özelliğini kullanarak güvenliğinin sağlanmasına yardımcı olun.
  • Bilgisayarınızda paylaşılan klasörler varsa, yalnızca yetkili kullanıcılar tarafından erişilebilmesi için paylaşımlara parolalar uyguladığınızdan emin olun. Daha fazla güvenlik için, bilgisayarınızdaki paylaşımlara kimlerin erişebildiğini tam olarak denetleyebilmek için kullanıcı düzeyinde erişim denetimi kullanın.
  • Bir dosyayı sildiğinizde Geri Dönüşüm Kutusu'nu hemen boşaltın. Dosyalar silindikleri zaman dosyaları tümüyle kaldıran veya dosyaların üzerine yazan bir yardımcı program kullanabilirsiniz.
  • Verilerinizi yedeklediğinizde, yedek kopyaları bir güvenlik kasası veya kilitli dolap gibi güvenli bir yerde saklayın.
  • Önemli belgelerin yalnızca yetkili kullanıcılar tarafından açılabilmeleri için parola korumalı olmalarını sağlayın. Parolalarınızı güvenli ve ayrı bir yerde saklayın. Bir parolayı anımsayamıyorsanız, parola korumalı belgenin içeriği hiçbir şekilde kurtarılamaz.
  • Belgeleri elektronik biçimde dağıtmayın. Bunun yerine, onları yazdırın. Zorunlu olmadıkça (örneğin, bir sunum yapmanız gerekmedikçe) ayırt edici yazı tipleri, filigranlar, logolar veya özel kağıt gibi tanımlayıcı öğeler kullanmayın.
  • E-posta anonim değildir. Kimlik bilgilerinizin herhangi bir şekilde belgeye iliştirilmesi konusunda endişeleriniz varsa belgeyi e-posta yoluyla göndermeyin.
  • Bir belgeyi HTTP veya Dosya Aktarım Protokolü (FTP) kullanarak Internet üzerinden göndermeyin. Bu protokoller kullanılarak gönderilen bilgiler "şifresiz metin" olarak gönderilir; bir başka deyişle, yorumlanmaları teknik olarak mümkündür (ancak olasılığı düşüktür).

Özellikler

Makale numarası: 825576 - Last Review: 22 Şubat 2008 Cuma - Gözden geçirme: 5.1
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Office Word 2003
Anahtar Kelimeler: 
kbhowtomaster kbregistry KB825576

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com