Artikel-ID: 836982 - Geändert am: Mittwoch, 5. Dezember 2007 - Version: 3.2

Fehlermeldung "0x8007045A ERROR_DLL_INIT_FAILED" bei Verwendung der Windows Update-Website oder der Microsoft Update-Website

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
836982  (http://support.microsoft.com/kb/836982/EN-US/ ) You receive a "0x8007045A ERROR_DLL_INIT_FAILED" error message when you use the Windows Update Web site or use the Microsoft Update Web site
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie versuchen, Updates von der Windows Update-Website oder der Microsoft Update-Website zu downloaden, wird eventuell die folgende Fehlermeldung angezeigt:
0x8007045A ERROR_DLL_INIT_FAILED

Ursache

Dieses Problem tritt auf, weil ein Dateikonflikt vorliegt oder die Msxml.dll-Dateien beschädigt sind.

Lösung

Wenden Sie eine der folgenden Methoden an, um dieses Problem zu beheben.

Methode 1: Microsoft XML-Parser aktualisieren oder neu installieren

Der aktuellste XML-Parser steht auf folgender Microsoft-Website zum Download zur Verfügung:
http://msdn.microsoft.com/XML/XMLDownloads/default.aspx (http://msdn.microsoft.com/XML/XMLDownloads/default.aspx)

Methode 2: Ersetzen Sie die beschädigten Dateien

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Kopieren Sie die folgenden DLL-Dateien aus dem Ordner "C:\WINDOWS\SYSTEM" eines ordnungsgemäß funktionierenden Computers auf den Computer, auf dem das Problem auftritt:
    • Msxml3.dll
    • Msxml3a.dll
    • Msxml3r.dll
  2. Nachdem Sie die Dateien ersetzt haben, müssen Sie sie registrieren. Gehen Sie folgendermaßen vor, um die Dateien zu registrieren:
    1. Klicken Sie auf Start und anschließend auf Ausführen.
    2. Geben Sie REGSVR32 C:\WINDOWS\SYSTEM\MSXML.DLL in das Feld Öffnen ein, und klicken Sie danach auf OK. Wenn die Registrierung erfolgreich war, wird Ihnen eine entsprechende Meldung angezeigt.
    3. Wiederholen Sie die Schritte a und b für die folgenden Dateien:
      • C:\WINDOWS\SYSTEM\MSXML2.DLL
      • C:\WINDOWS\SYSTEM\MSXML3.DLL
    4. Starten Sie den Computer neu.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kberrmsg kbwindowsupdate kbprb kbwindowsupdatev6 KB836982
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
 

SPRACHE AUSWÄHLEN

 

Related Support Centers