更新プログラムをインストールするときに "Windows Update にエラーが発生しました。要求されたページは表示できません" というエラー メッセージが表示される

文書翻訳 文書翻訳
文書番号: 883614 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Update を使用して更新プログラムをインストールしようとすると、次のエラー メッセージが表示されます。
Windows Update has encountered an error and cannot display the requested page. The necessary service "Automatic Updates" (WUAUSERV) is not started or Background Intelligent Transfer Service (BITS) is disabled. Error 0x8DDD0018

原因

この問題は、バックグラウンド インテリジェント転送サービス (BITS) または自動更新サービスが停止されている場合に発生します。

解決方法

この問題を解決するには、状況に応じて、以下のいずれかの方法を使用します。

方法 1 : サービスが開始されていることを確認する

BITS および自動更新サービスが開始されていることを確認します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、services.msc と入力し、[OK] をクリックします。
  2. サービスの一覧で、[Automatic Updates] を右クリックし、[プロパティ] をクリックします。
  3. [スタートアップの種類] ボックスの一覧の [自動] をクリックし、[適用] をクリックします。
  4. [サービスの状態] が [停止] に設定されている場合は、[開始] をクリックし、[OK] をクリックします。
  5. [Background Intelligent Transfer Service] を右クリックし、[プロパティ] をクリックします。
  6. [スタートアップの種類] ボックスの一覧の [手動] をクリックし、[適用] をクリックします。
  7. [サービスの状態] が [停止] に設定されている場合は、[開始] をクリックし、[OK] をクリックします。

方法 2 : サービス コントロール マネージャにいずれかまたは両方のサービスが表示されない場合に対処する

: ここで説明するコマンドを手動で入力するときは、コマンドは大文字と小文字が区別されることに注意してください。

サービス コントロール マネージャに、自動更新サービスまたはバックグラウンド インテリジェント転送サービスが表示されない場合は、表示されないサービスを再インストールします。これを行うには、状況に応じて、次のいずれかまたは両方の手順を実行します。

自動更新サービスが表示されない場合

自動更新サービスを再インストールするには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次のコマンドを入力し、[OK] をクリックします。
    %windir%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %windir%\inf\au.inf
  2. オペレーティング システムの CD を挿入するように求めるメッセージが表示されたら、[コピー元] ボックスに次のパスを入力し、[OK] をクリックします。
    %windir%\ServicePackFiles\i386
    : 上記の場所には、更新済みの最新の Service Pack のファイルが保存されています。このパスを使用して必要なファイルをコピーできない場合は、オペレーティング システムの CD を挿入し、[OK] をクリックしてください。

バックグラウンド インテリジェント転送サービスが表示されない場合

バックグラウンド インテリジェント転送サービスを再インストールするには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次のコマンドを入力し、[OK] をクリックします。
    %windir%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %windir%\inf\qmgr.inf
  2. オペレーティング システムの CD を挿入するように求めるメッセージが表示されたら、[コピー元] ボックスに次のパスを入力し、[OK] をクリックします。
    %windir%\ServicePackFiles\i386
    : 上記の場所には、更新済みの最新の Service Pack のファイルが保存されています。このパスを使用して必要なファイルをコピーできない場合は、オペレーティング システムの CD を挿入し、[OK] をクリックしてください。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

プロパティ

文書番号: 883614 - 最終更新日: 2010年9月14日 - リビジョン: 4.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Update
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Update
キーワード:?
kberrmsg kbtshoot kbwindowsupdate kbprb KB883614
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com