Lorsque vous tentez d'utiliser le lecteur de CD-ROM dans Windows XP, le message d'erreur « Impossible de satisfaire à la demande en raison d'une erreur de périphérique d'E/S » s'affiche

Traductions disponibles Traductions disponibles
Numéro d'article: 891894 - Voir les produits auxquels s'applique cet article
Template: zGeneric Problem Article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous tentez d'installer un programme ou de copier des données de votre lecteur de CD-ROM dans Windows XP, l'un des messages d'erreur suivants peut s'afficher :
Impossible de satisfaire à la demande en raison d'une erreur de périphérique d'E/S
Seule une partie d'une requête ReadProcessMemory ou WriteProcessMemory a été effectuée

Cause

Ce message d'erreur indique un problème survenant lors d'une tentative de lecture ou d'écriture sur un périphérique, tel qu'un disque dur, un lecteur de CD-ROM ou un lecteur réseau. Ce problème peut survenir pour l'une des raisons suivantes :
  • Windows tente d'utiliser un mode de transfert que le lecteur de CD-ROM ne peut pas utiliser.
  • Le matériel auquel vous tentez d'accéder est endommagé ou défectueux.
  • Les pilotes de périphérique pour le matériel sont défectueux ou incompatibles.
  • Il y a un problème de connexion, par exemple un câble inapproprié.
  • Le CD-ROM auquel vous tentez d'accéder est endommagé.

AVANT DE COMMENCER

De nombreux problèmes courants liés à la lecture d'un CD-ROM peuvent être résolus de l'une des manières suivantes. Essayez d'abord les procédures suivantes pour voir si elles résolvent le problème.
  • Redémarrez l'ordinateur et réessayez le lecteur de CD-ROM.
  • Utilisez un disque de nettoyage pour nettoyer le lecteur de CD-ROM.
  • Si vous avez accès à un autre ordinateur, tentez de lire les données figurant sur le CD-ROM à partir de cet autre ordinateur pour vous assurer que le CD-ROM n'est pas endommagé. Si le CD-ROM ne fonctionne pas sur l'autre ordinateur, nettoyez-le et réessayez.
  • Si vous n'avez pas accès à un autre ordinateur, essayez un autre CD-ROM pour vous assurer que le problème est lié à l'ordinateur et non au CD-ROM d'origine.
Si le problème est résolu et que le message d'erreur ne s'affiche plus, vous avez terminé. Si le problème persiste, passez à la section suivante.

Résolution

Vous pouvez utiliser plusieurs méthodes pour tenter de résoudre le problème. Essayez ces méthodes en respectant l'ordre dans lequel elles sont présentées.

Cet article s'adresse aux utilisateurs débutants ou d'un niveau intermédiaire.

Il vous sera peut-être plus facile de suivre ces étapes si vous imprimez d'abord l'article.

Méthode 1 : assurez-vous que tous les câbles sont correctement connectés.

S'il s'agit d'un lecteur de CD-ROM externe, tel qu'un périphérique USB, veillez à ce que le câble qui relie le lecteur à l'ordinateur soit en bon état de fonctionnement. S'il est défectueux, le lecteur de CD-ROM ne fonctionnera pas correctement. Si vous disposez d'un autre câble, utilisez-le et essayez aussi de le connecter à un autre port USB.

Remarque Le remplacement des câbles d'un lecteur interne d'un PC est à réserver aux utilisateurs expérimentés, car cette opération est susceptible d'endommager de nombreuses pièces internes. Ne tentez pas de remplacer les câbles d'un ordinateur portable.

Si la sécurisation de la connexion, la connexion à un autre port USB ou l'utilisation d'un autre câble a résolu le problème, vous avez terminé. Si le problème persiste, passez à la méthode 2.

Méthode 2 : démarrez l'ordinateur en mode minimal.

Tentez un démarrage minimal de l'ordinateur pour déterminer si l'un de vos programmes ou lecteurs est en conflit avec le lecteur de CD-ROM. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
310353 Comment faire pour effectuer un démarrage en mode minimal dans Windows XP
Si un démarrage minimal résout le problème, il se peut que l'ordinateur contienne un programme ou lecteur incompatible. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
316434 COMMENT FAIRE : Effectuer une procédure de dépannage avancé à l'aide du démarrage en mode minimal dans Windows XP
Si cette méthode a résolu le problème, vous avez terminé. Si le problème persiste, passez à la méthode 3.

Méthode 3 : modifiez le mode de transfert de votre lecteur de CD-ROM dans les propriétés du canal IDE.

Si le mode de transfert du lecteur de CD-ROM a été modifié ou est incorrect, Windows ne peut pas transférer les données du CD-ROM vers l'ordinateur. Vous pouvez résoudre ce problème en restaurant le mode de transfert correct. Pour modifier le mode de transfert, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Tapez devmgmt.msc dans la zone Ouvrir, puis appuyez sur ENTRÉE.

    La boîte de dialogue Gestionnaire de périphériques s'ouvre.
  3. Développez Contrôleurs ATA/ATAPI IDE. Un sous-ensemble s'affiche, répertoriant les différents canaux ATA/ATAPI IDE pour l'ordinateur.
  4. Cliquez avec le bouton droit sur le canal auquel votre lecteur de CD-ROM est connecté, puis cliquez sur Propriétés. En général, ce canal est le Canal IDE secondaire.

    Avertissement Ne modifiez pas le canal IDE primaire, périphérique 0, car il s'agit généralement du disque système. Si vous modifiez ce paramètre, l'ordinateur risque de ne plus fonctionner correctement, voire plus du tout.
  5. Sous l'onglet Paramètres avancés, sélectionnez PIO seulement dans la zone Mode de transfert pour le périphérique représentant le lecteur de CD-ROM. Il s'agit généralement du Périphérique 0. Cliquez ensuite sur OK.
  6. Testez le CD-ROM dans le lecteur.
Si le problème persiste après la modification du mode de transfert pour le périphérique 0 du canal secondaire IDE, votre lecteur de CD-ROM n'est peut-être pas situé à cet emplacement. Utilisez la même procédure pour restaurer le mode de transfert d'origine DMA si disponible. Ensuite, répétez les étapes 1-6 pour modifier le mode de transfert pour les périphériques IDE dans l'ordre suivant jusqu'à ce que le problème soit résolu :
  • Canal IDE principal, périphérique 1
  • Canal IDE secondaire, périphérique 1
Si cette méthode a résolu le problème, vous avez terminé. Si le problème persiste, passez à la méthode 4.

Méthode 4 : vérifiez l'état du périphérique dans le Gestionnaire de périphériques.

Vous pouvez vérifier l'état du lecteur de CD-ROM dans le Gestionnaire de périphériques pour vous assurer du bon fonctionnement du pilote de périphérique. S'il existe une panne matérielle ou un conflit logiciel qui empêche le périphérique de fonctionner correctement, le Gestionnaire de périphériques parviendra généralement à détecter le problème. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
283658 COMMENT FAIRE : Gérer les périphériques dans Windows XP
Si cette méthode vous a permis de résoudre le problème, vous avez terminé. Si le problème persiste, passez à la méthode 5.

Méthode 5 : contactez le fabricant du matériel.

Il se peut qu'il existe des pilotes de périphériques ou des microprogrammes mis à jour pour le lecteur de CD-ROM. Contactez le fabricant du matériel pour déterminer s'il existe une mise à jour pour votre pilote de périphérique ou votre microprogramme. Pour plus d'informations sur le fabricant de votre matériel, visitez le site Web suivant :
http://support.microsoft.com/gp/vendors/
Microsoft fournit des informations relatives aux contacts tiers afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces. Si le problème persiste et que vous êtes familiarisé avec le dépannage avancé, consultez la section « Dépannage avancé ».

Sinon, consultez la section « Étapes suivantes ».

DÉPANNAGE AVANCÉ

Essayez d'accéder au périphérique sur un autre ordinateur

Si vous avez essayé toutes les autres méthodes, vous pouvez retirer physiquement le lecteur de CD-ROM de l'ordinateur et l'installer dans un autre ordinateur pour déterminer si le matériel est endommagé. Si le problème persiste et que le lecteur de CD-ROM ne fonctionne pas sur un autre ordinateur, le matériel est probablement endommagé. Contactez le fabricant du matériel. Pour plus d'informations sur le fabricant de votre matériel, visitez le site Web suivant :
http://support.microsoft.com/gp/vendors/
Microsoft fournit des informations relatives aux contacts tiers afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces. Si le problème persiste, consultez la section « Étapes suivantes ».

ÉTAPES SUIVANTES

Problèmes similaires et solutions

Si vous avez essayé toutes les méthodes figurant dans cet article et que le lecteur de CD-ROM ne fonctionne toujours pas correctement, vous pouvez consulter d'autres articles de support technique pour tenter de résoudre le problème. Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants de la Base de connaissances Microsoft :
324129 Comment faire pour résoudre les problèmes survenant lors de l'écriture de données sur un disque optique CD-R ou CD-RW dans Windows XP
307148 Impossible d'accéder au lecteur de DVD-ROM après la sortie de veille prolongée de votre ordinateur

Contactez l'assistance

Si ces méthodes n'ont pas fonctionné dans votre cas, vous pouvez utiliser le site Web Services de support client Microsoft pour trouver d'autres solutions à votre problème. Les services offerts sur ce site comprennent notamment :
  • Base de connaissances offrant des fonctions de recherche : recherchez des informations de support technique et des outils d'auto-assistance pour les produits Microsoft.
  • Centres de solutions : consultez les questions les plus fréquentes spécifiques au produit et les points principaux du support.
  • Groupes de discussion du Support client Microsoft : contactez vos homologues et les intervenants techniques MVP (Most Valuable Professionals) de Microsoft.
  • Autres options de support : posez vos questions en ligne, contactez les Services de support client Microsoft ou envoyez vos commentaires.
Si ces problèmes persistent, vous voudrez peut-être contacter le support technique :
http://support.microsoft.com/contactus


Pour obtenir de l'aide concernant des problèmes de lecteur de CD-ROM ou de DVD-ROM sous Windows Vista, visitez la page Web Microsoft suivante :

Propriétés

Numéro d'article: 891894 - Dernière mise à jour: mercredi 21 octobre 2009 - Version: 4.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbexpertiseinter kbexpertisebeginner kbresolve kbtshoot kbprb KB891894
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com