Word не сохраняет изменения или появляется сообщение об ошибке в программе Office после установки Adobe Acrobat 7.0

Важно

В этой статье описывается известная проблема совместимости между Adobe Acrobat 7.0 и более ранними версиями Microsoft Office. Если вы используете текущую версию Microsoft 365 или более новый выпуск Adobe Acrobat, эта статья может не применяться к вашей среде.

Проблема

При использовании программы Microsoft Office, перечисленной в разделе «Относится к», вы можете столкнуться с одним или несколькими из следующих симптомов:

  • При изменении рабочей области в Microsoft Word изменения не сохраняются при выходе из Word. Эти изменения в рабочей области включают следующие примеры:

    • Вы создаете макрос.
    • Вы можете изменить шрифт по умолчанию.
    • Вы добавляете запись автотекста.
    • Вы добавляете панель инструментов.
  • При перезапуске Word элементы, которые вы изменили или добавили, недоступны.

    Примечание. Это поведение происходит, даже если установлен флажок проверки шаблона "Запрос на сохранение обычных".

  • При попытке запустить приложение Office появляется сообщение об ошибке, похожее на следующее:

    Примечание

    Ошибка выполнения Visual C++

    Примечание

    Библиотека среды выполнения Microsoft Visual C++

    Program Files\Microsoft Office\office10\product name.exe

    Это приложение запросило у среды выполнения необычное завершение.

  • При открытии документа Word появляется следующее сообщение об ошибке:

    Примечание

    Недостаточно памяти или места на диске. Word не может отобразить запрошенный шрифт.

  • При закрытии Word файл можно открыть дважды, чтобы открыть его в Word. В этом сценарии Word перестает отвечать на запросы (зависает).

Причина

Эти проблемы могут возникать после установки Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard или Adobe Acrobat 7.0 Elements.

В Acrobat 7.0 надстройка COM устанавливается в указанной ниже папке.

\Acrobat 7.0\PDFMaker\OfficeНадстройка COM содержит значки PDFMaker и команды меню для программ Office.

Временное решение

В зависимости от ситуации воспользуйтесь одним из следующих способов. Если при выходе из Word изменения не сохраняются, используйте метод 1 или 2. Если при попытке открыть документ Word или приложение Office выводится сообщение об ошибке, используйте метод 3 или 4.

Способ 1. Сохраните макросы, настройки и пользовательские настройки в Word с помощью команды "Сохранить все" в меню "Файл"

Примечание. Этот метод не применяется к Microsoft Office Word 2007.

Чтобы вручную сохранить макросы, настройки и пользовательские параметры в Word 2003 и более ранних версиях Word, выполните следующие действия:

  1. Нажмите и удерживайте клавишу SHIFT.
  2. В меню "Файл " выберите команду "Сохранить все".

Изменения сохраняются. Кроме того, изменения доступны в других документах Word.

Способ 2. Добавление команды "Сохранить все"

В Word нажимайте кнопку "Сохранить все" при каждом создании макроса, параметра или пользовательского параметра.

Чтобы добавить команду "Сохранить все" в Word, выполните одно из следующих действий.
 

  • В Word 2007 выполните следующие действия, чтобы добавить команду "Сохранить все" на панель быстрого доступа.

    1. Нажмите кнопку Microsoft Office, а затем — Параметры Word.
    2. Нажмите Настройка.
    3. В поле Выбрать команды из: выберите пункт Все команды.
    4. В списке под полем "Выбрать команды от " нажмите кнопку "Сохранить все", а затем нажмите кнопку "Добавить".
    5. Нажмите кнопку "ОК", чтобы закрыть диалоговое окно "Параметры Word".
  • В Word 2003 и более ранних версиях Word выполните следующие действия, чтобы добавить команду "Сохранить все" в меню "Файл".

    1. В меню "Сервис " выберите пункт "Настроить".
    2. На вкладке "Команды " выберите "Файл " в разделе "Категории".
    3. В разделе "Команды" перетащите команду "Сохранить все " в меню "Файл ". Когда откроется меню "Файл ", поместите команду "Сохранить все " в нужное место.
    4. Закройте диалоговое окно "Настройка ".

Способ 3. Обратитесь в Adobe

Обратитесь в Adobe Systems Incorporated, чтобы определить, доступно ли обновление для Acrobat 7.0.

Microsoft предоставляет контактные данные третьих лиц, чтобы вы могли получить техническую поддержку. Эти контактные данные могут меняться без уведомления. Microsoft не гарантирует точность контактных данных третьих лиц.

Способ 4. Удаление надстройки Adobe из Office

Удалив надстройку Adobe, вы не сможете сохранить файл в формате PDF-файла в программе Office.

Чтобы удалить надстройку Adobe, выполните следующие действия.

Примечание, поскольку существует несколько версий Microsoft Windows, указанные ниже действия могут отличаться на вашем компьютере. Если это так, обратитесь к документации по продукту, чтобы выполнить эти действия.

  1. Закройте все программы.
  2. Нажмите кнопку Пуск, наведите указатель мыши на пункт Настройка и выберите команду Панель управления.
  3. Дважды щелкните "Установка или удаление программ".
  4. В разделе "Установленные программы" щелкните Adobe Acrobat Professional 7.0, а затем нажмите кнопку "Изменить".
  5. Нажмите кнопку "Изменить", а затем кнопку "Далее".
  6. Разверните "Создать Adobe PDF".
  7. Разверните Acrobat PDFMaker.
  8. Щелкните стрелку рядом с Microsoft Office и выберите пункт Не установлено.
  9. В мастере настройки Adobe Acrobat Professional 7.0 нажмите кнопку «ОК».
  10. Закройте Установка или удаление программ.

Если после выполнения этих действий по-прежнему наблюдаются указанные выше симптомы, можно вручную удалить надстройку Adobe из реестра.

Важно! Прежде чем вручную удалить надстройку Adobe, обратитесь в Adobe за дополнительной информацией.

Внимание! В этом разделе метод или задача содержит шаги по изменению реестра. Однако ошибки при изменении реестра могут привести к серьезным проблемам. Поэтому будьте внимательны, выполняя описанные действия. В качестве дополнительной меры предосторожности перед внесением изменений создайте резервную копию реестра. Тогда в случае возникновения проблемы вы сможете восстановить реестр. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:

322756 Резервное копирование и восстановление реестра Windows

Чтобы вручную удалить надстройку Adobe, выполните следующие действия.

  1. Нажмите кнопку Пуск, нажмите кнопку Выполнить, введите команду regedit и нажмите кнопку ОК.

  2. Найдите и щелкните следующий подраздел реестра:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin

  3. В меню "Файл " выберите пункт "Экспорт", введите имя файла и нажмите кнопку "Сохранить".

  4. Щелкните правой кнопкой мыши запись реестра PDFMaker.OfficeAddin и нажмите кнопку Удалить.

  5. Выполните действия 3 и 4, чтобы удалить записи реестра надстроек в следующих подразделах реестра:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin

       

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook

  6. Закройте редактор реестра.

Дополнительные сведения

Глобальный шаблон (файл Normal.dotm в Word 2007 и файл Normal.dot в Word 2003 и более ранних версиях Word) — это стандартный шаблон, используемый Word. По умолчанию изменения, влияющие на все новые документы, сохраняются в глобальном шаблоне. Это поведение, если при сохранении изменений не указан другой шаблон. В Acrobat 7.0 приложение Word может запретить автоматическое сохранение изменений в глобальном шаблоне.

Для получения дополнительной информации об этой проблеме посетите следующий веб-сайт Adobe:

http://www.adobe.com/products/acrobat.html?promoid=IUGXF