Des problèmes peuvent se produire lors du transfert de fichiers vers ou à partir d'un périphérique connecté à un concentrateur USB 2.0 dans Microsoft Windows XP

Traductions disponibles Traductions disponibles
Numéro d'article: 908673 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Vous essayez de transférer des fichiers vers ou à partir d'un périphérique connecté à un concentrateur USB dans Microsoft Windows XP. Lorsque vous effectuez cette opération, vous pouvez rencontrer un ou plusieurs des problèmes suivants :
  • Lorsque vous tentez de transférer des fichiers, le transfert échoue. Un message d'erreur peut s'afficher concernant une erreur d'écriture différée. Le message d'erreur peut varier en fonction du périphérique utilisé.
  • D'autres périphériques USB connectés au concentrateur USB 2.0 peuvent cesser de fonctionner. Vous recevez un message indiquant que les périphériques USB ont été déconnectés ou reconnectés.
  • Les périphériques USB peuvent être déconnectés, puis énumérés à nouveau.
  • Un clavier USB peut cesser de fonctionner correctement. Par exemple, le comportement des touches peut être irrégulier. Lorsque vous appuyez sur une touche, l'entrée peut être répétée plusieurs fois, ou rien ne se produit.
Remarque Certains ordinateurs sont équipés d'un concentrateur USB 2.0 interne. Par exemple, un ordinateur portable peut avoir un seul bus USB et utiliser un concentrateur USB interne pour fournir deux ou plusieurs ports USB disponibles sur l'ordinateur. Par conséquent, ce problème peut survenir si le périphérique est connecté directement au port USB de l'ordinateur.

Ce problème peut également se produire si le périphérique est interne et connecté par voie interne au concentrateur USB 2.0. Par exemple, ce problème peut se produire si vous utilisez un ordinateur portable équipé d'une radio Bluetooth interne qui est connectée à un concentrateur USB 2.0 interne. Lorsque vous utilisez ce périphérique Bluetooth pour transférer les fichiers à un autre périphérique, vous pouvez rencontrer les problèmes décrits dans la section « Symptômes ».

Cause

Ce problème peut se produire si le concentrateur USB 2.0 est soumis à un trafic important et que vous transférez des fichiers vers un périphérique USB à faible débit ou à débit maximal. Le problème ne se produit pas lorsque vous transférez des fichiers vers un périphérique USB à haut débit.

Pour plus d'informations sur les vitesses de transfert des données USB 2.0, reportez-vous à la section « Plus d'informations ».

De plus, ce problème a été observé sur les ordinateurs qui utilisent des processeurs (UC) Transmeta.

Résolution

Informations sur le correctif logiciel

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Ne l'appliquez qu'aux systèmes sur lesquels vous constatez ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, il est recommandé d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif logiciel est disponible pour téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le correctif auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non directement liés au correctif logiciel en question. Pour obtenir la liste complète des numéros de téléphone des services de Support technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si votre langue n'est pas répertoriée, cela signifie qu'aucun correctif logiciel n'est disponible pour cette langue.

Informations sur les fichiers

La version anglaise de ce correctif logiciel possède les attributs de fichier indiqués dans le tableau suivant ou ceux d'une version ultérieure. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties à l'heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire de l'outil Date et heure du Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom du fichierVersion du fichierTaille du fichierDateHeurePlateformeSP requisDossier
Usbehci.sys5.1.2600.278327,26425-oct-200523:39x86SP2SP2QFE
Usbport.sys5.1.2600.2783143,10425-oct-200523:39x86SP2SP2QFE
Lorsque vous appliquez ce package de correctifs logiciels, la clé de Registre suivante est automatiquement ajoutée et configurée :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USB\EnSoftRetry
La clé de Registre est configurée avec une valeur DWORD égale à 1. Cette valeur permet d'activer le chemin de code Soft-Retry qui est utilisé dans ce correctif logiciel.

Lorsque ce correctif logiciel est appliqué, un transfert USB qui échoue pour des raisons spécifiques est retenté de manière silencieuse et ne se termine pas avec un état d'« erreur ». Lorsque ce processus a lieu, les pilotes de périphériques clients USB peuvent ne pas recevoir de notification indiquant que la communication avec le périphérique a échoué en raison d'une erreur de niveau inférieur sur le bus USB.

Si le périphérique USB concerné nécessite un fonctionnement correct de la génération de rapports, vous ne devez pas appliquer ce correctif logiciel. Ou bien vous devez désactiver la fonctionnalité Soft-Retry en affectant la valeur 0 à la clé de Registre EnSoftRetry.

Un processus Soft-Retry a lieu lorsque les conditions suivantes sont remplies :
  • la valeur de Registre est activée ;
  • L'erreur signalée par le contrôleur hôte EHCI (Enhanced Host Controller Interface) USB pour le transfert effectué est l'une des suivantes :
    • Transaction error (XactErr) (Erreur de transaction (XactErr))
    • Missed micro-frame (Micro-trame manquée)
    Ces conditions d'erreur sont décrites en détail dans la spécification relative au contrôleur EHCI USB comme suit :
    Transaction error (XactErr). (Erreur de transaction (XactErr).) Set to a one by the Host Controller during status update in the case where the host did not receive a valid response from the device (Timeout, CRC, Bad PID, etc.). (Défini sur un par le contrôleur hôte lors de la mise à jour de l'état dans le cas où l'hôte n'a pas reçu de réponse correcte du périphérique (Timeout, CRC, Bad PID, etc.).) Refer to Section 4.15.1.1 for summary of the conditions that affect this bit. (La section 4.15.1.1 comporte un récapitulatif des conditions qui affectent ce bit.) 
    Missed micro-frame (Micro-trame manquée) This bit is set when the host controller detected that a host-induced hold-off caused the host controller to miss a required complete-split transaction. (Ce bit est défini lorsque le contrôleur hôte a détecté qu'en raison d'une retenue induite par l'hôte, le contrôleur hôte a manqué une transaction complète-partagée.) 
Pour plus d'informations sur la spécification EHCI USB, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.intel.com/technology/usb/ehcispec.htm

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Plus d'informations

Vitesses de transfert de données prises en charge par USB 2.0

USB 2.0 prend en charge les vitesses de transfert de données maximales suivantes, selon la quantité de bande passante de bus requise par le périphérique :
  • 1,5 mégabits par seconde (Mbits/s) pour les périphériques à faible débit qui n'utilisent pas beaucoup de bande passante. Ces périphériques comprennent notamment les souris et les claviers ;
  • 12 Mbits/s pour les périphériques à débit maximal et à performances plus élevées. Ces périphériques comprennent notamment les périphériques de stockage, les haut-parleurs, les scanneurs et les appareils photo numériques ;
  • 480 Mbits/s pour les périphériques à haut débit. Ces périphériques comprennent les périphériques de stockage de masse et les graveurs de CD et de DVD à haute vitesse.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 908673 - Dernière mise à jour: mercredi 18 mai 2011 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
  • Windows Vista Professionnel
  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Basique
  • Windows Vista Édition Familiale Premium
  • Windows Vista Service Pack 1
  • Windows Vista Starter
  • Windows Vista Édition Intégrale
  • Windows Vista Entreprise 64 bits
  • Windows Vista Édition Familiale Basique 64 bits
  • Windows Vista Édition Familiale Premium 64 bits
  • Windows Vista Édition Intégrale 64 bits
  • Windows Vista Professionnel 64 bits
  • Windows 7 Entreprise
  • Windows 7 Édition Familiale Basique
  • Windows 7 Édition Familiale Premium
  • Windows 7 Professionnel
  • Windows 7 Édition Starter
  • Windows 7 Édition Integrale
Mots-clés : 
kbautohotfix kbexpertisebeginner kbqfe kbhotfixserver KB908673
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com