Symptômes
Lorsque vous essayez de démarrer un des jeux Microsoft répertoriés dans la section « s’applique à », l’un des messages d’erreur suivants s’affiche :
Message d’erreur 1
Le fichier d3dx9_25. dll est introuvable
Message d’erreur 2
Le fichier d3dx9_27. dll est introuvable
Cause
Ce problème peut se produire si le fichier Microsoft DirectX mentionné dans le message d’erreur est endommagé ou n’est pas copié correctement.
Résolution
Télécharger et installer la dernière version de DirectX
Pour résoudre ce problème, téléchargez et installez la dernière version du programme d’exécution de l’utilisateur final de DirectX. Pour cela, accédez au site web de Microsoft à l’adresse suivante :
http://www.microsoft.com/download/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en Remarque Le message d’erreur suivant peut s’afficher au cours de l’installation :
Le logiciel que vous installez n’a pas été validé lors du test permettant d’obtenir le logo Windows et vérifiant sa compatibilité avec cette version de Windows. (Indiquez-moi pourquoi ce test est important.)
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
822798 Impossible d’installer certains programmes ou mises à jour
Copie manuelle du fichier
Pour résoudre ce problème, copiez le fichier D3dx9_25. dll ou D3dx9_27. dll à partir du disque 1 CD/DVD du jeu CD/DVD de jeu dans le dossier de jeu correspondant. Pour cela, suivez la procédure adaptée à votre version de Windows :
Windows 7 ou Windows Vista
-
Insérez le CD 1 CD/DVD de votre jeu dans le lecteur de CD/DVD de votre ordinateur.
-
Cliquez sur Démarrer . , puis cliquez sur documents.
-
Recherchez, puis cliquez sur ordinateur.
-
Recherchez le lecteur de CD/DVD, puis cliquez dessus.
-
Recherchez puis cliquez sur le dossier suivant :
CDDrive:\ DirectX9 Remarque Dans ce chemin d’accès, CDDrivereprésente la lettre du lecteur du CD.
-
Double-cliquez sur Apr2005_d3dx9_25_x86. cab, cliquez avec le bouton droit sur d3dx9_25. dll, puis cliquez sur copier.
Remarque Utilisez le fichier Apr2005_d3dx9_25_x64. cab pour la version x64 du système d’exploitation Windows.
-
Recherchez le dossier suivant pour votre jeu :
Lecteur: \Program Files\Microsoft jeux \titre du jeu Remarque Dans ce chemin d’accès, Drivereprésente la lettre du lecteur sur lequel le jeu est installé et le titre du jeu représente le jeu que vous voulez réparer.
-
Cliquez avec le bouton droit sur le dossier de jeu correspondant au jeu installé sur l’ordinateur, puis cliquez sur coller. Remarque Si vous avez installé plusieurs jeux sur votre ordinateur, répétez les étapes 7and 8 pour les autres jeux.
Windows XP
-
Insérez le CD 1 CD/DVD de votre jeu dans le lecteur de CD/DVD de votre ordinateur.
-
Cliquez sur Démarrer, pointez sur programmes, sur accessoires, puis cliquez sur Explorateur Windows.
-
Recherchez puis cliquez sur le dossier suivant :
CDDrive:\ DirectX9 Remarque Dans ce chemin d’accès, CDDrivereprésente la lettre du lecteur du CD.
-
Double-cliquez sur Apr2005_d3dx9_25_x86. cab, cliquez avec le bouton droit sur d3dx9_25. dll, puis cliquez sur copier.
Remarque Utilisez le fichier Apr2005_d3dx9_25_x64. cab pour la version x64 du système d’exploitation Microsoft Windows.
-
Recherchez le dossier suivant pour votre jeu :
Lecteur: \Program Files\Microsoft jeux \titre du jeu
Remarque Dans ce chemin d’accès, Drive représente la lettre d’un lecteur sur lequel est installé le jeu et le titre du jeu représente le jeu que vous voulez réparer.
-
Cliquez avec le bouton droit sur le dossier de jeu correspondant au jeu installé sur l’ordinateur, puis cliquez sur coller. Remarque Si vous avez installé plusieurs jeux sur votre ordinateur, répétez les étapes 5 et 6 pour les autres jeux.
Étapes suivantes
Si vous avez besoin d’aide, consultez le site web des services du support technique Microsoft pour trouver d’autres solutions. Ce site web fournit les services suivants :
-
Microsoft Community (http://Answers.Microsoft.com/en-US/Windows/default.aspx) : interagissez avec des collègues et des MVP (Most Valuable Professionals) Microsoft.
-
Centres de solutions (http://support.microsoft.com/select/?target=hub) : affichez les questions les plus fréquentes spécifiques au produit et les points principaux du support.
-
Base de connaissances offrant des fonctions de recherche (http://support.microsoft.com/search/?adv=1) : recherchez des informations de support technique et des outils d’auto-assistance pour les produits Microsoft.
-
Autres options de support (http://support.microsoft.com/default.aspx?pr=csshome) : utilisez Internet pour poser une question, contacter les services du support technique Microsoft ou transmettre vos commentaires.