Windows XP SP2'de Windows Güvenlik Duvarı hizmeti başlatılamıyor

Makale çevirileri Makale çevirileri
Makale numarası: 920074 - Bu makalenin geçerli olduğu ürünleri görün.
Önemli Bu makale, kayıt defterini değiştirmeyle ilgili bilgiler içermektedir. Kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Sorun oluşması durumunda kayıt defterini nasıl geri yükleyeceğinizi bildiğinizden emin olun. Kayıt defterini yedekleme, geri yükleme ve değiştirme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986 Microsoft Windows Kayıt Defteri'nin Açıklaması
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Microsoft Windows XP Service Pack 2'yi (SP2) yükledikten sonra, Windows Güvenlik Duvarı hizmetini başlatamazsınız. Özellikle, aşağıdaki belirtilerden bir veya daha fazlasıyla karşılaşabilirsiniz:
  • Denetim Masası'ndaki Hizmetler listesinde Windows Güvenlik Duvarı/Internet Bağlantı Paylaşımı (ICS) görüntülenmez.
  • Hizmetler listesinde Windows Güvenlik Duvarı/Internet Bağlantı Paylaşımı (ICS) görüntülenir, ancak bu hizmeti başlatamazsınız.
  • Windows Güvenlik Duvarı ayarlarına erişmeye çalıştığınızda aşağıdaki hata iletisini alırsınız:
    Windows, tanımlanamayan bir sorun nedeniyle Windows Güvenlik Duvarı ayarlarını görüntüleyemiyor.

Neden

Bu sorun, eksik veya bozuk bir SharedAccess.reg dosyası nedeniyle oluşur. SharedAccess.reg dosyası, Windows Güvenlik Duvarı hizmetini temsil eder.

Not Windows XP SP2'deki Windows Güvenlik Duvarı, Windows XP'nin önceki sürümlerindeki Internet Bağlantısı Güvenlik Duvarı (ICF) hizmetinin yerine kullanılmaktadır.

Çözüm

Bu sorunu gidermek için aşağıdaki yöntemlerden birini kullanın.

Yöntem 1: Windows Güvenlik Duvarı'nı yüklemek üzere "Setup API InstallHinfSection" işlevini çağırma

Windows Güvenlik Duvarı'nı yüklemek için şu adımları izleyin:
  1. Başlat'ı tıklatın, Çalıştır'ı tıklatın, cmd yazın ve Tamam'ı tıklatın.
  2. Komut istemine aşağıdaki komutu yazın ve ENTER tuşuna basın:
    Rundll32 setupapi,InstallHinfSection Ndi-Steelhead 132 %windir%\inf\netrass.inf
  3. Windows'u yeniden başlatın.
  4. Başlat'ı tıklatın, Çalıştır'ı tıklatın, cmd yazın ve Tamam'ı tıklatın.
  5. Komut istemine şu komutu yazın ve ENTER tuşuna basın:
    Netsh firewall reset
  6. Başlat'ı ve sonra Çalıştır'ı tıklatın, firewall.cpl yazın ve ENTER tuşuna basın. Windows Güvenlik Duvarı iletişim kutusunda, Açık (önerilir) seçeneğini ve sonra da Tamam'ı tıklatın.

Yöntem 2: Kayıt defterine Windows Güvenlik Duvarı girdisini ekleme

Uyarı Kayıt Defteri Düzenleyicisi'ni veya başka bir yöntemi kullanarak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu sorunlar, işletim sisteminizi yeniden yüklemenizi gerektirebilir. Microsoft bu sorunların çözülebileceğini garanti etmemektedir. Kayıt defterini değiştirmek kendi sorumluluğunuzdadır.

Windows Güvenlik Duvarı girdisini kayıt defterine eklemek için şu adımları izleyin:
  1. Aşağıdaki metni Not Defteri'ne kopyalayın ve dosyayı Sharedaccess.reg adıyla kaydedin:
    Windows Kayıt Defteri Düzenleyicisi Sürüm 5.00
    
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess]
    "DependOnGroup"=hex(7):00,00
    "DependOnService"=hex(7):4e,00,65,00,74,00,6d,00,61,00,6e,00,00,00,57,00,69,00,\
      6e,00,4d,00,67,00,6d,00,74,00,00,00,00,00
    "Description"="Ev veya küçük işyeri ağları için ağ adresi çevirme, adresleme, ad çözme ve/veya yetkisiz giriş engelleme hizmetleri sağlar."
    "DisplayName"="Windows Güvenlik Duvarı/Internet Bağlantı Paylaşımı (ICS)"
    "ErrorControl"=dword:00000001
    "ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
      74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
      00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
      6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00
    "ObjectName"="LocalSystem"
    "Start"=dword:00000002
    "Type"=dword:00000020
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch]
    "Epoch"=dword:00002cd0
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters]
    "ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
      00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
      69,00,70,00,6e,00,61,00,74,00,68,00,6c,00,70,00,2e,00,64,00,6c,00,6c,00,00,\
      00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List]
    "%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\AuthorizedApplications\List]
    "%windir%\\system32\\sessmgr.exe"="%windir%\\system32\\sessmgr.exe:*:enabled:@xpsp2res.dll,-22019"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Setup]
    "ServiceUpgrade"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Setup\InterfacesUnfirewalledAtUpdate]
    "All"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Enum]
    "0"="Root\\LEGACY_SHAREDACCESS\\0000"
    "Count"=dword:00000001
    "NextInstance"=dword:00000001
  2. Sharedaccess.reg dosyası içeriğini kayıt defteriyle birleştirmek ve Windows Güvenlik Duvarı girdisini oluşturmak üzere bu dosyayı çift tıklatın.
  3. Windows'u yeniden başlatın.
  4. Başlat'ı tıklatın, Çalıştır'ı tıklatın, cmd yazın ve Tamam'ı tıklatın.
  5. Komut istemine şu komutu yazın ve ENTER tuşuna basın:
    Netsh firewall reset
  6. Başlat'ı tıklatın, Çalıştır'ı tıklatın, firewall.cpl yazın ve sonra Tamam'ı tıklatın.
  7. Kullanmak istediğiniz Windows Güvenlik Duvarı ayarlarını yapılandırın.
Bu yöntemler işe yaramazsa, Windows XP SP2'yi yeniden yükleyin.

Daha fazla bilgi

Windows Güvenlik Duvarı hizmetinin başlatıldığını doğrulamak için şu adımları izleyin:
  1. Başlat'ı tıklatın, Çalıştır'ı tıklatın, services.msc yazın ve Tamam'ı tıklatın.
  2. Hizmetler listesinde, Windows Güvenlik Duvarı/Internet Bağlantı Paylaşımı (ICS) hizmetini bulun. Hizmet durumunun Başladı olduğuna dikkat edin.
  3. Hizmetler özelliğini kullanma hakkında bilgi için, Eylem menüsünde Yardım'ı tıklatın.

Durum

Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Referanslar

Windows XP Service Pack 2'deki Windows Güvenlik Duvarı'nı kullanma hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
875357 Windows XP Service Pack 2'de Windows Güvenlik Duvarı ayarlarında sorun giderme
892199 Windows XP Service Pack 2'de Windows Güvenlik Duvarı hizmetini başlatamıyorsunuz
Windows XP SP2'deki Windows Güvenlik Duvarı ile ilgili sorunları giderme hakkında daha fazla bilgi için aşağıdaki Microsoft Web sitesini ziyaret edin:
http://www.microsoft.com/technet/prodtechnol/winxppro/support/wftshoot.mspx

Özellikler

Makale numarası: 920074 - Last Review: 10 Haziran 2013 Pazartesi - Gözden geçirme: 1.4
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows XP Professional Edition
Anahtar Kelimeler: 
kbprb kbfirewall kbtshoot KB920074

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com