Help and Support
 

powered byLive Search

Message d'erreur lorsque vous démarrez un ordinateur Windows Vista après avoir modifié le mode SATA du lecteur de démarrage : « STOP 0x0000007B INACCESSABLE_BOOT_DEVICE »

Numéro d'article:922976
Dernière mise à jour:mardi 9 janvier 2007
Version:2.0
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Important Cet article contient des informations sur la modification du Registre. Sauvegardez le Registre avant de le modifier. Assurez-vous de savoir comment restaurer le Registre en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 (http://support.microsoft.com/kb/256986/) Description du Registre de Microsoft Windows

Symptômes

Prenons l'exemple du scénario suivant. Dans l'outil de configuration du BIOS d'un ordinateur Microsoft Windows Vista, vous modifiez le mode SATA (Serial Advanced Technology Attachment) d'un lecteur de démarrage afin qu'il utilise la spécification AHCI (Advanced Host Controller Interface). Vous redémarrez ensuite l'ordinateur. Dans ce scénario, le message d'erreur suivant s'affiche :
STOP 0x0000007B INACCESSABLE_BOOT_DEVICE

Retour au début

Cause

Ce problème se produit si le pilote AHCI (Msahci.sys) de Windows Vista est désactivé. Ce pilote doit être activé pour que vous puissiez modifier le mode SATA du lecteur de démarrage.

Retour au début

Résolution

Avertissement Des problèmes sérieux peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou d'une autre méthode. Ces problèmes peuvent vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.Pour résoudre ce problème, activez le pilote AHCI dans le Registre avant de modifier le mode SATA du lecteur de démarrage. Pour cela, procédez comme suit :
1.Fermez toutes les applications Windows.
2.Cliquez sur Démarrer, tapez regedit dans la zone Démarrer la recherche, puis appuyez sur ENTRÉE.
3.Si la boîte de dialogue Contrôle de compte d'utilisateur s'affiche, cliquez sur Continuer.
4.Recherchez la sous-clé de Registre suivante et cliquez dessus :
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
5.Dans le volet droit, cliquez avec le bouton droit sur Démarrer dans la colonne Nom, puis cliquez sur Modifier.
6.Dans la zone Données de la valeur, tapez 0, puis cliquez sur OK.
7.Dans le menu Fichier, cliquez sur Quitter pour quitter l'Éditeur du Registre.

Retour au début

Plus d'informations

Durant l'installation de Windows Vista, tout pilote de stockage non utilisé est désactivé. Cela permet d'accélérer la procédure de démarrage du système d'exploitation. Lorsque vous remplacez le lecteur de démarrage par un pilote qui a été désactivé, vous devez activer ce nouveau pilote avant de modifier la configuration matérielle.

Supposons par exemple que vous installiez Windows Vista sur un ordinateur qui contient un contrôleur utilisant le pilote Pciide.sys. Vous remplacez ensuite le mode SATA par le mode AHCI. Le lecteur doit alors charger le pilote Msahci.sys. Par contre, vous devez activer le pilote Msahci.sys avant d'effectuer cette modification.

Ce problème ne concerne que le lecteur de démarrage. Si le lecteur que vous modifiez n'est pas le lecteur de démarrage, ce problème ne se produira pas.

AHCI fournit plusieurs fonctionnalités pour les périphériques SATA, en particulier, la connexion à chaud et la gestion de l'alimentation. Pour plus d'informations sur la spécification AHCI, reportez-vous au site Web d'Intel à l'adresse suivante :
http://www.intel.com/technology/serialata/ahci.htm (http://www.intel.com/technology/serialata/ahci.htm)
Microsoft fournit les coordonnées de sociétés tierces afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces. Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft ; nous n'accordons aucune garantie, implicite ou autre, en ce qui concerne le fonctionnement ou la fiabilité de ces produits.

Retour au début


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
?Windows Vista Business
?Windows Vista Enterprise
?Windows Vista Home Basic
?Windows Vista Home Premium
?Windows Vista Starter
?Windows Vista Ultimate

Retour au début

Mots-clés : 
kbtshoot kbhardware kberrmsg kbexpertiseinter kbprb KB922976

Retour au début

L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.