Windows Update から Windows XP Service Pack 3 をインストールしようとすると、インストールが失敗し、Windows Update ログ ファイルにエラー コードが記録される

文書翻訳 文書翻訳
文書番号: 949386 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Update から Windows XP Service Pack 3 (SP3) をインストールしようとすると、Service Pack のインストールが失敗します。 また、Windows Update ログ ファイルに次のエラー コードが記録されます。
0x80246007
Service Pack ログ ファイルを調べると、次のステータス メッセージを含むエントリが存在する場合があります。
SUS_E_DM_NOTDOWNLOADED
  • 通常、Windows Update ログ ファイルは次の場所にあります。
    C:\WINDOWS\WindowsUpdate.log
  • 通常、Service Pack ログ ファイルは次の場所にあります。
    C:WINDOWS\svcpack.log

原因

この問題は、次のいずれかの条件に該当する場合に発生することがあります。
  • Windows XP SP3 のダウンロード処理の終了後に、WINDOWS\SoftwareDistribution\Download フォルダが削除された。
  • Windows XP SP3 がダウンロードされた後、Service Pack がインストールされる前にシステム ファイルが変更された。

解決方法

この問題を解決するには、以下の方法を記載されている順に実行します。

方法 1 : Windows Update から Windows XP SP3 を再度ダウンロードする

これを行うには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[すべてのプログラム] をポイントし、[Windows Update] をクリックします。
  2. [高速] をクリックします。 コンピュータが更新プログラムの条件を満たしている場合、Windows XP SP3 が更新プログラムの 1 つとして自動的に選択されます。
  3. [更新プログラムのインストール] をクリックします。
  4. マイクロソフト ソフトウェア ライセンス条項を確認し、同意します。

方法 2 : 「Microsoft ダウンロード センター」から Windows XP SP3 をダウンロードする

これを行う方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法
マイクロソフトのサポート ファイルをダウンロードする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法

方法 3 : Software Distribution フォルダの名前を変更し、ダウンロードを再試行する

これを行うには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに cmd と入力し、[OK] をクリックします。
  2. コマンド プロンプトで、services.msc と入力します。
  3. [Automatic Updates] を右クリックし、[停止] をクリックします。
  4. C:\WINDOWS\SoftwareDistribution\Download フォルダの名前を次のように変更します。
    C:\WINDOWS\SoftwareDistribution\Download.old
  5. サービス スナップインで、[Automatic Updates] を右クリックし、[開始] をクリックします。
  6. [スタート] ボタンをクリックし、[すべてのプログラム] をポイントし、[Windows Update] をクリックします。

プロパティ

文書番号: 949386 - 最終更新日: 2008年11月11日 - リビジョン: 4.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows Update
キーワード:?
kbdownload kbwindowsupdate kbupdateissue kbupdate kbexpertisebeginner kberrmsg kbprb kbtshoot KB949386
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com