Problèmes de performances sont dus à une fuite de mémoire sur un serveur d'impression basée sur Windows Server 2008 qui possède de nombreux clients de l'imprimante basée sur Windows Vista

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Sommaire

Symptômes

Considérez le scénario suivant :
  • Vous avoir un serveur d'impression Windows Server 2008.
  • Ce serveur d'impression possède de nombreuses fenêtres Clients d'imprimante basée sur Vista.
Dans ce scénario, l'utilisation de la mémoire de la Service de spouleur d'impression augmente considérablement au fil du temps. Par exemple, ce problème se produit lorsque plusieurs clients de milliers d'imprimante envoient leurs travaux d'impression au serveur d'impression. Finalement, le serveur d'impression cesse de répondre et vous devez redémarrer le serveur pour résoudre ce problème. En fonction de la charge de l'impression, cela problème peut se produire après l'exécution du système pour une journée ou plusieurs semaines.

En outre, lorsqu'un utilisateur essaie d'imprimer les documents un ordinateur Windows Vista, l'impression travail aléatoirement échoue et l'utilisateur reçoit le message d'erreur suivant :
Windows ne peut pas Connectez-vous à l'imprimante. Le service de spouleur d'impression du serveur ne fonctionne pas. Veuillez Redémarrez le spouleur sur le serveur ou la machine serveur

Cause

Ce problème se produit en raison d'une fuite de mémoire dans le service Spouleur d'impression. Le service Spouleur d'impression gère un file d'attente de notification client unbounded. En outre, le service Spouleur d'impression met en cache une structure DEVMODE pour chaque poignée de client d'ouverture de l'imprimante. Ensemble, ces deux fonctionnalités consomment beaucoup de mémoire lorsque de nombreux clients de l'imprimante accéder à ce serveur d'impression.

En outre, Imprimante Vista clients Windows utilisent asynchrone appels de procédure distante (RPC) pour récupérer des notifications de changement d'imprimante. Par conséquent, de nombreux RPC asynchrones sont planifiées lorsque de nombreux clients de l'imprimante Utilisez le serveur d'impression. Après le nombre total d'expédiée RPC atteint un limite de 6 000, l'utilisateur du client reçoit le message d'erreur qui est mentionné dans la section « Symptômes ».

Résolution

Informations sur le correctif

A correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu. uniquement pour corriger le problème décrit dans cet article. Appliquer la correctif uniquement aux systèmes qui rencontrent ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous conseillons d'attendre pour la mise à jour de logiciel suivant contient ce correctif.

Si le correctif est disponible en téléchargement, il est une section « Téléchargement de correctif logiciel disponible » en haut de cette Base de connaissances article. Si cette section n'apparaît pas, contactez le Service clientèle de Microsoft prise en charge et pour obtenir le correctif.

RemarqueSi des problèmes supplémentaires se produisent ou si des procédures de dépannage est requis, Vous devrez créer une demande de service distinct. Les coûts habituels du support technique s'applique aux autres questions et problèmes qui ne relèvent pas de Ce correctif spécifique. Pour une liste complète du Service clientèle de Microsoft et Les numéros de téléphone du support ou pour créer une demande de service distincte, visitez le site Web de Microsoft suivant :
http://support.Microsoft.com/contactus/?ws=support
RemarqueLe formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour auquel le correctif est disponible. Si vous ne voyez pas votre langue, cela signifie qu'un correctif n'est pas disponible pour cette langue.

Correctifs de Windows Vista et Windows Server 2008 importants sont inclus dans les packages. Toutefois, seul l'un de ces produits peut-être être répertorié sur la page « Demande de correctif ». Pour demander le package de correctifs qui s'applique à Windows Vista et Windows Server 2008, sélectionnez simplement le produit est répertorié dans la page.

Conditions préalables

Aucune condition préalable n'est requis.

La nécessité de redémarrer

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de remplacement de correctif

Ce correctif ne remplace pas d'autres correctifs.

Informations sur les fichiers

La version anglaise de ce correctif possède le fichier attributs (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour trouver la différence entre l'UTC et l'heure locale, utilisez laHeure Zonel'onglet dans laDate et heureélément de contrôle Panneau de configuration.
Windows Server 2008 x 86 exécutant des versions
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Nom de fichierVersion du fichierFichier tailleDateHeurePlate-forme
Localspl.dll6.0.6001.22200634,36811-Jun-200805 : 23x 86
Spoolss.dll6.0.6001.22200163,84011-Jun-200805 : 23x 86
Spoolsv.exe6.0.6001.22200126,97611-Jun-200803 : 41x 86
Windows Server 2008, les versions Itanium
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierFichier tailleDateHeurePlate-formeBranche de service
Localspl.dll6.0.6001.222001,617,92011-Jun-200805 : 36IA-64Pas disponible
Spoolss.dll6.0.6001.22200446,46411-Jun-200805 : 39IA-64Pas disponible
Spoolsv.exe6.0.6001.22200437,24811-Jun-200804 : 19IA-64Pas disponible
Localspl.dll6.0.6001.22200634,36811-Jun-200805 : 23x 86SysWOW64
Spoolss.dll6.0.6001.22200163,84011-Jun-200805 : 23x 86SysWOW64
Windows Server 2008 x 64 des versions
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Nom de fichierVersion du fichierFichier tailleDateHeurePlate-formeBranche de service
Localspl.dll6.0.6001.22200788,48011-Jun-200805 : 50x 64Pas disponible
Spoolss.dll6.0.6001.22200241,66411-Jun-200805 : 50x 64Pas disponible
Spoolsv.exe6.0.6001.22200268,80011-Jun-200804 : 26x 64Pas disponible
Localspl.dll6.0.6001.22200634,36811-Jun-200805 : 23x 86SysWOW64
Spoolss.dll6.0.6001.22200163,84011-Jun-200805 : 23x 86SysWOW64

Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations terminologie de mise à jour de logiciel, cliquez sur l'article suivant numéro pour afficher la article de la Base de connaissances Microsoft :
824684Description de la terminologie standard utilisée pour décrire les mises à jour du logiciel Microsoft

Propriétés

Numéro d'article: 951638 - Dernière mise à jour: mardi 15 mars 2011 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Web Server 2008
Mots-clés : 
kbautohotfix kbexpertiseinter kbbug kbfix kbqfe kbmt KB951638 KbMtfr
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