Messaggio di errore quando si tenta di installare gli aggiornamenti tramite il sito Web Windows Update o il sito Web Microsoft Update: "0x80070422"

Traduzione articoli Traduzione articoli
Identificativo articolo: 958043 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di installare gli aggiornamenti tramite il sito Web Windows Update o il sito Web Microsoft Update, è possibile che venga visualizzato il seguente messaggio di errore:
0x80070422

Cause

Questo problema può verificarsi se un servizio richiesto non è in esecuzione.

Risoluzione

Microsoft Windows 2000, Windows XP e Windows Server 2003

Per risolvere questo problema, avviare i servizi necessari. Per effettuare questa operazione in Windows 2000, Windows XP o in Windows Server 2003, attenersi alla seguente procedura:
  1. Fare clic su Avviare, fare clic su Eseguire, tipo Blocco note, quindi fare clic su OK o premere INVIO.
  2. Copiare il testo seguente e quindi incollare il testo nel blocco note:
    sc config wuauserv start= auto
    sc config bits start= auto
    sc config DcomLaunch start= auto
    net stop wuauserv
    net start wuauserv
    net stop bits
    net start bits
    net start DcomLaunch
    
  3. Fare clic su File, fare clic su Salva come, quindi digitare Repair.bat.
  4. Nel Salva come tipo Fare clic su Tutti i file.
  5. Nel Salva in Fare clic su Desktop, quindi fare clic su Salva.
  6. Nel File menu, fare clic su Esci.
  7. Fare doppio clic sul file Repair.bat salvato al passaggio 5. Questa azione Avvia i servizi necessari.
  8. Provare a installare nuovamente gli aggiornamenti. Se è possibile installare gli aggiornamenti, eliminare il file Repair.bat. Per eliminare il file Repair.bat, pulsante destro del mouse Repair.bat, fare clic su Elimina, quindi fare clic su .

Windows Vista e Windows Server 2008

Per avviare i servizi necessari in Windows Vista o Windows Server 2008, attenersi alla seguente procedura:
  1. Fare clic su Avviare
    Riduci l'immagineEspandi l'immagine
     Pulsante Start
    , tipo Blocco note nel Avviare la ricerca casella e quindi scegliere Blocco note nel Programmi elenco.
  2. Copiare il testo seguente e quindi incollare il testo nel blocco note:
    sc config wuauserv start= auto
    sc config bits start= auto
    sc config DcomLaunch start= auto
    net stop wuauserv
    net start wuauserv
    net stop bits
    net start bits
    net start DcomLaunch 
    
  3. Fare clic su File, fare clic su Salva come, quindi digitare Repair.bat.
  4. Nel Salva come tipo Fare clic su Tutti i file (*. *).
  5. Nel Salva in Fare clic su Desktop, quindi fare clic su Salva.
  6. Nel File menu, fare clic su Esci.
  7. -Fare clic sul file Repair.bat salvato al passaggio 5 e quindi fare clic su Esegui come amministratore. Questa azione Avvia i servizi necessari.

    Riduci l'immagineEspandi l'immagine
    Autorizzazione di controllo di accesso utente
    Se viene chiesto di password di amministratore o di confermare, digitare la password o fare clic su Continua.
  8. Provare a installare nuovamente gli aggiornamenti. Se è possibile installare gli aggiornamenti, eliminare il file Repair.bat. Per eliminare il file Repair.bat, pulsante destro del mouse Repair.bat, fare clic su Elimina, quindi fare clic su ..
Per ulteriori informazioni su come risolvere il problema con Windows Update o Microsoft Update, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support

Proprietà

Identificativo articolo: 958043 - Ultima modifica: mercoledì 25 luglio 2012 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Update
  • Microsoft Update
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Starter
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Chiavi: 
kbwindowsupdate kbexpertisebeginner kbtshoot kbprb kbmt KB958043 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 958043
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com