文書番号: 958740 - 最終更新日: 2009年10月19日 - リビジョン: 3.2

Windows 7 および Windows Vista のスタート メニューやエクスプローラ内の表示で、一部のアプリケーションのアイコンが適切に表示されないことがある

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。

目次

すべて展開する | すべて折りたたむ

現象

Microsoft Windows 7 および Microsoft Windows Vista のログオン後、スタート メニューやエクスプローラ内の、一部のアプリケーションのアイコンが適切に表示されず、一般的なアイコン
元に戻す画像を拡大する
一般的なアイコン
として表示されることがあります。

原因

Windows 7 および Windows Vista の IconCache.db ファイル内の情報に不整合が発生するため、適切なアイコンが表示されなくなる現象が発生します。

回避策

IconCache.db ファイルの情報を一度リセットすることで、この現象を回避することができます。次のいづれかの手順を実行してください。

方法 1 : 画面の表示色を変更する方法

画面の表示色を変更すると、IconCache.db ファイル内のデータが再構築され、問題を解決できる可能性があります。

Windows 7 の場合

  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、メニューから [コントロール パネル] をクリックします。
  2. [画面の解像度の調整] をクリックし、[詳細設定] をクリックします。
  3. [モニター] タブをクリックし、[色] を現在の設定から新しい設定に変更します。たとえば、[True Color (32 ビット)] から [High Color (16 ビット)] に変更します。
  4. [適用] をクリックしてから [OK] をクリックし、変更を適用します。
  5. 手順の 3 で設定した [色] を元の設定に戻します。たとえば、[High Color (16 ビット)] から [True Color (32 ビット)] に変更します。
  6. [適用] をクリックしてから [OK] をクリックし、変更を適用します。

Windows Vista の場合

  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、メニューから [コントロール パネル] をクリックします。
  2. [個人設定] をダブルクリックし、[画像の設定] をクリックします。
  3. [色] を現在の設定から新しい設定に変更します。たとえば、[最高 (32 ビット)] から [中 (16 ビット)] に変更します。
  4. [適用] をクリックしてから [はい] をクリックし、変更を適用します。
  5. 手順の 3 で設定した [色] を元の設定に戻します。たとえば、[中 (16 ビット)] から [最高 (32 ビット)] に変更します。
  6. [適用] をクリックしてから [はい] をクリックし、変更を適用します。

方法 2 : セーフ モードで起動する方法

セーフ モードで起動することによって、IconCache.db ファイル内のデータが再構築され、問題を解決できる可能性があります。
  1. セーフ モードでコンピューターを起動させます。
  2. セーフ モードで起動後、コンピューターを通常モードで再起動させます。
Windows のセーフ モード機能の詳細については、次のマイクロソフト Web サイトを参照してください。
http://windowshelp.microsoft.com/Windows/ja-JP/Help/d063548a-3fc9-4723-99f3-b12a0c4354a81041.mspx (http://windowshelp.microsoft.com/Windows/ja-JP/Help/d063548a-3fc9-4723-99f3-b12a0c4354a81041.mspx)

方法 3 : IconCache.db ファイルを削除する方法

IconCache.db を削除して Windows 7 または Windows Vista に再度ログオンすると、IconCache.db ファイルは自動的に再作成されます。

Windows 7 の場合

  1. 隠し属性ファイルを表示する設定に変更します。
    1. [スタート] ボタン
      元に戻す画像を拡大する
      [スタート] ボタン
      をクリックし、メニューから [コントロール パネル] をクリックします。
    2. 右上にある [表示方法] から、[大きいアイコン] または [小さいアイコン] をクリックします。
    3. [フォルダ オプション] アイコンをクリックします。
    4. [表示] タブをクリックします。
    5. [詳細設定] の [ファイルとフォルダーの表示] 項目の [隠しファイル、隠しフォルダー、および隠しドライブを表示する] オプション ボタンをクリック します。
    6. [OK] をクリックし、[コントロール パネル] を閉じます。
  2. Local フォルダを見つけて、Local フォルダにある IconCache.db ファイルを Shift + Del キーを押して削除します。

    Windows 7 がデフォルト値の状態では、このフォルダは次の場所にあります。

    %systemdrive%\ユーザー\<ログオン ユーザー名>\AppData\Local

    ファイルを検索する方法については、次のマイクロソフト Web サイトを参照してください。
    ファイルまたはフォルダを検索する
    http://windowshelp.microsoft.com/Windows/ja-JP/help/ed53ade7-cfb8-425a-841d-6a6aa6991dfe1041.mspx#ENC (http://windowshelp.microsoft.com/Windows/ja-JP/help/ed53ade7-cfb8-425a-841d-6a6aa6991dfe1041.mspx#ENC)
  3. Windows 7 を一旦ログオフし、再度ログオンします。

Windows Vista の場合

  1. 隠し属性ファイルを表示する設定に変更します。
    1. [スタート] ボタン
      元に戻す画像を拡大する
      [スタート] ボタン
      をクリックし、メニューから [コントロール パネル] をクリックします。
    2. 左側にあるメニューから、[クラッシック表示] リンクをクリックします。
    3. [フォルダ オプション] アイコンをクリックします。
    4. [表示] タブをクリックします。
    5. [詳細設定] の [ファイルとフォルダの表示] 項目の [すべてのファイルとフォルダを表示する] オプション ボタンをクリックします。
    6. [OK] をクリックし、[コントロール パネル] を閉じます。
  2. Local フォルダを見つけて、Local フォルダにある IconCache.db ファイルを Shift + Del キーを押して削除します。

    Windows Vista がデフォルト値の状態では、このフォルダは次の場所にあります。

    %systemdrive%\ユーザー\<ログオン ユーザー名>\AppData\Local

    ファイルを検索する方法については、次のマイクロソフト Web サイトを参照してください。
    ファイルまたはフォルダを検索する
    http://windowshelp.microsoft.com/Windows/ja-JP/help/ed53ade7-cfb8-425a-841d-6a6aa6991dfe1041.mspx#ENC (http://windowshelp.microsoft.com/Windows/ja-JP/help/ed53ade7-cfb8-425a-841d-6a6aa6991dfe1041.mspx#ENC)
  3. Windows Vista を一旦ログオフし、再度ログオンします。
注 : Copyprofile オプションを使用した、システム準備 (sysprep) ツールの実行を検討している場合で、sysprep ツールを実行前に本現象が発生した際は、必ず IconCache.db を削除してから sysprep ツールを実行してください。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

この資料は以下の製品について記述したものです。
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows 7 Ultimate
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Home Premium
  • Windows 7 Home Basic
  • Windows 7 Starter
キーワード:?
kbharmony kbexpertisebeginner kbnofix kbbug kbtshoot kbexpertiseinter KB958740
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"