Numéro d'article: 969519 - Dernière mise à jour: jeudi 30 avril 2009 - Version: 2.0

Message d'erreur lorsque vous créez un profil dans Outlook 2007 après l'installation de la mise à jour cumulative qui est décrite dans l'article 961752 de la Base de connaissances Microsoft : « Outlook n'a pas pu se connecter »

Sommaire

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Symptômes

Lorsque vous créez un profil dans Outlook 2007, le message d'erreur suivant peut s'afficher :

Outlook n'a pas pu se connecter. Vérifiez que vous êtes bien connecté au réseau et que le serveur et le nom de la boîte aux lettres utilisés sont corrects. La connexion à Microsoft Exchange n'est pas disponible. Outlook doit être en ligne ou connecté pour effectuer cette action.
Ce problème survient après l'installation de la mise à jour cumulative datée du 24 février 2009 décrite dans l'article 961752 de la Base de connaissances Microsoft et si l'une des conditions suivantes est vérifiée :
  • Dans votre serveur de boîtes aux lettres Exchange, la valeur de Registre « No RFR Service » a la valeur 1.

    Pour plus d'informations sur le chemin d'accès de Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    302914  (http://support.microsoft.com/kb/302914/ ) Comment Outlook 2000 accède-t-il à Active Directory
  • Vous spécifiez le nom d'un catalogue global comme nom de serveur dans les paramètres de profil Outlook et ce catalogue global n'est pas un serveur Exchange.

Cause

Ce problème se produit en raison d'une modification de code dans Outlook 2007 qui est incluse dans la mise à jour décrite dans l'article 961752 de la Base de connaissances. Une fois la mise à jour installée, Outlook continue de supposer que vous vous connectez à une boîte aux lettres Exchange 2000 Server, ou à une version ultérieure, et continue d'utiliser le service de redirection lorsque vous créez un nouveau profil.

Si la valeur de Registre « No RFR Service » a la valeur 1 sur Exchange Server, le serveur est configuré pour continuer à utiliser DSProxy. Or, Outlook ne prend plus en charge DSProxy une fois la mise à jour installée et il ne peut donc pas atteindre votre serveur de catalogue global.

Un serveur de catalogue global ne prend pas en charge le service de redirection. Par conséquent, si vous spécifiez le catalogue global comme nom de serveur Exchange et que vous n'avez pas installé Exchange sur le serveur de catalogue global, ce dernier ne peut pas vous fournir les informations de serveur Exchange.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes ci-dessous.

Méthode 1

Ne spécifiez pas de serveur de catalogue global lorsque vous créez votre profil Outlook.

Si vous spécifiez un serveur de catalogue global lors de la création manuelle de votre profil Outlook et que vous n'avez pas installé Exchange sur le serveur de catalogue global, spécifiez le nom d'un serveur Exchange de votre organisation.

Si vous utilisez un fichier .prf pour créer votre profil Outlook et que ce fichier .prf spécifie un serveur de catalogue global comme nom de serveur de boîtes aux lettres Exchange, modifiez le fichier .prf afin qu'il utilise le nom d'un serveur Exchange de votre organisation au lieu d'un serveur de catalogue global.

Méthode 2

Cessez d'utiliser la valeur de Registre « No RFR Service » sur le serveur Exchange.

Si vous utilisez la valeur de Registre « No RFR Service » sur un serveur Exchange Server 2003 ou Exchange Server 2007, vous pouvez contourner ce problème en procédant comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter, tapez regedit dans la zone Ouvrir, puis cliquez sur OK.
  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters
  3. Cliquez avec le bouton droit sur No RFR Service, puis cliquez sur Modifier.
  4. Dans la zone Données de la valeur, tapez 0, puis cliquez sur OK.
  5. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  6. Tapez Refer TCPIP to DsProxy, puis appuyez sur ENTRÉE.
  7. Cliquez avec le bouton droit sur Refer TCPIP to DsProxy, puis cliquez sur Modifier.
  8. Dans la zone Données de la valeur, tapez 1, puis cliquez sur OK.
  9. Quittez l'Éditeur du Registre.
  10. Redémarrez le service Surveillance du système Exchange, ainsi que les autres services dépendants.

Plus d'informations

Avant que vous n'installiez la mise à jour décrite dans l'article 961752 de la Base de connaissances Microsoft, Outlook utilise la logique de connexion au serveur de catalogue global suivante lorsque vous créez un nouveau profil. Lorsque vous créez un nouveau profil Outlook, le client doit connaître le nom de votre serveur de catalogue global. Lors de la procédure initiale de création de profil, Outlook ne connaît pas la version Exchange qui héberge votre boîte aux lettres. Outlook suppose donc que le serveur Exchange prend en charge le service DSProxy et utilise le nom de serveur Exchange comme nom de serveur de catalogue global. Outlook invite alors Exchange à rediriger via proxy les appels NSPI (Name Service Provider Interface) vers le serveur de catalogue global réel.

Remarque Exchange connaît les serveurs de catalogue global auxquels il peut se connecter.

Une fois cette connexion initiale établie et le premier démarrage d'Outlook réussi, Outlook place en mémoire cache la version d'Exchange qui héberge votre boîte aux lettres. Étant donné qu'Outlook 2007 prend uniquement en charge les connexions avec Exchange 2000 Server et avec les versions ultérieures, Outlook sait que ces versions d'Exchange prennent en charge le service de redirection (DSRefer). Par conséquent, Outlook utilise le service de redirection sur Exchange au lieu d'utiliser DSProxy pour obtenir le nom d'un serveur de catalogue global. Dès qu'Outlook possède le nom du serveur de catalogue global, les appels NSPI sont envoyés directement au serveur de catalogue global.

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
961752  (http://support.microsoft.com/kb/961752/ ) Description du package de correctifs logiciels Outlook 2007 (Outlook.msp) daté du 24 février 2009

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Outlook 2007
Mots-clés : 
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