رسالة خطأ: لمنع الفقدان المحتمل للبيانات، يتعذر على Microsoft Excel إزاحة الخلايا غير الفارغة من ورقة العمل

ينطبق على
Office Products Excel 2010

الأعراض

عند محاولة إدراج صفوف أو أعمدة في ورقة عمل Microsoft Excel 2000، قد تتلقى رسالة خطأ مشابهة للرسالة الآتية:

ملاحظة

لمنع الفقدان المحتمل للبيانات، يتعذر على Microsoft Excel إزاحة الخلايا غير الفارغة من ورقة العمل.

السبب

قد تحدث هذه المشكلة إذا تمت إضافة صيغة إلى ورقة العمل بأكملها، أو في حالة إضافة تنسيق (مثل حد) إلى عمود أو صف بأكمله.

الدقة

لحل هذه المشكلة، امسح كل خلية من الخلايا في الصف أو العمود، ثم قم بإزالة أي تنسيق من الصفوف والأعمدة المتبقية. اتبع هذه الخطوات للقيام بذلك:

  1. انقر فوق خلية العنوان في العمود الفارغ الأول إلى يسار البيانات. (خلية العنوان هي الخلية الأولى في كل عمود، وتشير إلى العمود الذي تتواجد فيه).

  2. اضغط باستمرار على CTRL+SHIFT، ثم اضغط على مفتاح السهم إلى اليمين لتحديد كافة الأعمدة إلى يسار العمود الأول الذي نقرت فوقه.

  3. ضمن القائمة تحرير، انقر فوق حذف.

  4. انقر فوق الصف الأول الفارغ أسفل الصف الأخير في بياناتك.

  5. اضغط باستمرار على CTRL+SHIFT، ثم اضغط على مفتاح السهم لأسفل لتحديد كافة الصفوف الموجودة أسفل الصف الأول الذي نقرت فوقه.

  6. ضمن القائمة تحرير، انقر فوق حذف.

    ملاحظة: لإزالة أي تنسيق من الخلايا المتبقية، تابع اتباع الخطوات التالية.

  7. انقر فوق الخلية الصغيرة الواقعة بين عنوان الصف الأول وعنوان العمود الأول لتحديد ورقة العمل بأكملها.

  8. في القائمة "تنسيق"، انقر فوق "خلايا"، ثم انقر فوق علامة التبويب "حد".

    ملاحظة: قد يختلف التنسيق المضاف إلى الخلايا المتبقية. تفترض الخطوة 8 أنك تريد إزالة تنسيق الحدود. لإزالة أنواع أخرى من التنسيقات، قد تحتاج إلى تغيير الإعدادات ضمن علامة تبويب أخرى في مربع الحوار تنسيق الخلايا.

  9. انقر فوق بلا، ثم انقر فوق موافق.

  10. انقر فوق أي خلية في الصف حيث تريد إدراج الصف.

  11. في قائمة إدراج، انقر فوق صف. لإدراج عمود، انقر فوق "عمود".