تعرف المشكلة الخاصة بتحديثات الأمان 3098779 و 3097997 ل. NET Framework 4.5.1 و 4.5.2 بعد تثبيت 4.6. NET Framework على ويندوز 8.1 Windows RT 8.1 و Windows Server 2012 R2

هام: تمت ترجمة هذه المقالة باستخدام برامج مايكروسوفت للترجمة الآلية ومن المحتمل ان يتم تحريرها او تدقيقها بعد ذلك من خلال تكنولوجيا منصة مجموعات الترجمة(CTF) او من خلال مترجم بشري. تقدم لك شركة مايكروسوفت هذه المقالات المترجمة بشكل آلي او بالترجمة البشرية او بعد تحريرها وتدقيقها من قبل مجموعات الترجمة حتى تمكنكم من الوصول إلى جميع المقالات الموجودة في قواعد المعرفة لديها بلغات مختلفة. إلا أن المقالات المترجمة قد تحتوي على أخطاء في المفردات او بناء الجمل او النحو. وعليه، فإن شركة مايكروسوفت ليست مسؤولة عن اية أخطاء او عدم دقة في الترجمة او أية أضرار قد تحدث نتيجة أخطاء في ترجمة محتويات النص او استخدامه من قبل العملاء.

اضغط هنا لرابط المقالة باللغة الانجليزية3118750
الموجز
العملاء الذين تقوم بالترقية من NET Framework 4.5.1 أو 4.5.2 إلى 4, 6 ب. NET Framework أو الذي قام بتثبيت Visual Studio 2015 بعد تثبيت التحديثات 3098779 و 3097997 قد تواجه مشكلات عند تشغيل تطبيقات NET Framework.

أيضا، قد يتعرض العملاء الذين يستخدمون نظام يحتوي Microsoft net Framework 4, 6 مثبتة والذين قم بتطبيق تحديثات الأمان 3098779 و 3097997 ل Microsoft. net Framework 4.5.1 و 4.5.2 على ويندوز 8.1 Windows RT 8.1 و Windows Server 2012 R2 مشكلات عند تشغيل تطبيقات NET Framework.

ملاحظة: أنظمة تشغيل أقدم NET Framework 4.5.1 أو 4.5.2 مثبتاً لديك لا تتأثر بهذه المشكلة لأن تحديثات الأمان 3098779 و 3097997 لا تنطبق عليها.
الأعراض

السيناريو 1

  • يتم استخدام NET Framework 4.5.1 أو 4.5.2 على Windows 8.1 أو Windows RT 8.1 أو Windows Server 2012 R2.
  • قمت بتثبيت كافة تحديثات ل NET Framework 4.5.1 و 4.5.2. ويتضمن ذلك التحديثات 3098779 و 3097997.
  • تنزيل وتثبيت NET Framework 4, 6 أو يمكنك تثبيت Microsoft Visual Studio عام 2015.
في هذا السيناريو، لا تتم ترقية بعض مكونات 4-6 ب. NET Framework كما هو متوقع، أو لا تقم بتشغيل بعض تطبيقات NET Framework أو لا تعمل بشكل صحيح.

السيناريو 2

  • استخدام 4, 6 ب. NET Framework على Windows 8.1 أو Windows RT 8.1 أو Windows Server 2012 R2.
  • تطبيق التحديثات يدوياً 3098779 و 3097997 أو أي تحديث آخر غير مخصص ". NET Framework 4, 6"، على الرغم من أن هذه التحديثات تستهدف NET Framework 4.5.1 و 4.5.2.

    ملاحظة:وهذا سيناريو غير معتمد. لمزيد من المعلومات حول كيفية تحديد التطبيق الصحيح لتحديث Microsoft NET Framework، راجع مقالة قاعدة معارف Microsoft 3136092.
في هذا السيناريو، لا يتم تشغيل بعض تطبيقات NET Framework أو لا تعمل بشكل صحيح.
الحل

حل السيناريو 1

العملاء حل هذه المشكلات قبل الترقية إلى NET Framework 4.6.1 من مواقع "مركز تحميل microsoft" التالية على الويب:

بدلاً من ذلك، يمكنك إزالة العملاء تثبيت تحديثات 3098779 و 3097997 إذا قاموا بتثبيت Visual Studio 2015 من محدثاً بشكل كامل. NET 4.5.1 أو 4.5.2 نظام يحتوي التحديثات 3098779 و 3097997 تثبيت أو ترقية أنظمتهم إلى 4, 6 ب. NET Framework.

العملاء ثم إعادة فحص Windows Update وتنزيل وتثبيت التحديثات 3098785 و 3098000. هذه هي المقابل نشرة أمان Microsoft MS15-118 تحديثات ل 4.6 Framework. NET في ويندوز 8.1 أو Windows RT 8.1 أو Windows Server 2012 R2. سيتم تصحيح هذا الإجراء عدم تطابق الإصدار.

حل السيناريو 2

يجب أن تكون على علم بأن هذا ليس سيناريو معتمداً العملاء الذين قاموا بتطبيق التحديثات 3098779 و 3097997 على الأنظمة التي تحتوي 4.6. NET Framework تثبيت يدوياً. لا تنطبق هذه التحديثات إلى 4, 6 ب. NET Framework.

ولذلك، عليك إلغاء تثبيت العملاء الذين يستخدمون 4, 6 ب. NET Framework التحديثات 3098779 و 3097997. ثم يجب إعادة فحص Windows Update العملاء وتثبيت هذه التحديثات التي تنطبق 4.6. NET Framework. سيتم تصحيح هذا الإجراء عدم تطابق الإصدار.

وبالمثل، العملاء الذين يستخدمون. NET 4.5.1 أو 4.5.2 يجب التأكد من وجود أية تحديثات قابلة للتطبيق على أي إصدار NET Framework مثبت على الأنظمة الخاصة بهم. على سبيل المثال، يجب عدم تطبيق التحديثات التي تهدف 4.6. NET Framework لأنظمة صافي تثبيت 4.5.2 أو 4.5.1. لمزيد من المعلومات حول كيف يتم على التطبيق الصحيح لتحديثات Microsoft net Framework 4-6 و 4.6.1، سيميكروسوفتكنووليدجي مقالة قاعدة تحديد 3136092.
تصريح
أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في قسم "ينطبق على".

تطبيق على

تنطبق هذه المادة على ما يلي:

  • Microsoft net Framework 4, 6 عند استخدامها مع:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft NET Framework 4.5.2 عند استخدامها مع:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft NET Framework 4.5.1 عند استخدامها مع:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 3118750 - آخر مراجعة: 01/15/2016 01:10:00 - المراجعة: 4.0

Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.5.1

  • atdownload kbbug kbexpertiseinter kbfix kbsecbulletin kbsecurity kbsecvulnerability kbmt KB3118750 KbMtar
تعليقات