Симптоми
В Microsoft Exchange Server 2019 или Exchange Server 2016 предполага, че сте задали уеб прокси сървър Exchange Server използва за връзка към интернет чрез параметъра InternetWebProxy и няма пряк достъп до интернет. Можете да изпитате, че OAuth връзка винаги е неуспешно, ако я проверите с помощта на Тест-OAuthConnectivity cmdlet, дори и ако връзката работи добре.
Причина
Този проблем възниква, защото Тест-OAuthConnectivity cmdlet не спазва InternetWebProxy настройките на сървъра на Exchange. Следователно ако Exchange Server е блокиран за свързване към интернет директно, правилно няма да тествате OAuth връзка.
Статус
Microsoft потвърждава, че това е проблем в продуктите на Microsoft, изброени в раздела "Отнася се за".
Решение
За да решите този проблем, инсталирайте една от следните актуализации:За Exchange Server 2019 инсталиране на сборна актуализация 1 за Exchange Server 2019 или по-късно сборна актуализацияза Exchange Server 2019.
За Exchange Server 2016 инсталиране на сборна актуализация 12 за Exchange Server 2016 или по-късно сборна актуализация за Exchange Server 2016.
Препратки
Научете повече за терминологията, използвана за описание на софтуерните актуализации от Microsoft.