ПРОБЛЕМ
Когато добавяте акаунт за Outlook за Microsoft 365 чрез домейн по избор или акаунт за Outlook.com с персонализиран имейл адрес, получавате следната грешка:
ПРИЧИНА
Този проблем възниква, тъй като процесът на автоматично откриване, който се използва от Outlook, получи неочакван резултат от уеб сървър на друг доставчик, когато извършва търсене в главния домейн. Например Outlook може да получи резултат, като например https://<RootDomain>/AutoDiscover/AutoDiscover.xml.
Обикновено търсенето на главни домейни ще е неуспешно в този случай и Outlook ще извърши търсене за автоматично откриване срещу https://AutoDiscover. <RootDomain>/AutoDiscover/AutoDiscover.xml. Въпреки това, тъй като Outlook получава успешно автоматично откриване на отговор от главния домейн, Outlook се опитва да удостовери самоличността си по отношение на рекламираните протоколи, като например POP и IMAP, и операцията е неуспешна.
РЕШЕНИЕ
Свържете се с доставчика на уеб услугата или доставчика на уеб хостинг на вашия уеб сайт за домейни и се уверете, че уеб сървърът не отговаря на заявките за автоматично откриване.
ЗАОБИКОЛНО РЕШЕНИЕ
За да заобиколите този проблем, ако доставчикът на уеб услуга или доставчикът на уеб хостинг не е в състояние да го реши, предприемете следните действия:
-
Създайте Outlook ключове от системния регистър, за да изключите последните известни добри настройки, основния домейн на HTTPS и SRV записа, както е описано по-долу. След като записите в системния регистър бъдат въведени, рестартирайте Outlook и опитайте да добавите акаунта или създайте нов профил отново.
-
Използвайте ExcludeLastKnownGoodUrl , за да попречите на Outlook да използва последното известно добро автоматично откриване на URL адрес
HKEY_CURRENT_USER \Software\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD: ExcludeLastKnownGoodUrl
Value: 1
ИЛИ
HKEY_CURRENT_USER \Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD: ExcludeLastKnownGoodUrl
Value: 1 -
Използвайте ExcludeHttpsRootDomain , за да не позволите на Outlook да използва основния домейн
за HTTPS HKEY_CURRENT_USER \Software\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD: ExcludeHttpsRootDomain
Value: 1
ИЛИ
HKEY_CURRENT_USER \Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD: ExcludeHttpsRootDomain
Value: 1 -
Използвайте ExcludeSrvRecord , за да не позволите на Outlook да използва основния домейн
за HTTPS HKEY_CURRENT_USER \Software\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD: ExcludeSrvRecord
Value: 1
ИЛИ
HKEY_CURRENT_USER \Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
DWORD: ExcludeSrvRecord
Value: 1
-
Забележки:
-
Държачът x. 0 представлява вашата версия на Office (16,0 = Office 2016, Office 365 и Office 2019, 15,0 = Office 2013).
-
Когато стойността за ExcludeLastKnownGoodUrl е зададена на 1, Outlook не използва последното известно работно URL за автоматично откриване.
Важно: Изключването на основния домейн на HTTPS не е дългосрочно решение за този проблем и не го препоръчваме. Тези заобиколни решения се предоставят като незабавно облекчение за проблема. Веднага щом доставчикът на уеб услугата или доставчикът на уеб хостинг реши проблема, трябва да бъде премахнат ключът от системния регистър на Outlook.
За повече информация относно настройките за автоматично откриване и настройки на системния регистър вижте неочаквано поведение на автоматичното откриване, когато имате настройки на системния регистър под ключа \Autodiscover.