Симптом
Когато се опитате да отворите страницата на Project център в бизнес портала в Microsoft Dynamics GP, получавате следното съобщение за грешка:
Не разполагате с потребителски запис в Keeper за лични данни. Обърнете се към вашия GP администратор на Microsoft Dynamics за съдействие
Причина
Този проблем има няколко различни причини:
-
Неправилен служител е свързан с потребителя Keeper за лични данни (PDK).
-
Неправилен служител е свързан с потребителя на бизнес портала.
-
ИД на фирмата е променено в PDK40001 след скорошна надстройка, сервизен пакет или създаване на база данни Test.
Решение
1. За да се уверите, че правилният ИД на служител е свързан с потребителя на PDK, влезте в Keeper за лични данни като "sa". В раздела Настройка щракнете върху Система и след това щракнете върху Потребител. В прозореца Настройка на потребител на PDK въведете ИД на потребител и фирма за потребителя, който получава грешката. Проверете дали стойността в полето "ИД на служител" е правилна. Ако е неправилен, изтрийте потребителя на PDK и го създайте отново, като използвате правилния ИД на служителя.
2. За да проверите дали правилният ИД на служител е свързан с потребителя на бизнес портала, обърнете внимание на ИД на служителя, намерен в Решение 1. След това изпълнете следните стъпки:
a. Влезте в бизнес портала (BP) с потребител, който е администратор на BP.
б. От началната страница на BP щракнете върху Действия на сайта, след което изберете Настройки.
Забележка Ако използвате BP 5.1, тогава за достъп до раздела Разширени роли отидете на Сайт Настройки за уеб сайта на бизнес портала от най-високо ниво и след това щракнете върху Администриране на бизнес портал.
в. Под секцията Администриране на бизнес портал щракнете върху Потребители.
г. В списъка с потребители намерете потребителя, който изпитва проблема, и щракнете върху потребителя.
д. В секцията Потребителски свойства щракнете върху раздела Роли.
е. В списъка с роли намерете реда, който чете Служител – ИД на служител – "вашата фирма".
ж. Съответства ли точно стойността в ИД на служителя това, което е видяно в Решение 1? Трябва да го направи.
з. Ако не, щракнете върху Промяна, за да отворите прозореца Промяна на портала и Разширени роли.
i. В долния раздел, където се казва Роля/Фирма, използвайте падащото меню, за да намерите "Служител/вашата фирма"
j. След като служителите попълват прозореца за превъртане, изберете ИД на служителя, който е идентифициран в Решение 1.
k. Щракнете върху OK и нека потребителят на BP изпробва отново своя график.
3. Проверете дали полето CMPNYNAM в PDK40001 е правилната CMPANYID. CMPANYID и CMPNYNAM трябва да изглеждат по същия начин в PDK40001, както в SY01500.
Въведете името на фирмата на мястото на XXXXX.
изберете CMPANYID, CMPNYNAM, * от PDK40001, където CMPNYNAM = "XXXXX" изберете
CMPANYID, CMPNYNAM, * от SY01500, където CMPNYNAM = "XXXXX" Ако те не съвпадат, променете
CMPANYID в PDK40001 на правилния ИД с помощта на инструмент за заявки на SQL.
Забележка Създайте възстановимо архивиране, преди да изпълните всички команди за актуализиране в базата данни.
По-долу е пример за команда за актуализация, която може да се използва:
актуализирайте PDK40001 set CMPANYID = "YYYYY", където CMPNYNAM = XXXXX бележка въвежда името на фирмата на мястото на XXXXX и ИД на
фирма от SY01500 за ГГГГГГ.