Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Когато се опитате да стартирате една от игрите на Microsoft, които са изброени в раздела "важи за", ще получите едно от следните съобщения за грешка:

Съобщение за грешка 1

Файлът d3dx9_25. dll не е намерен

Съобщение за грешка 2

Файлът d3dx9_27. dll не е намерен

Причина

Този проблем може да възникне, ако файлът на Microsoft DirectX, споменат в съобщението за грешка, е повреден или не е копиран правилно.

Решение

Изтеглете и след това инсталирайте най-новата версия на DirectX

За да отстраните този проблем, изтеглете и инсталирайте най-новата версия на уеб инсталиращата програма на DirectX за крайни потребители. За целта посетете следния уеб сайт на Microsoft:

http://www.microsoft.com/download/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en Забележка При инсталирането може да получите следното съобщение за грешка:

Софтуерът, който инсталирате, не е преминал проверката на емблемата на Windows, за да се провери съвместимостта му с тази версия на Windows. (Обяснете ми защо това изследване е важно.)

За допълнителна информация щракнете върху следния номер на статия, за да прегледате статията в базата знания на Microsoft:

822798 Не можете да инсталирате някои актуализации или програми  

Ръчно копиране на файла

За да отстраните този проблем, копирайте файла D3dx9_25. dll или D3dx9_27. dll от диск 1 CD/DVD диск на играта CD/DVD пакета в съответната папка на играта. За да направите това, следвайте подходящите стъпки за вашата версия на Windows:

Windows 7 или Windows Vista

  1. Поставете диск 1 CD/DVD диск за играта си в CD/DVD устройството на компютъра.

  2. Щракнете върху " Стартwindows iconи след това щракнете върху документи.

  3. Намерете и след това щракнете върху компютър.

  4. Намерете и след това щракнете върху CD/DVD устройството.

  5. Намерете и след това щракнете върху следната папка:

    CDDrive:\ DirectX9 Забележка В този път CDDriveпредставлява буквата на устройството на CD устройството.

  6. Щракнете двукратно върху Apr2005_d3dx9_25_x86. cab, щракнете с десния бутон върху d3dx9_25. dllи след това щракнете върху Копирай.

    Забележка Използвайте Apr2005_d3dx9_25_x64. cab файла за x64-базираната версия на операционната система Windows.

  7. Намерете следната папка за вашата игра:

    Диск: се намира файлове \ Microsoft Games \заглавие на играта Забележка В този път дискпредставлява буквата на устройството, на която е инсталирана играта, а заглавието на играта представлява играта, която искате да поправите.

  8. Щракнете с десния бутон върху папката на играта, която съответства на играта, която е инсталирана на компютъра, и след това щракнете върху постави. Забележка Ако сте инсталирали повече от един мач на компютъра, повторете стъпки 7and 8 за другите игри.

Windows XP

  1. Поставете диск 1 CD/DVD диск за играта си в CD/DVD устройството на компютъра.

  2. Щракнете върху Старт, посочете програми, посочете принадлежностии след това щракнете върху Windows Explorer.

  3. Намерете и след това щракнете върху следната папка:

    CDDrive:\ DirectX9 Забележка В този път CDDriveпредставлява буквата на устройството на CD устройството.

  4. Щракнете двукратно върху Apr2005_d3dx9_25_x86. cab, щракнете с десния бутон върху d3dx9_25. dllи след това щракнете върху Копирай.

    Забележка Използвайте Apr2005_d3dx9_25_x64. cab файла за x64-базираната версия на операционната система Microsoft Windows.

  5. Намерете следната папка за вашата игра:

    Диск: се намира файлове \ Microsoft Games \заглавие на играта

    Забележка В този път диск представлява буквата на устройството, на което е инсталирана играта, а заглавието на играта представлява играта, която искате да поправите.

  6. Щракнете с десния бутон върху папката на играта, която съответства на играта, която е инсталирана на компютъра, и след това щракнете върху постави. Забележка Ако сте инсталирали повече от един мач на компютъра, повторете стъпки 5 и 6 за другите игри.

Следващи стъпки

Ако имате нужда от още помощ, посетете уеб сайта за услуги за поддръжка на клиенти на Microsoft, за да намерите други решения. Този уеб сайт предоставя следните услуги:

  • Общност на Microsoft (http://Answers.Microsoft.com/EN-US/Windows/Default.aspx): взаимодействие с връстници и с най-ценните професионалисти в Microsoft (най-ценни).

  • Центрове за решения (http://support.Microsoft.com/Select/?TARGET=Hub): Преглед на често задавани въпроси за конкретен продукт (ЧЗВ) и основни моменти от поддръжката.

  • База знания за търсене (http://support.Microsoft.com/Search/?ADV=1): Потърсете информация за техническата поддръжка и инструменти за самостоятелна помощ за продуктите на Microsoft.

  • Други опции за поддръжка (http://support.Microsoft.com/Default.aspx?PR=csshome): Използвайте уеб, за да зададете въпрос, да се свържете с услугите за поддръжка на клиенти на Microsoft или да предоставите обратна връзка.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×