Департамент полето в картата за контакт на потребителя е празна, когато картата се извлича от приложението UCMA 3.0

Работете навсякъде от всяко устройство с Microsoft 365

Надстройте до Microsoft 365, за да работите навсякъде с най-новите функции и актуализации.

Надстройване сега

Симптоми

Да разгледаме следния сценарий:

  • Разработване на приложение чрез Microsoft единни комуникации управляван API 3.0 (UCMA 3.0) в Microsoft Lync Server 2010.

  • Приложението използва RemotePresenceView клас или свойството LocalEndpoint.PresenceServices да извлече визитки.

  • Приложението се опитва да извлече картата за контакт на потребителя. Отдел информацията на потребителя е конфигурирано в Active Directory.

В този случай полето отдел на картата е празна.

Причина

Този проблем възниква, защото полето отдел не е включен в XML формат резултат, който се връща към приложението UCMA 3.0.

Решение

За да разрешите този проблем, инсталирайте следния сборен:

описание на сборната актуализация за Lync 2010: февруари 2012 г.

Допълнителна информация

За повече информация относно RemotePresenceView клас посетете следния уеб сайт на Microsoft:

За повече информация за свойството LocalEndpoint.PresenceServices посетете следния уеб сайт на Microsoft:

Нуждаете се от още помощ?

Разширете уменията си
Преглед на обучението
Получавайте първи новите функции
Присъединете се към Microsoft приобщени

Беше ли полезна тази информация?

Благодарим ви за обратната връзка!

Благодарим ви за вашата обратна връзка. Изглежда, че ще бъде полезно да ви свържем с един от нашите агенти по поддръжката на Office.

×