Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Когато се опитате да добавите нови потребители към бизнес портала, домейнът може да не е в списъка.

Причина

Бизнес порталът няма достъп до домейновия контролер.

Решение

Уверете се, че можете да ping домейновия контролер за домейна, който не е посочен в бизнес портала. Използвайте командата ping на сървъра, на който се изпълнява бизнес портал. Уверете се, че можете да ping по името му NetBios.

За да използвате командата ping, изпълнете следните стъпки на сървъра, на който се изпълнява бизнес портал:

  1. Щракнете върху Старт, щракнете върхуИзпълнение , въведете cmd и след това щракнете върху OK.

  2. За да ping по име, изпълнете следните стъпки:

    1. Въведете следната команда:

      ping SERVERNAMENote Замести SERVERNAME с името на домейновия контролер.

    2. Натиснете КЛАВИША ENTER.

Заобиколно решение

Ако използвате microsoft Business Portal 2.0, Microsoft Business Portal 2.5 или Microsoft Business Portal 2.5 Feature Pack (Business Portal 2.7), използвайте метод 1. Ако изпълнявате бизнес портал 3.0, използвайте метод 2.

Метод 1: Използвайте помощната програма за настройка на защитата, за да добавите потребителите от домейна, който не е посочен в бизнес портала

За да изпълните помощната програма за настройка на защитата, изпълнете следните стъпки:

  1. Намерете папката с клетки на уеб сайта, в който е инсталиран бизнес порталът. По подразбиране това се намира в C:\Inetpub\wwwroot\bin.

  2. Щракнете двукратно върху SecuritySetupUtility.exe.
    Забележка За да изпълните тази помощна програма, трябва да влезете в сървъра като лицето, инсталирало бизнес портала.

Метод 2: Ръчно добавяне на запис към BusinessFramework.config файл

  1. В Windows Explorer намерете BusinessFramework.config файл. По подразбиране този файл се намира в C:\Inetpub\wwwroot\bin.

  2. Отворете файла с помощта на текстов редактор, като Notepad.

  3. Добавете следния запис към файла:

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True”/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>


    Ето част от това как трябва да изглежда файлът, след като добавите записа:

    <Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>
    <directoryList type="String" value="/sites/BusinessPortal/|/BusinessPortal/"/>
    </Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True"/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>

Повече информация

Стъпки за възпроизвеждане на проблема

  1. Стартирайте бизнес портала.

  2. Щракнете върху Сайт Настройки, щракнете върху Потребители и разрешения, щракнете върху Управление на потребители на бизнес портали след това щракнете върху Добавяне на нови потребители.

  3. В прозореца Добавяне на потребители щракнете върху Напред.

В списъка Домейн не е посочен домейн или някои домейни не са в списъка.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×