Симптоми
Да разгледаме следния сценарий:
-
Достъп до пощенска кутия с помощта на Microsoft Outlook в онлайн режим в среда на Microsoft Exchange Server 2010.
-
Поне едно правило се прилага в папката Входящи в пощенската кутия.
-
Опитвате се да копирате папката Входящи в целевата папка в пощенската кутия.
При този сценарий получавате следното съобщение за грешка:
Не може да премествате или копирате папки. Не може да копира папката. Папка не може да се копират в някоя от нейните подпапки. Или може да нямате необходимите разрешения за папка. За да проверите вашите разрешения за папката, с десния бутон върху папката и изберете свойства от контекстното меню.
Освен това услугата Microsoft Exchange RPC клиентски достъп се срива на Exchange Server 2010 сървъра. В този случай следните събития са регистрирани в регистрационния файл за събития на Exchange Server 2010 сървъра:
Влизане име: система
Източник: Диспечерът за управление на услуги
Дата: Дата
ИД на събитие: 7031
Категория на задача: няма
Ниво: грешка
Ключови думи: класически
Потребител: няма данни
Компютър: компютъра
Описание: Услугата Microsoft Exchange RPC клиент достъп прекратява неочаквано. Той е направил този 1 път. Следните коригиращ действия ще бъдат предприети в 5000 милисекунди: рестартиране на услугата.
Име за вписване: Приложение
Източник: MSExchange общ
Дата: Дата
ИД на събитие: 4999
Категория на задача: общи
Ниво: грешка
Ключови думи: класически
Потребител: няма данни
Компютър: компютъра
Описание: Уотсън отчети да се изпращат за идентификатор на процес: Процес ID, параметри: E12 компилация типверсия, M.E.RpcClientAccess.Service, M.E.Data.Storage, M.E.D.S.CoreObject.ProcessCopyPropertyProblems, System.IndexOutOfRangeException, XXXX, версия.
Причина
Този проблем възниква, защото достъпът е отказан, грешка възниква, когато услугата за клиентски достъп remote procedure call (RPC) се опитва да копирате свойството правило размера на папката "Входящи" в целевата папка. В тази ситуация услугата RPC клиентски достъп не поддържа грешката правилно и се срива.
Решение
За да разрешите този проблем, инсталирайте следния Сборен пакет за актуализация:
2661854 описание на сборния пакет за актуализация 2 за Exchange Server 2010 Service Pack 2
Заобикаляне на проблема
За да заобиколите този проблем, използвайте един от следните методи:
Метод 1
Експортиране на папка "Входящи" .pst файл и след това импортирате .pst файла в целевата папка.
Метод 2
Отворете Outlook в кеширан режим и след това копирайте папката Входящи целевата папка.
Статус
Microsoft потвърждава, че това е проблем в продуктите на Microsoft, изброени в раздела "Отнася се за".