Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Важно: Тази статия съдържа информация, която ви показва как да понижите настройките за защита или как да изключите функциите за защитата на компютъра. Можете да направите тези промени, за да заобиколите конкретен проблем. Преди да направите тези промени, ви препоръчваме да прецените рисковете, свързани с изпълнението на това решение във вашата конкретна среда. Ако решите да реализирате заобиколно решение, вземете подходящи допълнителни мерки за защита на компютъра.

Симптоми

Опитвате се да получите достъп до споделена папка, която се намира на компютър, базиран на Windows 98 от компютър с Windows 7 или Windows 2000. Трябва да предоставите потребителско име и парола. Обаче удостоверяването е неуспешно. Следователно няма достъп до споделената папка.

Забележка: Този проблем не възниква, ако имате достъп до споделената папка от компютър, работещ под Windows XP или Windows Vista.

Причина

Windows 7 използва NTLM версия 2 (NTLMv2) удостоверяване. По подразбиране NTLMv2 удостоверяване не е разрешен в Windows 2000 или Windows 98. Следователно този проблем възниква.

Решение

Предупреждение Неправилното модифициране на системния регистър с помощта на редактора на системния регистър или по друг начин може да доведе до възникване на сериозни проблеми. Тези проблеми могат да наложат преинсталиране на операционната система. Microsoft не гарантира, че тези проблеми могат да бъдат разрешени. Вие поемате риска при модифициране на системния регистър.

За да разрешите този проблем, разрешете NTLMv2 удостоверяване на Windows 2000 или Windows 98 компютър. За да направите това, изпълнете следните стъпки:

  1. Стартирайте редактора на системния регистър. За да направите това, щракнете върху Старт, щракнете върху изпълнение, въведете Regeditи натиснете ENTER.

  2. Намерете и щракнете върху следния подключ в системния регистър:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA

  3. Намерете стойността от системния регистър LmCompatibilityLevel .



    Ако стойността в системния регистър не е налично, следвайте тези стъпки, за да го създадете:

    1. Изберете подключа на системния регистър, посочен в стъпка 2.

    2. В менюто Редактиране посочете Създайи след това щракнете върху DWORD стойност.

    3. Въведете LmCompatibilityLevelи след това натиснете ENTER.

  4. Задайте DWORD стойността на 1. За да направите това, щракнете върху Промяна в менюто Редактиране , въведете 1 в полето Value data и щракнете върху OK.

  5. Затворете редактора на системния регистър и рестартирайте компютъра.

За повече информация как да разрешите NTLMv2 удостоверяване, щракнете върху следния номер на статия в базата знания на Microsoft:

239869 как да активирате NTLM 2 автентификация


Забележка: Samba 2.x поддържа NTLMv2 удостоверяване. Следователно може да срещнете подобни проблеми при опит за достъп до споделени папки, които се намират в Samba системи от компютър с Windows 7. За да заобиколите този проблем, следвайте тези стъпки на компютър, базиран на Windows 7:

  1. Стартирайте редактора на системния регистър. За да направите това, щракнете върху Старт Start button , въведете Regedit в полето за Търсене на програми и файлове , и след това натиснете ENTER.

  2. Намерете и щракнете върху следния подключ в системния регистър:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA

  3. Намерете стойността от системния регистър LmCompatibilityLevel .



    Ако стойността в системния регистър не е налично, следвайте тези стъпки, за да го създадете:

    1. Изберете подключа на системния регистър, посочен в стъпка 2.

    2. В менюто Редактиране посочете Създайи след това щракнете върху DWORD стойност.

    3. Въведете LmCompatibilityLevelи след това натиснете ENTER.

  4. Задайте DWORD стойността на 1. За да направите това, щракнете върху Промяна в менюто Редактиране , въведете 1 в полето Value data и щракнете върху OK.

  5. Затворете редактора на системния регистър и рестартирайте компютъра.

Предупреждение Това решение може да направи компютъра или мрежата по-уязвими за атаки от злонамерени потребители или злонамерен софтуер, например вируси. Ние не препоръчваме тези промени, но предоставяме тази информация, за да изпълните това решение по своя преценка. Използвайте това решение на свой собствен риск.

НУЖДА ОТ ОЩЕ ПОМОЩ?

Ако тази статия не отговаря на въпроса ви, щракнете върху този бутон, за да поставите въпроса на други членове на Общността в Microsoft Answers:

Задайте въпрос


Ако искате да видите отговорите на подобни проблеми, щракнете върху следните връзки, за да прегледате темите във форума за отговори от Microsoft:


Препратки

Продуктите на други разработчици, които се обсъждат в тази статия, са произведени от фирми, независими от Microsoft. Microsoft не дава никакви гаранции, подразбиращи се или от друго естество, за производителността или надеждността на тези продукти.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×